СПИ Юпитер 6.0

Содержание

  1. Введение
  2. Общие сведения о функционировании системы
    • 2.1. Типы аппаратуры, устройства и их назначение
    • 2.2. Ручные и автоматические объекты, различия тактики охраны
    • 2.3. Структура программного обеспечения пульта
    • 2.4. Сообщения и состояния объектов
  3. Интерфейсная программа АСЦН Юпитер
    • 3.1. Элементы интерфейса и правила ввода данных
    • 3.2. Загрузка интерфейсной программы
    • 3.3. Смена пользователя пульта
    • 3.4. Основной экран интерфейсной программы
    • 3.5. Окно текущих сообщений
    • 3.6. Окно необработанных тревог
    • 3.7. Карточка устройства в БД
    • 3.8. Журналы системы
    • 3.9. Панель объектов
  4. Изменение конфигурации устройств
    • 4.1. Операции с линией КПЦО ("АТС")
    • 4.2. Операции с УТ
    • 4.3. Операции с конфигурацией устройств АК
      • 4.3.1. Конфигурация АК Комета
        • 4.3.1.1. Конфигурация ГК Комета
        • 4.3.1.2. Конфигурация ИО Комета
      • 4.3.2. Конфигурация АК Центр и Атлас
      • 4.3.3. Конфигурация АК Юпитер
        • 4.3.3.1 Настройка шлейфов
        • 4.3.3.2 Настройка пользователей АК-24 и УОО-5
        • 4.3.3.3 Настройка таблицы охраны и связанных ключей
        • 4.3.3.4 Особенности АК Юпитер, связанные с настройками
        • 4.3.3.5 Конфигурирование ПОИСК и ППКОП «Юпитер 5П».
        • 4.3.3.6 Настройка параметров расширителей ПОИСК
        • 4.3.3.7 Настройка параметров разделов ПОИСК и ППКОП «Юпитер 5П»
        • 4.3.3.8 Настройка таблицы пользователей ПОИСК
        • 4.3.3.9 Настройка таблицы пользователей ППКОП «Юпитер 5П»
    • 4.4. Перенос данных между УТ
    • 4.5. Конфигурирование системы радиоохраны "СТРУНА" и "СТРУНА-3M"
    • 4.6. Особенности настройки ПОИСК по цифровым линиям.
  5. Процесс охраны объектов в системе
    • 5.1. Охрана "автоматических" объектов
      • 5.1.1. АК Комета
      • 5.1.2. АК Юпитер
    • 5.2. Охрана "ручных" объектов
      • 5.2.1. Карточка "ручного" объекта
      • 5.2.2. Постановка "ручного" объекта на охрану
        • 5.2.2.1. Постановка на охрану объекта типа Центр
        • 5.2.2.2. Постановка на охрану объекта типа АТЛАС
      • 5.2.3. Снятие "ручных" объектов с охраны
      • 5.2.4. Смена режима охраны объекта (Различия с DOS версией)
      • 5.2.5. Пароли для ручных объектов
    • 5.3. Процедуры перевзятия и опроса
    • 5.4. Проверка приборов ОПС объекта
    • 5.5. Команды ПОИСК
  6. Анализ лент сообщений
    • 6.1. Архив сообщений системы
    • 6.2. Синтезированные ключи устройств в сообщениях
    • 6.2. “Уплывание” ответчика Комета
  7. Настройка интерфейсной программы
    • 7.1. Установка путей размещения файлов программы
    • 7.2. Установка параметров печати
    • 7.3. Установка таймеров программы
    • 7.4. Настройка звуков
    • 7.5. Настройка БД
    • 7.6. Установка паролей
    • 7.7. Настройка сообщений
    • 7.8. Настройка причин тревог
    • 7.9. Настройка примечаний
    • 7.10. Настройка сети
    • 7.11. Настройка вывода звука через звуковую карту
  8. Установка и настройка ПО
    • 8.1. Установка ПО пульта
    • 8.2. Конвертор конфигурации СПИ Юпитер
    • 8.3. Описание файлов СПИ Юпитер 6.0
    • 8.4. Настройка файлов конфигурации системы
  9. Совместная работа СПИ Юпитер с пограммой Балтика
    • 9.1. Балтика DOS-версии
    • 9.2. Балтика Windows-версии
  10. Подготовка резервного компьютера
  11. Замена неисправного компьютера на резервный
  12. Настройка сетевой версии СПИ Юпитер
    • 12.1. Особенности работы клиент-серверного ПО СПИ Юпитер
    • 12.2. Установка протокола TCP/IP
    • 12.3. Настройка сервера СПИ Юпитер
    • 12.4. Настройка клиента СПИ Юпитер
  13. Расшифровка таблицы сообщений СПИ Юпитер 6.0
  14. Список изменений и дополнений СПИ Юпитер 6.0

Все рекомендации, предложения и ошибки программы мы принимаем:
Тел.: 8 (812) 350-5424
Факс: 8 (812) 352-5728
E-mail: elesta@elesta.ru, alex@elesta.ru
HTTP: www.elesta.ru


Типы аппаратуры, устройства и их назначение

2.1. Типы аппаратуры, устройства и их назначение

АСЦН Юпитер можно разделить на аппаратную и программную части. Аппаратная часть системы см. рис. 1 состоит из устройств передачи данных трех уровней: пультового, станционного, абонентского. Каждое устройство контролирует несколько подчиненных. Контроль подразумевает получение информации с подчиненных устройств и передачу на них команд от вышестоящего устройства. Исправность любого устройства всегда определяется его вышестоящим устройством.

На пульте охраны используется до двух коммутаторов пульта централизованной охраны, далее КПЦО, на каждый компьютер. КПЦО имеет 4 выхода для подключения телефонных линий связи, по которым он получает данные со станционных устройств. КПЦО подключается к компьютеру через стандартный кабель RS-232.

Станционные устройства называются устройствами трансляции, далее УТ. Всего к КПЦО может быть подключено до 64 УТ (до 16 УТ на каждую из 4 линий). Группы УТ одной линии КПЦО обычно располагаются в одном из помещений телефонной станции. Иногда несколько групп УТ, подсоединенных к одной линии КПЦО могут располагаться на нескольких станциях. При этом один из УТ на ближайшей к пульту станции используется в качестве ретранслятора сигналов для дальних станций. В канал связи КПЦО-УТ могут быть включены устройства преобразования канала в/из протокол RS-232, для использования цифровых каналов связи. Подробнее о подключении УТ можно узнать из документации по УТ.

УТ типов Комета, Атлас и Юпитер являются одним и тем же устройством и различаются лишь программой, записанной в ПЗУ. УТ Центр отличается от других типов УТ. Типом УТ определяется состав и количество подключенных к нему абонентских устройств. Используемые в АСЦН Юпитер УТ поддерживают работу со следующими типами абонентских комплектов (АК) аппаратуры: Комета, Атлас, Центр, Юпитер. В последнем случае Юпитер - это название устройств абонентского комплекта. Устройства абонентского комплекта находятся непосредственно на охраняемом объекте. Для связи с УТ используется телефонная линия клиента или одного из нескольких клиентов. Охранные датчики устройств АК называются шлейфами. Точнее, шлейфом называют обычно любую пару проводов, но в данном случае под шлейфом имеют в виду шлейф датчика.

АК Юпитер состоит из базового блока (ББ), который имеет 3 линии для подключения ИО Юпитер. ББ оборудован датчиком взлома корпуса и имеет источник бесперебойного питания, который позволяет при сбоях основного питания обеспечивать работоспособность блока в течение 4 часов.

На линию ББ может быть подключено до 8 ИО, и т.о. всего до 24 ИО на блок. Обмен данными между ББ и ИО осуществляется в виде кодированных цифровых пакетов, что значительно затруднит имитацию ИО или сообщений с него. ИО имеет устройство взятия-снятия, предназначенное для считывания кодового брелка при взятии и снятии объекта с охраны.

Линии ББ могут использоваться и в качестве шлейфов, если ББ устанавливается непосредственно на объект. Также, в перспективе, возможно подключение параллельных расширителей. Тогда на линию ББ можно будет использовать до 8 шлейфов расширителя.

Из всех АК, используемых в АСЦН Юпитер, устройства АК Юпитер являются наиболее надежными и защищенными.

Абонентский комплект Комета состоит из группового концентратора (далее ГК) и индивидуальных ответчиков (далее ИО). К УТ Комета может быть подключено до 20 ГК Комета, к ГК может подключаться до 8 ИО. Таким образом, на один УТ Комета может приходиться до 160 охраняемых объектов. ГК Комета имеет датчик взлома корпуса и выключатель для отметки прибытия патруля на объект. В ИО Комета есть УВС, представляющий собой 2 переключателя для ввода числового кода.

АК Комета в том виде, в каком он описан выше, в настоящее время уже снят с производства. На смену ему разработана модификация АК Юпитер на основе ББ Юпитер, к которому может быть подключено до 8 ответчиков Юпитер.

АК Центр и Атлас состоят только из ответчиков, которые непосредственно подключаются к линии связи с УТ. Ответчик Атлас был выпущен в нескольких модификациях. Одна из последних - Атлас-Ю3, имеет аккумулятор, позволяющий сохранять работоспособность устройства в течение 2-х часов, при отключении основного питания.


Ручные и автоматические объекты, различия тактики охраны

2.2. Ручные и автоматические объекты, различия тактики охраны

Объекты с аппаратурой Комета и Юпитер относятся к так называемым автоматическим объектам. Объекты Атлас и Центр - к объектам с ручной тактикой охраны.

Работа системы с автоматическими объектами не требует вмешательства оператора при постановке и снятии объектов с охраны. Все действия по взятию/снятию объекта выполняются самим клиентом на объекте, аппаратура которого (устройство взятия-снятия (УВС) ответчика) позволяет выполнить такие действия. В ИО Комета для этих целей имеются переключатели для набора кода, а в ИО Юпитер - считыватель кодового брелка. Постановка/снятие объекта с охраны фиксируется в ГК или ББ, о чем и выдается соответствующее сообщение для УТ.

Аппаратура объекта с ручной тактикой охраны не имеет УВС и может только контролировать состояние охраняемого шлейфа (шлейфов) и сообщать о его состоянии УТ. Взятие/снятие объекта с ответчика не может быть выполнено. Для этого клиент должен связаться с дежурным пульта (по телефону), и по команде с пульта, подаваемой вручную оператором, в УТ будет послана команда разрешающая /запрещающая контролировать состояние объекта.


Структура программного обеспечения пульта

2.3 Структура программного обеспечения пульта

Программа - это записанный на одном из входных языков компьютера алгоритм. Алгоритм - это описание последовательности действий, необходимых для получения результата из входных данных. Т.о. работа компьютера, выполняющего программу, заключается в выполнении последовательности предопределенных действий, к которым могут относиться ввод данных с клавиатуры, получение данных от устройств, вывод информации на экран и другие не столь очевидные действия. Под программным обеспечением (ПО) понимают набор программ, для решения какой-либо проблемы.

ПО АСЦН Юпитер состоит из:
1) программы интерфейсного модуля (интерфейсной программы), далее - ИМ;
2) драйвера аппаратуры.

Интерфейсная программа служит для ввода и получения данных оператором. Она совмещает в себе, в настоящее время, функции автоматизированного рабочего места (далее - АРМ) инженера и АРМ-а оператора пульта охраны.

Драйвер аппаратуры работает на фоне выполнения других задач в системе (в т.ч. и интерфейсной программы) и выполняет роль посредника между интерфейсной программой и аппаратурой, максимально сглаживая различия в работе с разнотипными устройствами. Драйвер выполняет следующие функции.

1) Осуществляет обмен данными с аппаратурой (прием и получение пакетов с КПЦО).
2) Прием сообщений может сопровождаться звуковыми сигналами, независимо от звуков интерфейсной программы, что может быть удобно при временном выходе из программы ИМ.
3) Раскодирует и кодирует данные при приеме и передаче. Выполняет разбор сообщений, формирование команд, в зависимости от типов аппаратуры.
4) Обеспечивает хранение и доступ к данным о конфигурации устройств.
5) Поддерживает очереди сообщений аппаратуры и команд аппаратуре, что позволяет ему работать с аппаратурой некоторое время автономно, без ИМ.
6) Выполняет функции сторожевого таймера. Иными словами, при зависании программы ИМ, в некоторых случаях, позволяет перезагрузить компьютер по истечении заданного времени.


Сообщения и состояния объектов

2.4. Сообщения и состояния объектов

Под состоянием устройства нужно понимать его исправность, охраняется ли устройство (опрашивается вышестоящим), состояние его датчиков, состояние питания и т.п. информация. Для каждого типа устройств может быть свой набор данных. Здесь не будут рассматриваться вопросы, связанные с самой аппаратурой. Важнее, как эта информация представляется на пульте.

Необходимо понимать, что данные о состоянии устройств обновляются на пульте с некоторой задержкой. Поскольку в реальной системе может быть несколько тысяч устройств, данные о их состоянии обновляются не путем их последовательного опроса (этот способ не эффективен), а путем получения сообщений аппаратуры изменении состояния только некоторых из них. Например, какой-либо охраняемый объект был снят с охраны, клиент выполнил взятие объекта. Теперь объект взят. Аппаратурой формируется сообщение “взятие”. В результате, данные о том, что объект взят фиксируются и аппаратурой, и ПО пульта. Остальную же, большую часть времени, от объекта не поступает никаких сообщений. На передачу сообщения аппаратуре требуется некоторое время. Например, передача взятия ответчика может занять до 10 секунд. В этот интервал времени объект на пульте будет считаться снятым (программа будет сообщать его старое состояние).

Если какое-либо устройство в цепочке передачи вышло из строя, то изменения состояний его подчиненных устройств невозможно проконтролировать. Также всегда существует вероятность потери сообщения и, как следствие, несоответствие представляемой на пульте информации реальному состоянию объектов. Для установки соответствия данных в аппаратуре и на пульте существуют процедуры перевзятия и опроса. Перевзятие восстанавливает данные в аппаратуре по данным пульта. Опрос, наоборот, восстанавливает данные пульта по данным аппаратуры. Команду перевзятия следует подавать с пульта при восстановлении устройства после неисправности. Опрос необходим при сбоях связи, искажениях сообщений, иногда, при сбоях ПО. Далее в описании, где это необходимо, будет упоминаться перевзятие и опрос.

Рассмотрим состояния объектов, как они представляются на пульте.

ИСПРАВЕН. Означает исправность устройства, которое, чаще всего, не является само по себе охраняемым объектом, а лишь служит для передачи данных. После добавления любого устройства в базу данных пульта, оно устанавливается в это состояние.

НЕИСПРАВНОСТЬ. Означает любую неисправность устройства, либо линии связи, при которой связь с устройством теряется.

ЗАБЛОКИРОВАН (Другими словами - состояние ремонта). Состояние объекта на пульте (нет аналогичного состояния устройства), при котором все сообщения от устройства игнорируются. Иногда, в основном на время пуско-наладочных работ, требуется перевести объект в этот режим.

ВЗЯТ. Контролируется состояние охраняемого устройства (его охранных шлейфов)

СНЯТ. Состояние охраняемого устройства не контролируется.

ТРЕВОГА. Нарушен охранный шлейф на объекте, что означает проникновение на охраняемый объект.

ВЗЛОМ. Сработал датчик вскрытия корпуса ГК или ББ. Это состояние может быть только у ГК КОМЕТА или ББ ЮПИТЕР.

САБОТАЖ. Зафиксирована попытка подключения к линии связи между УТ и объектовым устройством.

Некоторые состояния ручных объектов в базе данных пульта не имеют никакой связи с состояниями реальных объектов. Эти состояния выставляются программой ИМ принудительно, во время операций с ручными объектами, и связаны с ведением отсчета времени таймерами программы ИМ для подачи команд в заданное время. К этой группе относятся следующие состояния.

ОЖИДАЕТ ВЫХОДА,
ОЖИДАЕТ КОМАНДУ ВЗЯТИЯ,
ОЖИДАЕТ ВЗЯТИЯ, ОЖИДАЕТ ПЕРЕВЗЯТИЯ,
ОЖИДАЕТ КОМАНДУ СНЯТИЯ,
ОЖИДАЕТ СНЯТИЯ.


Элементы интерфейса и правила ввода данных

3.1. Элементы интерфейса и правила ввода данных

Интерфейсом называется способ обмена данными между:

  1. программой и пользователем
  2. программой и программой.

Интерфейсом также называется и набор сигналов, используемых при взаимодействии устройств, например, интерфейс RS-232. Интерфейсная программа Юпитер осуществляет обмен данными (ввод и отображение данных) с пользователем.

Программа обеспечивает оконный интерфейс, т.е. экран программы, состоит из различных окон, в которые осуществляется вывод и ввод данных. В любой момент времени может быть только одно окно, в которое можно вводить данные и которое будет реагировать на нажатия клавиш. Это окно называется активным окном. Вывод же данных в интерфейсной программе может происходить во все окна программы параллельно с вводом данных.

Для ввода данных служат панели диалога (обычно имеют серый цвет). Для простого просмотра и выбора какой-либо информации служат окна просмотра (обычно имеют черный цвет фона).

В окнах просмотра для прокрутки (передвижения по строкам) данных используются клавиши “<-”, “->” , “PgUp” и “PgDown”. Некоторые окна просмотра позволяют для текущего элемента выполнить какие-либо действия по нажатию Enter.

Панели диалога содержат несколько элементов ввода данных различных типов. Переход между элементами осуществляется клавишей Tab. Порядок перехода жестко определен в программе. Обратный порядок перехода можно получить нажатием Shift+Tab, т.е. при нажатом Shift нажать Tab . Выйти из любой панели диалога без сохранения введенных данных можно нажатием ESC.

  1. Строка ввода. Позволяет вводить строки текста и числа. Сразу после выбора строки, весь ее текст выделяется синим цветом фона. Нажатие любой клавиши в этот момент, кроме “<-”, “->” Home и End, приведет к потере ранее введенного текста и начнет ввод строки сначала. Завершается ввод или редактирование строки переходом к другому полю клавишей Tab. Для некоторых строк ввода в программе предусмотрен выбор вариантов текста строки, который вызывается клавишей Enter. После выбора варианта из списка клавишами "↑" и "↓" нужно нажать Enter, а если нужного варианта в списке нет - ESC.
  2. Выключатель (или блок выключателей). Включение или выключение выключателей выполняется клавишей Пробел. Переход между выключателями одного блока - клавишами "↑", "↓" , “<-” и “->”.
  3. Переключатель. Изменение позиции переключателя (в зависимости от положения позиций) осуществляется клавишами "↑" и "↓" или “<-” и “->”.
  4. Кнопка. Если Вы выберете “кнопку” и нажмете клавишу Enter, ввод данных в панель диалога будет завершен и панель будет убрана с экрана. Кнопка “Отмена” означает всегда, что введенные данные не нужно сохранять (данные были введены неправильно). Кнопки “Принять” или “Установить” будут фиксировать введенные данные.


Загрузка интерфейсной программы

3.2. Загрузка интерфейсной программы

Во время загрузки программы на экран выдается протокол загрузки Рис. 3.1. В это время пользователю желательно не предпринимать никаких действий и ожидать завершения загрузки. Если информация на экране перестанет обновляться достаточно долгое время (около минуты), попытайтесь перезагрузить компьютер. Если перезагрузка не поможет, обратитесь за разъяснениями к разработчику.


Смена пользователя пульта

3.3. Смена пользователя пульта

Программа автоматически предлагает изменить пользователя пульта после загрузки. Имя пользователя и пароль окно можно ввести вручную. Вместо имени пользователя можно ввести числовой идентификатор, который задается при добавлении в систему нового пользователя. Если программе не удалось преобразовать введенное значение в число - она считает, что было введено имя пользователя. Но удобнее выбрать пользователя из списка пользователей. Для этого, при пустой строке имени пользователя, нужно нажать Enter. Программа выведет список пользователей, Рис. . Пользователь выбирается клавишами "↑" и "↓", выбор завершается нажатием Enter.

Пароль пользователя при вводе отображается в виде символов “***”. Пароль вводится с учетом русских /латинских букв, поэтому будьте внимательны и правильно выберите раскладку клавиатуры.
Внимание: в отличие от DOS версии Юпитер 5.0 учитывается регистр символов (строчные /прописные).

Если или пароль или имя пользователя введено неправильно - программа выведет диалог с сообщением об отказе в доступе. Из соображений безопасности она не сообщает, что неправильно ввел пользователь: пароль или имя.

Для регистрации другого пользователя (например инженера ) необходимо нажать клавишу F3. Будет предложено ввести имя пользователя нового пользователя и пароль. Данное окно можно закрыть, нажав клавишу Esc.

При первой регистрации пользователя диалог содержит заголовок: "Регистрация пользователя". Его нельзя закрыть клавишей "Esc", так как появится диалог с предложением выйти из программы. (Начиная с версии 6.0.33 тот же эффект можно достичь клавишами "Shift + F3"). Диалог последующей регистрации пользователь может отменить, нажав клавишу "Esc".

Внимание: при смене пользователя, если настроен компьютер, с которым необходимо синхронизировать время - происходит автоматическая синхронизация времени.


Основной экран интерфейсной программы

3.4. Основной экран интерфейсной программы

Основной экран программы, см. Рис. 3.3, состоит из следующих частей: - строки состояния АРМ; - окна необработанных тревог - окна текущих сообщений (текущей ленты) - окна проверяемых объектов - строки подсказки.

Переход между 3-мя окнами основного экрана (и, возможно, дополнительно открытыми окнами, например, окном буфера взятий) осуществляется клавишей Tab.

Строка состояния АРМ содержит номер версии программы, имя пользователя, текущее время и дату. Номер версии может быть интересен инженеру пульта:
1) при замене программы на ее более позднюю версию (иногда при замене требуется выполнить дополнительные преобразования данных программы);
2) если в работе программы возникли ошибки и Вы собираетесь сообщить об этом разработчикам.

В поле имени пользователя выводится то имя под которым пользователь зарегистрировался при входе. Во всех ответственных операциях в “ленте” сообщений пульта будет фиксироваться номер соответствующий этому пользователю в списке. Если регистрация не была выполнена в поле будет выведено “Неизвестный пользователь” (в данном случае предоставляются минимальные права доступа).

Строка подсказки по клавишам, доступным в каждом из окон программы изменяется в зависимости от окна, в котором Вы работаете. Строка подсказки не содержит никакой информации для окон, где ввод данных подчиняется обычным правилам, описанным выше. И наоборот, там где это возможно, будет выведена подсказка по специфическим функциям окна.


Окно текущих сообщений

3.5. Окно текущих сообщений

Окно текущих сообщений пульта отображает все сообщения пульта включающие как сообщения аппаратуры, так и сообщения, сформированные программой (например, “запуск пульта” ). Пока интерфейсная программа работает, она непрерывно получает сообщения. И даже, если окно сообщений будет перекрыто другими окнами и его не будет видно на экране, это не значит, что прием сообщений прекращен. При переходе в окно сообщений указатель текущей записи фиксируется на последней на этот момент записи. Клавишами “PgUp”, “PgDown”, "↑" и "↓" можно пролистать текущую ленту вперед и назад на заданное (по умолчанию установлено 7) число дней.

При нажатии на какой-либо записи ленты, будет открыта карточка объекта из базы данных для объекта, с которого поступило сообщение. Работа с карточкой объекта будет описана позже. Структура сообщения ленты приведена на Рис. 3.4.

Ключ объекта - это тот ключ который сопоставляется объекту в базе данных и выводится в карточке объекта. Но даже если устройство не имеет карточки, ему может быть задан ключ.

Уровень устройства определяет устройство, с которого получено сообщение. Существуют следующие уровни устройств: АРМ, УЗЕЛ, КПЦО, АТС, УТ, Направление, Объект. Сообщения от АРМ генерируются самой интерфейсной программой одного из компьютеров сети, сообщения от узла - компьютером, к которому подключена аппаратура. Сообщения от АТС относятся целиком к одной линии КПЦО. Направление - это устройство абонентского комплекта, подключенное непосредственно к УТ (может быть как ответчик Центр, так и ГК Комета).

Параметр в зависимости от сообщения может быть числом или словом. Числовой параметр обычно является номером пользователя. Нечисловой параметр уточняет смысл сообщения, например “ЗАПУСК(УТ)(КОМЕТА)” или “ТРЕВОГА(Направление)(ОБРЫВ)”.


Окно необработанных тревог

3.6. Окно необработанных тревог

Окно необработанных тревог отображает все тревожные сообщения с момента их поступления до сброса после предпринятых оператором действий по отработке тревоги. Структура записи окна тревог приведена на Рис. 3.5.

Ключ объекта, время и сообщение в окне тревог аналогичны полям в окне текущей ленты сообщений. Наименование и адрес объекта выбираются из карточки объекта.

Если выбрать одно из тревожных сообщений в окне клавишами "↑" и "↓" и нажать Enter, на экране появится окно параметров тревоги Рис. 3.6.

Существуют 3 варианта дальнейших действий.

  1. Изменить активную кнопку клавишами: "<—" и "—>".
  2. По нажатию Enter выполненые действия зависят от активной кнопки:
    • Если активна кнопка "Передача", то возможно два варианта.
      • При настроенной связи с программой "Балтика" появится диалог на Рис. *.*. При нажатии клавиш "Tab" и "Enter" тревога будет отправлена дежурному офицеру.
        Рис. *.*
      • При не настроенной связи с программой "Балтика" появится диалог на Рис. *.*. При нажатии клавиш "Tab" и "Enter" тревога будет сброшена без запроса установки причины тревоги.
        Рис. *.*
    • Если активна кнопка "Карточка объекта" откроется карточка объекта.
    • Если активна кнопка "Сброс тревоги" - то же что и при нажатии клавиши Забой
  3. По нажатию Пробел будет открыта карточка объекта (работа с карточкой будет описана ниже). Это необходимо иногда для того, чтобы просмотреть выбранные из ленты последние сообщения от объекта перед сбросом тревоги.
  4. Нажатие клавиши Забой откроет окно сброса тревоги с установкой обработанной тревоге причины, описанной как проверочная (некоторые тревоги появляются только в результате проверки работы системы, например, “Проверка ОПС с х/о” ). Список “проверочных” причин тревог открывается сразу при сбросе “проверочной” тревоги Рис. 3.8.
    Рис. *.*
    При нажатии клавиши Esc Вы попадете опять в окно тревог. При нажатии кнопки Enter появится диалог "Сброс тревоги", где будет установлев флаг "Производилась проверка" и в поле причина тревоги будет введенная причина тревоги( Рис. *.*).

Рис. *.*

При нажатии кнопки Enter тревога будет сброшена. При нажатии клавиши Esc Вы попадете опять в окно тревог. Для снятия флага "Производилась проверка" Вам необходимо нажать клавиши Tab и Пробел.

Внимение: Необходимо помнить, что сброс одного тревожного сообщения по заданному ключу сбросит и остальные тревоги, пришедшие с объекта на данный момент.
Все сброшенные тревоги попадают в журнал обработанных тревог, о котором будет рассказано позже. В журнале обработанных тревог потом можно будет выбрать тревожное сообщение и отредактировать поле причины тревоги.


Карточка устройства в БД

3.7. Карточка устройства в БД

Карточка (запись) объекта в электронной базе данных, такой как БД Ладога, с которой может работать компьютер, представляет собой аналог карточки в обычной бумажной картотеке охраняемых объектов. Использование электронных баз данных позволяет автоматизировать большую часть рутинной работы, связанной с поиском информации.

В БД программа может легко, в течении нескольких секунд, провести поиск карточки по какому либо полю карточки среди тысяч записей. В электронной карточке БД легче вносить изменения в данные: не требуется переписывать весь текст карточки заново, если внесено много исправлений. Карточку БД, наконец, в любой момент можно распечатать и получить ее бумажный вариант. Конечно, полностью от бумажной картотеки можно не отказываться и оставить ее для подстраховки, на случай сбоев компьютера.

Ключ объекта в БД Ладога это некоторое слово состоящее из символов цифр, букв и любых допустимых (отображаемых) в тексте символов, Например, “3-Б52” Длина ключа в БД Ладога может быть до 6-ти символов. В БД Ладога каждому объекту однозначно сопоставляется только один, уникальный вариант ключа. Т.о. не должно быть два или более объектов с одним ключом.

Интерфейсная программа Юпитер использует в своей работе базу из получившей широкое распространение системы управленияя базами данных (СУБД) Ладога.

Инженеру пульта: Данная СУБД является отдельным независимым от ПО АСЦН Юпитер программным продуктом, и разработчики ПО Юпитер не занимаются технической поддержкой самой СУБД Ладога.

В отличие от СУБД ЛАДОГА, выполняющей функции АРМ Инженера пульта и, которая позволяет выполнять любые операции с БД, в том числе ввод новых карточек и редактирование старых, интерфейсная программа Юпитер пока может только отображать эти данные.

Вызов окна карточки объекта выполняется из:
1) основного экрана программы при наборе (цифрового) ключа объекта;
2) при выборе сообщения из окна текущих сообщений (ленты);
3) из архивов (лент) сообщений (работа с архивами будет описана позже);
4) из панели объектов (будет описана далее).

Рассмотрим вариант вызова карточки из основного экрана программы. При вводе любых цифр в этом экране, появляется окно вида Рис. 3.9.

При нажатии Enter будет открыто окно карточки объекта Рис. 3.10.

  1. Ключ объекта
  2. Данные из БД Ладога
  3. Данные из БД Ладога из раздела Квартиросъемщики и доверенные лица
  4. 30 последних сообщений от объекта
  5. Содержание поля зависит от типа аппаратуры
  6. Меню допустимых операций над заданным объектом

Если карточка с заданным ключом не найдена в БД, будет открыто окно вида Рис. 3.11.

Однако, если карточки объекта с данным ключом нет в БД Ладога, но существует устройство с таким ключом в конфигурации АСЦН Юпитер, то по этому устройству будет выдана та информация, которая не относится к БД Ладога. Это - выборка из ленты сообщений, состояние устройства, его адрес в АСЦН и примечание. Отсутствие карточки в БД Ладога не накладывает никаких ограничений на работу с данным объектом.


Журналы системы

3.8. Журналы системы

Журналы системы можно открыть из меню Рис. 3.12, которое открывается при нажатии клавиши Пробел в основном экране интерфейсной программы. Выбор журнала производится клавишами "↑" и "↓". Переход в выбранный журнал завершается нажатием Enter.

Текущий журнал обработанных тревог Рис. 3.13 содержит все обработанные (сброшенные) тревоги за двое последних суток.

Столбец “сообщение” содержит название обработанного тревожного сообщения. Столбец “Взятые” используется только для ГК Комета и показывает, какие ответчики стояли на охране в момент неисправности ГК. Поле “поступило” содержит время и дату поступления сообщения на пульт, а поле “обработано” - время обработки (сброса) тревоги. В поле “Деж(урная)” стоит номер дежурного пульта (задается при запуске программы или смене дежурных), во время работы которого пришло тревожное сообщение. Если в поле стоит 0, то это означает, что сообщение пришло в момент между запуском программы и регистрацией пользователя в системе или, регистрация не была выполнена совсем. В поле “Причина” может быть записана причина тревоги.

В данном окне для прокрутки данных используются клавиши "↑", "↓", PgUp и PgDown. Для выхода из журнала в основной экран программы нужно нажать Esc (но здесь это не отменит сделанных вами для записей изменений). Причину тревоги для выбранной записи можно ввести, если нажать Enter. Тогда появится окно вида рис *.*.

Причину тревоги можно ввести вручную или выбрать из списка рис *.*, который вызывается нажатием клавиши Enter при пустом поле причины тревоги.

Общий журнал обработанных тревог позволяет выбрать данные по тревогам не только за текущий день, но и за любой день, любого месяца и года. При открытии журнала будет выдано окно вида рис *.* для выбора месяца.

Пункт “Лента за текущий месяц” выбирает последний месяц работы системы. Выбор пунктов осуществляется клавишами "↑" и "↓", после чего нужно нажать Enter. По клавише Esc выполняется выход в основной экран программы. Если месяц архива все же выбран, программа предложит выбрать день месяца см. рис. *.*.

По клавише Esc выполняется выход в предыдущее меню. Пункт “Лента за месяц” выбирает все дни месяца, остальные пункты - отдельные дни месяца. По нажатию клавиши Пробел открывается меню, если выбрать опцию "Печать" Открывается дилог для печати записей:

При открытии окна диапазон номеров записей установлен с первой по последнюю записи журнала. Однако, эти значения можно изменить. Кнопка “Печатать” начнет печать записей на принтер или в файл вывода, в зависимости от настройки печати программы. Кнопка “Продолжить” или нажатие Esc приведут к выходу в окно журнала.

Журнал неисправных/тревожных на момент написания руководства в программе не был реализован. Журнал будет содержать все неисправные и тревожные объекты на текущий момент и будет полезен при передаче смены дежурными пульта.

“База данных” вызов просмотрщика или редактора БД Ладога в зависимости от привелегий пользователя.

Буфер взятий “ручных” объектов будет описан в разделе “Процесс охраны объектов”.

Журнал сообщений системы представляет интерес только для разработчиков программы. Он содержит протокол работы программы, в том числе и те данные, которые выдаются на экран в процессе загрузки ИМ. В следующих версиях программы этот журнал будет исключен из меню.


Панель объектов

3.9. Панель объектов

Панель объектов служит для индикации состояния устройств системы, операций с конфигурацией устройств и подачи на них команд. В панели объектов отражается структура физических связей устройств. На ней изображено, как и какие УТ подключены к КПЦО. По выбранному УТ можно просмотреть структуру устройств абонентского комплекта.

Переход в панель объектов выполняется из основного экрана интерфейсной программы. Для этого необходимо нажать клавишу F5.

Панель объектов (Рис. 3.20) состоит из следующих частей:

  1. Индикатора состояния станционной аппаратуры
  2. Индикатора устройств абонентского комплекта выбранного УТ
  3. Индикатора параметров выбранного устройства

Поле индикатора выбранного устройства служит только для отображения параметров выбранного устройства. Среди параметров устройства:

  1. его ключ в БД;
  2. состояние устройства;
  3. тип аппаратуры и уровень устройства;
  4. дата и время получения последнего сообщения от устройства;
  5. адрес устройства. Адрес отражает всю цепочку соединений устройств до заданного.

Переход между полями индикаторов станционной аппаратуры и абонентского комплекта осуществляется клавишей Tab. В обоих полях конкретное устройство выбирается клавишами “PgUp”, “PgDown”, “↑” и “↓”.

Указатели выбранного устройства показывают, какое устройство выбрано в панели объектов. На рис *.* выбрано УТ 1 на 1-й линии 1-го КПЦО. Маркер в поле станционной аппаратуры стоящий рядом с этим устройством активен, т.е. используется для выбора устройства (он имеет белый цвет). Маркер в поле абонентского комплекта неактивен, т.е. в данный момент не используется (он изображается черным цветом). Но как только мы переключимся в поле абонентского комплекта, маркер станет активным и с помощью него можно будет выбрать ГК данного УТ и, далее, ИО выбранного ГК.

Если, выбрав существующее в конфигурации устройство и нажать

  1. Пробел, вблизи с изображением устройства в панели появится меню операций с этим устройством. Состав пунктов меню варьируется в зависимости от типа и уровня устройства
  2. Enter, откроется карточка выбранного устройства.

Для отсутствующего в конфигурации устройства в обоих случаях программа выведет диалог добавления устройства, если у оператора есть права на добавление объекта, иначе будет выведен диалог Рис. *.*

Если устройство присутствует в конфигурации, будет выведено меню Рис. *.*. Пункты меню зависят от конкретного устройства.

Существующее устройство можно найти в конфигурации, если, находясь в панели объектов, набрать его ключ. Для этого достатоно нажать любую цифру на клавиатуре. После чего появится диалог ввода ключа(Рис. *.*). После того, как будет нажат Enter, программа проведет поиск объекта с заданным ключом и установит на него указатель в панели объектов.


Операции с линией КПЦО ("АТС")

4.1. Операции с линией КПЦО (“АТС”).

Добавление линии. Для отсутствующей линии в панели объектов открывается диалог вида Рис. 4.1.

Нажатие отменяет добавление линии. Порядок перебора полей в данной панели стандартный.
В поле “Ключ” необходимо ввести ключ устройства. Линию КПЦО лишь условно можно назвать устройством и карточку в БД “Ладога” для линии КПЦО заводить бессмысленно. Поэтому, при выборе ключа для линии, необходимо исходить из того, как сообщения от линии КПЦО должны выводиться в ленту. Ключ линии можно, например, задать в виде “АТС-11” (исходя из ее положения в структуре устройств) или, например, “510” (ориентируясь на номер телефонной станции, где расположены блоки УТ данной линии).
Позиция переключателя “Физ. линия” позволяет задать соответствие логических номеров линий КПЦО (номера линий в панели объектов) и физических линий КПЦО (на разъеме КПЦО). По умолчанию линии распределены следующим образом: 1 - 1; 2 - 2; 3 - 3; 4 - 4. Разводка линий КПЦО практически можно использовать для подключения длинных цепочек УТ/ретрансляторов стоящих на разных логических линиях. Это позволяет улучшить качество связи и уменьшить количество используемых “прямых” линий. См. рис. *.*. поясняющий сказанное:

  • а) Топология сети УТ в АСЦН Юпитер со старым протоколом обмена
  • б) Топология сети УТ в АСЦН Юпитер с новым протоколом обмена

Нажатие Enter в панели добавления приведет к добавлению линии.

Для выбранной и существующей в конфигурации линии открывается меню вида Рис. 4.2.

Карточка линии КПЦО. Несмотря на то, что карточку для линии КПЦО заводить не имеет смысла, существует возможность просмотра карточки этого “устройства”, если она существует.

Настройка линии. Окно изменения параметров линии содержит все те же поля, что и окно добавления линии. Настройка линии может понадобиться в процессе работы системы при изменении разводки линий.

Блокировка линии. Блокировка линии позволяет исключить любые сообщения от всех УТ подключенных к данной линии. Блокировку линии КПЦО с УТ, работающими с реальными объектами нельзя выполнять ни вкоем случае. Блокировка линии может понадобиться только в случае, когда на пульте введена конфигурация УТ данной линии, но сами УТ не подключены. Если, в данном случае, линия не заблокирована, то при каждом запуске КПЦО будут выдаваться сообщения о неисправности УТ.

При заблокированной линии пункт “Заблокировать” в меню Рис. 4.3 преобразуется в пункт “Разблокировать”.

Удаление линии выполняется после предупреждения Рис. 4.4.

При удалении линии конфигурация УТ данной линии будет потеряна и система перестанет работать с УТ этой линии. Поэтому операцию необходимо выполнять крайне осторожно, чтобы не повредить конфигурацию существующих УТ.


Операции с УТ

4.2. Операции с УТ.

Добавление УТ. Для добавления УТ на экран будет выведено окно вида Рис. 4.5.

Ключ УТ можно выбрать, по аналогии с линией КПЦО, исходя из положения УТ в структуре объектов, например “УТ-111”, или номера УТ на данной телефонной станции, например “510-1”. Часто выбирают ключ УТ по ключам объектов, подключенных к УТ. Например, для объектов Комета 70-ххх, где ххх -произвольное 3-значное число, выбирают ключ УТ “70 y”, где у-номер УТ с объектами 70-ххх.

Переключатель “Тип УТ” задает тип УТ и устройств АК подключенных к нему. В настоящее время ПО Юпитер поддерживается работа со всеми перечисленными в панели типами.

Для уже существующего УТ меню операций имеет вид Рис. 4.6.

Операция блокировки УТ позволяет исключить любые сообщения от самого УТ и подключенных к нему устройств. Другие операции будут описаны ниже.

Отличие от DOS версии Юпитер 5.0: Нельзя ввести примечание при добавлении объекта. Для ввода примечания используйте пункт меню "Настройка". В поле “примечание” для УТ можно ввести любую информацию которая будет выдана при вызове карточки УТ. Карточку для УТ не имеет смысла вводить в БД, но примечание будет отображено даже если карточка не найдена в БД. В качестве примечания для УТ можно, например ввести его серийный номер, справку о его расположении на телефонной станции и т.п. информацию.


Операции с конфигурацией устройств АК

4.3. Операции с конфигурацией устройств АК

  • 4.3.1. Конфигурация АК Комета
    • 4.3.1.1. Конфигурация ГК Комета
    • 4.3.1.2. Конфигурация ИО Комета


Конфигурация АК Центр и Атлас

4.3.2. Конфигурация АК Центр и Атлас

Вид панели объектов с изображением АК Центр и АК Атлас приведен на Рис. 4.10. Оба типа аппаратуры очень схожи с точки зрения их конфигурирования и работы с ними оператора. Напомним, что и Центр, и Атлас являются аппаратурой с “ручной” тактикой постановки на охрану, этим и объясняется их сходство.

Панель объектов Атлас

Панель объектов Центр

Экран с диалогом добавления направления Атлас или Центр представлен на Рис. 4.11.

При добавлении направления Центр (Атлас) необходимо задать ключ охраняемого объекта. Ключи объектов Центр обычно задаются по аналогии с системой Центр, где используются блоки емкостью до 120 объектов. Сами блоки пронумерованы и ключ объекта задается в виде NN-DDD или NNDDD, где NN - бывший номер блока Центр, а DDD - номер объекта, подключенного к блоку. Примеры ключей объектов: 37-120, 5-001. Поскольку УТ Центр рассчитано на подключение 60 направлений, а старые блоки на 120, при переводе направлений со старого блока используется два УТ Центр. Соответственно на 1-м УТ будут ключи NN-001 ... NN-060, на 2-м УТ - ключи NN-061 ... NN-120.

После добавления объекта Вам необходимо произвести настройку добавленного объекта. Для этого необходимо открыть карточку добавленного объекта и нажать клавишу F3, или в панели озъектов нажать Пробел, откроется меню из которого Вам необходимо выбрать пункт "Настройка". Откроется диалог настройки. На рис. *.* изображен диалог настройки Атласа. Панель настройки направления Центр отличается от приведенной на рисунке отсутствием строки ввода времени проверки.

Параметр “Время входа” определяет задержку между сообщением о входе на объект и генерацией ИМ сообщения “ТРЕВОГА” (если в этот период не было выполнено снятие объекта с охраны оператором пульта). Параметр “Время выхода” задает задержку между началом постановки объекта на охрану оператором и собственно подачей команды на взятие блоку УТ. Подробнее о назначении этих параметров будет рассказано далее при описании работы с ручными объектами.

Для объекта может быть введено примечание “вручную” или из готового списка. Напомним, что список стандартных примечаний вызывается клавишей Enter из строки ввода примечания.

Поля “Ключ связи ..." задают ключи объектов, связанных с данным во всех выполняемых операциях. Т.е. постановка, снятие, перевзятие и другие операции с ручными объектами выполняются синхронно для данного объекта и его связанных объектов. Тип связанного объекта может отличаться от типа данного объекта, но связанный объект может быть только "ручного" типа. Например, связь ручного ключа типа Атлас с ключом ГК Комета в операциях будет игнорироваться.

Операции с разнотипными объектами выполняются с учетом специфики аппаратуры объекта и с учетом расписания охраны. Например, если одновременно ставятся на охрану ОПС Центр, ОПС Атлас и КТС Атлас, то первый будет браться как ОПС Центр, второй - как ОПС Атлас (с проверкой прибора и ожиданием выхода), третий - как КТС Атлас (после проверки прибора сразу перейдет во взятое состояние). Во время взятия все 3 объекта будут помещены в буфер взятий. Состояние объектов будет меняться соответственно их типам.

Таблица охраны объекта задает расписание охраны объекта по дням недели (и официально установленным праздничным дням) и часам каждого дня. Каждый час охраны дополнительно разделен на 2 получасовых интервала. Точное задание расписания охраны объекта чаще необходимо для государственных объектов, которые оборудуются как кнопками тревожной сигнализации (КТС), так и приборами охранно-пожарной сигнализации (ОПС), а в условиях договора отдельно оговаривается расписание охраны. Для квартир обычно используют тип охраны ОПС с 0 до 24 часов ежедневно (расписание по умолчанию).

Различие между типами охраны “ОПС” и “КТС” заключается в выполнении задержки между сигналом об обрыве (замыкании) шлейфа и выдачей сообщения “ТРЕВОГА” и задержки на выход для “ОПС”. Для типа охраны “КТС” тревога выдается сразу после получения сигнала от шлейфа. Постановка на охрану “КТС” выполняется также без задержки на выход. Тип охраны “ОПС+” или иначе “ОПС без снятия” подразумевает наличие задержки на выход (взятие) и отсутствие задержки на вход. Для ““комбинированного” типа охраны задержки определяются типом постановки объекта на охрану оператором.

Таблица охраны, как и прочие поля, выбирается в панели клавишей Tab. Перемещения по ячейкам таблицы выполняются клавишами "↑", "↓", PgUp и PgDown. Циклическое изменение типа охраны в ячейке - клавишей Пробел. Ячейки в верхней строке синхронно изменяют тип охраны в заданный час на все дни недели. Ячейки крайнего левого столбца изменяют тип охраны на весь выбранный день недели. И, наконец, ячейка в левом верхнем углу таблицы изменяет тип охраны во всех ячейках таблицы. Тип охраны в выбранной ячейке можно “распространить” на соседние ячейки (прямоугольную область таблицы), если не отпуская Shift выполнить перемещение клавишами "↑", "↓", PgUp и PgDown.

Необходимо помнить, что расписание охраны, если в нем записан тип охраны ОПС или КТС имеет приоритет по отношению к типу постановки объекта на охрану оператором. Т.е. например, если по расписанию объект должен охраняться как ОПС, а оператором он был поставлен как КТС, объект будет охраняться по расписанию - как ОПС. Чтобы избежать недоразумений, аккуратно заполняйте расписание охраны и время, когда объект может охраняться либо КТС, либо ОПС, отмечайте типом “комбинированный”.

Параметры «ручного» объекта описанные выше, кроме ключа, можно отредак-тировать позже, когда объект уже существует в конфигурации устройств. Панель редактирования параметров объекта (похожа на панель добавления объекта) вызывается пунктом “Настройка” в меню операций в панели объектов. Кроме перечисленных выше параметров, из карточки объекта можно установить так называемый расширенный тип объекта. Панель редактирования расширенного типа вызывается комбинацией клавиш Пробел.


Конфигурация АК Комета

4.3.1. Конфигурация АК Комета

4.3.1.1. Конфигурация ГК Комета
4.3.1.2. Конфигурация ИО Комета


Конфигурация ГК Комета

4.3.1.1. Конфигурация ГК Комета.

Вид панели объектов с изображением устройств АК Комета приведен на Рис. 4.7.

Если маркер в панели установлен на несуществующий ГК, при нажатии клавиши Enter или Пробел, для этого ГК будет открыт диалог добавления ГК Рис. 4.8.

При добавлении ГК необходимо указать ключ ГК. При задании ключей ГК и ИО желательно придерживаться какой-либо системы. Здесь сложно дать общие рекомендации по формированию ключей т.к. на каждом пульте используют свою систему ключей. Чаще, по аналогии с системой Комета (после переключения ГК с линейных блоков на УТ Комета), где все линейные блоки были пронумерованы и к каждому блоку было подключены до 100 ГК с номерами 0-99 используют ключи вида NN-GG0 или NN-GG. Соответственно NN - номер бывшего линейного блока, GG - номер ГК - 00-99. Примеры вариантов ключа ГК: 70-010, 50-98, 50980.

Автоматическое добавление ИО при добавлении ГК введено в ИМ для упрощения ввода конфигурации объектов, т.к. обычно после добавления ГК требуется добавить также и (большинство) ИО. А поскольку добавление всех необходимых ИО операция более трудоемкая чем удаление несуществующих ИО, в ИМ была введена такая функция.

Переключатель “Формирование ключей ИО” в диалоге добавления ГК задает вид ключей ответчиков, которые будут автоматически добавлены при добавлении ГК. Вариант “Расширение ключа ГК” означает, что для формирования ключей 8-ми ИО будут дописываться цифры от 1 до 8 в конец ключа ГК. Вариант “Замещение последнего символа” означает что для ИО будут использованы ключи, в которых за основу взят ключ ГК, но последний символ заменен на цифру от 1 до 8.

Таблицу, поясняющую оба способа формирования ключей ИО см. ниже.

Способ формирования ключей | Ключ ГК | Ключи ИО
Замена | 70-010 | 70-011, ... , 70-018
Замена | 50980 | 50981, ..., 50988
Расширение | 50980 | 509801, ..., 509808
Расширение | 5098 | 50981, ..., 50988

Существующий ГК можно, помимо прочих операций, заблокировать /разблокировать и удалить. Эти операции выполняются, как и для прочих устройств после стандартных предупреждающих сообщений.


Конфигурация ИО Комета

4.3.1.2. Конфигурация ИО Комета

Диалог добавления ИО Комета представлен на Рис. 4.9.

При добавлении ИО необходимо указать ключ ИО. Рекомендации по формированию ключей для АК Комета см. выше.

Прочие операции с конфигурацией ИО - блокировку и удаление, можно выполнить из меню операций для уже существующего ИО.


Конфигурация устройств АК Юпитер

4.3.3. Конфигурация устройств Юпитер

В настоящее время АК Юпитер представлен двумя следующими наборами устройств:

1. АК «Юпитер» | Абонентский Комплект «Юпитер»: базовый блок (ББ) с 24-мя индивидуальными ответчиками (ИО);
2. УОО «Юпитер» | Устройство Оконечное Объектовое «Юпитер»: ББ с пятью охранными шлейфами, к которому подключается устройство взятия/снятия (УВС).
3. ППКОП «Юпитер 5П» | Прибор Приемно-Контрольный Охранно-Пожарный «Юпитер 5П»: ББ с пятью охранно-пожарными шлейфами, к которому подключается УВС.
4. ПОИСК | Пожарно-Охранная Интегрированная Система Контроля: совокупность различных приборов и расширителей, объединенных единым интерфейсом. Базовые блоки в каждом варианте различные.

Базовые блоки в каждом варианте различные.
Для АК «Юпитер» ББ имеет 3 линии, на каждую линию могут подключаться до 8 ответчиков с 3-мя шлейфами каждый. Таким образом, может быть подключено до 24 ответчиков. В этом варианте, единицами охраны являются ИО, а ББ является только устройством передачи информации, которое может быть исправно или неисправно, а также может выдавать сообщение «ВЗЛОМ».
Для УОО «Юпитер» и ППКОП «Юпитер 5П» охраняемым устройством является сам ББ. То есть, он может быть взят или снят, выдать тревогу по одному из 5 шлейфов, сообщения «ВЗЛОМ»/«ЗАКРЫТИЕ»/«ПАТРУЛЬ», а также сообщения отслеживающие изменение режима питания.

Тип объектового устройства задается при добавлении в конфигурацию:

Изображение в панели объектов устройств, подключенных к ББ будет соответствовать типу ББ.

Для ППКОП «Юпитер 5П» и ПОИСК, при добавлении следует указать ключи, закрепляемые за первыми в системе расширителем (КМ для ПОИСК и ППКОП-5 для ППКОП «Юпитер 5П») и разделом. Для ППКОП «Юпитер 5П», также следует указать ключ, закрепляемый за УВС, подключенным к прибору.

а) АК «Юпитер» | б) УОО «Юпитер»

в) ППКОП «Юпитер 5П» | г) ПОИСК
    Переход в панели объектов к
  1. ответчикам (для АК «Юпитер») и, далее, к шлейфам;
  2. шлейфам (для УОО «Юпитер»);
  3. описанию расширителей, разделов и связей между ними (для ППКОП «Юпитер 5П» и ПОИСК) и, далее, к шлейфам;
выполняется клавишей Tab.

Для ББ на 24 ответчика в панели можно добавить ответчики. Панель добавления ИО Юпитер выглядит также, как и панель добавления ИО Комета. В ней задается только ключ ответчика.

Для ИО и УОО «Юпитер» имеется возможность настройки параметров шлейфов.

  • Настройка шлейфов
  • Настройка пользоватлей
  • Настройка таблицы охраны и связанных ключей
  • Особенности АК Юпитер, связанные с настройками
  • Конфигурирование ПОИСК и ППКОП «Юпитер 5П».
  • Настройка параметров расширителей ПОИСК и ППКОП «Юпитер 5П».


Настройка шлейфов

4.3.3.1 Настройка шлейфов

При выборе шлейфа (нажатием клавиши Tab выполняется переход к области отображения/настройки состояния шлейфов) нажатие клавиши Enter или двойным нажатие левой кнопки мыши, открывается диалог настройки параметров

Если установлен тип шлейфа “Охранный с задержкой”, программа запросит ввести задержку шлейфа (Pис *.*). для ввода задержки необходимо нажать клавишу Tab.

Тип: задает тип шлейфа, определяющий режим его функционирования:

Исключен | шлейф не используется.
Охранный без задержки | шлейф выдает сообщение ТРЕВОГА без задержки, если объект взят на охрану. В случае если в течение интервала времени, отведенного на выполнение процедуры взятия раздела под охрану шлейф будет нарушен и затем восстановится, то произойдет немедленное взятие раздела
Охранный с задержкой | шлейф выдает сообщение ТРЕВОГА по истечении заданного времени после нарушения, если объект взят на охрану. Для этого типа шлейфа имеет смысл настройка “Задержка”, которая задает для приборов ПОИСК и ППКОП-5 интервал от 0 до 150 секунд задержки с шагом в 10 секунд (0, 10, 20 и т.д), и для АК-24 и УОО интервал от 0 до 126 секунд задержки с шагом в 2 секунды (0, 2, 4). Этим типом шлейфа должен задаваться шлейф, который находится на входе объекта. Задержка должна дать возможность клиенту выполнить снятие объекта с охраны, но вместе с тем, ее величина должна быть не слишком большой для случая несанкционированного проникновения на объект. В случае, если в течение интервала времени, отведенного на выполнение процедуры взятия раздела под охрану шлейф будет нарушен и затем восстановится, то произойдет немедленное взятие раздела.
КТС | шлейф выдает сообщение ТРЕВОГА (КТС) без задержки, независимо от того, взят раздел или снят.
Пожарный | шлейф выдает сообщения ТРЕВОГА (ПОЖАР), ТРЕВОГА (ВНИМАНИЕ), ТРЕВОГА (НЕИСПРАВНОСТЬ) без задержки, не зависимо от того, взят раздел или снят. В данном режиме шлейф контролирует пожарные датчики.
Патрульный | сообщение о нарушении шлейфа интерпретируется программой как сообщение ПАТРУЛЬ. Шлейф срабатывает в любом состоянии раздела. Патрульный шлейф может использоваться для отметки прибытия патруля на сработавший объект или для контроля за передвижениям часового по объектам.
Проходной | только для ПОИСК. Шлейф функционирует аналогично шлейфу с типом «Охранный без задержки», за одним исключением: при выполнении процедуры постановки объекта под охрану шлейф не инициирует взятие до истечения интервала времени на взятие вне зависимости от изменения своего состояния.

Задержка: задает для ПОИСК и ППКОП-5 интервал времени от 0 до 150 секунд задержки с шагом в 10 секунды (0, 10, 20 и т.д), для АК-24 и УОО-5 интервал времени от 0 до 126 секунд задержки с шагом в 2 секунды (0, 2, 4 и т.д) в течение которого возможно произвести снятие раздела с охраны, при нарушении шлейфа, имеющего тип «Охранный с задержкой».


Настройка пользователей

4.3.3.2 Настройка пользователей

Для существующего ИО или УОО-5 открывается меню вида Рис. *.*. Для открытия меню в панели объектов необходимо выделить ответчик или УОО-5, нажать правую кнопку мыши или клавишу Пробел.

Если выбрать пункт “Пользователи”, то для разрешения и настройки пользователей будет открыто окно Рис. *.* со списком пользователей.

Диалог позволяет добавлять новых пользователей в систему, удалять и изменять параметры имеющихся пользователей.

Для добавления нового, или изменения существующего, пользователя следует выбрать нужную строку и нажать Enter, либо сделать двойное нажатие левой кнопки мыши.

Для удаления существующего пользователя следует нажать Пробел или снять галочку в нужной строке. При этом будет предложено подтвердить удаление пользователя.

При добавлении нового или изменении параметров существующего пользователя отображается диалог следующего вида:

Для каждого пользователя можно задать ряд параметров:

Номер клиента: | задает номер клиента, набираемый на клавиатуре УВС. Может принимать значение в диапазоне от 1 до 16. Значение данного параметра задается при выборе пользователя в таблице.
Пользователь: | задает номер пользователя, ассоциированный с номером клиента (см.выше), используется при поиске описания клиента в базе данных.


Настройка таблицы охраны и связанных ключей

4.3.3.3 Настройка таблицы охраны и связанных ключей

Вниманае, в данной версии программного обеспечения добавлена таблица времени охраны УОО-5 и ответчиков Юпитер. Вызов из пункта меню "Настройка".

В версии 6.0.31 отрабатывается только "ОПС без снятия", остальные типы охраны игнорируются. Если происходит снятие объекта, в данное время объект охраняется по таблице как "ОПС без снятия", на пульт выдается сообщение: "ТРЕВОГА (ВРЕМЯ ОХРАНЫ)". Настройка такая же как и у АК Центр и Атлас.


Особенности АК Юпитер, связанные с настройками

4.3.3.4 Особенности АК Юпитер, связанные с настройками

По части настроек АК Юпитер нужно помнить следующее. Все настройки, выполняемые с АК в интерфейсной программе лишь изменяют базу данных объектов. При этом программа автоматически не посылает аппаратуре измененные данные о настройках. Если Вы, например, добавили или удалили шлейф, то АК ничего об этом не узнает, пока на него не будет подана команда ПЕРЕВЗЯТИЕ, которая должна содержать информацию о составе шлейфов. До тех пор, АК будет работать со старым типом шлейфа, который был задан в установках по умолчанию или установлен предыдущей командой.

После установки задержек шлейфов на АК, т.е. то устройство для шлейфов которого сделаны изменения, необходимо подать команду УСТАНОВКА ЗАДЕРЖЕК из меню этого устройства.

Настройки пользователей хранятся тоже в базе объектов. Но эта информация никак не влияет на работу аппаратуры (никаких команд аппаратуре дополнительно не нужно посылать). Эти данные используются внутри программ пульта для интерпретации сообщений от ответчика или ББ. Так, например, если какой-либо брелок не описан в базе данных, то ВЗЯТИЕ/СНЯТИЕ этим брелком объекта, будет интерпретироваться как ТРЕВОГА(БРЕЛОК). Однако, аппаратура при этом отработает взятие или снятие объекта, и состояние объекта на пульте будет изменено на ВЗЯТОЕ или СНЯТОЕ, соответственно сообщению аппаратуры.


Конфигурирование ПОИСК и ППКОП "Юпитер 5П"

4.3.3.5 Конфигурирование ПОИСК и ППКОП "Юпитер 5П".

Панель объектов состоит из трех закладок, представляющих:

а) Список включенных в систему расширителей (до 110-и) | б) Список разделов, являющихся единицами охраны (до 60-и) | в) Визуальное представление связи между разделами и шлейфами.

При описании системы следует выделить два уровня представления:

а) аппаратный, на данном уровне перечисляются все приборы, входящие в систему (КМ, ППКОП-5, ППКОП-8, ПУ, РР-2, РИ-8, УВС-16, УВС-5П, УВС-8П) с указанием присвоенных им номеров в системе.

б) логический, на данном уровне перечисляются все разделы охраны, сформированные из отдельных шлейфов (сами шлейфы, физически, подключаются и контролируются ППКОП «Юпитер 5П» и ППКОП «Юпитер 8П»), с указанием присвоенных им номеров в системе.

Кроме того, для каждой системы задается единая таблица пользователей системы.

Система строится из набора приборов, образующих сеть, в которой каждый прибор выполняет определенные функции. Далее дается перечень приборов доступных на данный момент с их описанием.

КМ | Коммуникационный Модуль, служит для связи сети приборов системы с пультом. Конструктивно КМ выполнен в виде платы расширителя, устанавливаемой в ППКОП-8. КМ контролирует все приборы системы, определяя их исправность и передавая формируемые ими сообщения на пульт с использованием заданного канала связи. КМ является ядром системы, и его исправность определяет исправность всей системы в целом. КМ всегда располагается как расширитель с номером 1. В системе не может присутствовать более одного КМ. В списке расширителей отображается значком: M.
ППКОП «Юпитер 8П» | Прибор Приемно-Контрольный Охранно-Пожарный 8-и шлейфовый (ППКОП-8). Расширитель, контролирующий до 8-и охранно-пожарных шлейфов. Служит базой для установки КМ. Конструктивно представляет собой отдельный прибор, с резервированным питанием. В системе может быть несколько данных приборов. Их число зависит от требуемого числа охранно-пожарных шлейфов. Организационно шлейфы объединяются в разделы. Допускается произвольное включение шлейфов в разделы в зависимости от потребностей (например, можно объединить все пожарные шлейфы объекта в один раздел). В списке расширителей отображается значком: 8.
ППКОП «Юпитер 5П» | Прибор Приемно-Контрольный Охранно-Пожарный 5-и шлейфовый (ППКОП-5). Расширитель, контролирующий до 5-и охранно-пожарных шлейфов. Конструктивно представляет собой отдельный прибор, с независимым резервированным питанием. КМ интегрирован в состав ППКОП-5, и, поэтому как отдельный модуль не отображается. Шлейфы объединены в один раздел. Прибор ППКОП-5 представляет собой урезанный вариант ПОИСК. Совместно с ППКОП-5 может использоваться один УВС-5П. В списке расширителей отображается значком: 5.
ПУ «Юпитер» | Пульт Управления (ПУ), служит для настройки системы, отображения ее текущего состояния, а также выполнения операций по постановке/снятию разделов системы на/с охрану(ы). Конструктивно ПУ выполнен в виде отдельного прибора с индикатором и клавиатурой, подключается к КМ с использованием интерфейса CAN. В состав системы может входить несколько ПУ, в зависимости от потребностей пользователя. В списке расширителей отображается значком: П.
Расширитель Реле «Юпитер 2» | Расширитель Реле 2-х канальный (РР-2), служит для управления двумя релейными выходами, используемыми для включения сирен, замков, систем пожаротушения и тому подобного. Конструктивно РР-2 выполнен в виде отдельного прибора с индикатором исправности, подключается к КМ с использованием интерфейса CAN. В списке расширителей отображается значком:Р.
Расширитель индикации «Юпитер 8» | Расширитель Индикации 8-и канальный (РИ-8), служит для отображения состояния до 8-и объектов, в качестве которых могут выступать шлейфы или разделы. Конструктивно РИ-8 выполнен в виде отдельного прибора с индикаторами исправности и состояний, подключается к КМ с использованием интерфейса CAN. Прибор может использоваться как устройство выносной индикации состояния компонентов системы. В списке расширителей отображается значком: И.
УВС-16 «Юпитер» | Устройство Взятия/Снятия 16-и канальное (УВС-16), служит для отображения состояния до 16-и объектов, в качестве которых могут выступать шлейфы, разделы или расширители. Кроме того УВС-16 позволяет осуществлять операции по постановке/снятию разделов системы на/с охрану(ы). Конструктивно УВС-16 выполнен в виде отдельного прибора с индикаторами и клавиатурой, подключается к КМ с использованием интерфейса CAN. В списке расширителей отображается значком:У.
УВС-8П «Юпитер» | Устройство Взятия/Снятия 8-и канальное (УВС-8П), служит для отображения состояния до 8-и объектов, в качестве которых могут выступать шлейфы или разделы. Кроме того УВС-8П позволяет осуществлять операции по постановке/снятию разделов системы на/с охрану(ы). Конструктивно УВС-8П выполнен в виде отдельного прибора с индикаторами и клавиатурой, подключается к КМ с использованием интерфейса CAN. В списке расширителей отображается значком: У.
УВС-5П «Юпитер» | Устройство Взятия/Снятия 5-и канальное (УВС-5П), служит для отображения состояния до 8-и объектов, в качестве которых выступают шлейфы. Кроме того УВС-5П позволяет осуществлять операции по постановке/снятию разделов системы на/с охрану(ы). Конструктивно УВС-5П выполнен в виде отдельного прибора с индикаторами и клавиатурой, подключается к ППКОП-5 с использованием интерфейса RS-232 или RS-485. Устройство может использоваться только совместно с ППКОП-5. В списке расширителей отображается значком: У.

В зависимости от конфигурации охраняемого объекта формируется набор приборов, требуемых для решения задач охраны. Все выбранные приборы следует последовательно добавить в таблицу расширителей. При этом следует учитывать то, что КМ должен присутствовать в системе всегда и иметь номер 1. КМ добавляется автоматически при добавлении ПОИСК в конфигурацию.

При добавлении расширителя требуется указывать уникальный ключ прибора и его тип.

С помощью ключа, в дальнейшем, будут идентифицироваться сообщения, относящиеся к состоянию данного расширителя и командам, переданным для него.

Для описания разделов охраны следует на закладке «Разделы» добавить требуемые разделы охраны, указав для каждого из них уникальный ключ.

Далее, на закладке «Расширители», следует, для шлейфа расширителя ППКОП-8, выбрать пункт контекстного меню «Добавить в группу» (вызывается по правой кнопке мыши, или нажатию «ПРОБЕЛ»).

Далее в диалоге следует указать тот раздел, к которому шлейф будет, в дальнейшем, относиться.

Установленная, таким образом, связь шлейфов и разделов будет отображаться:

при просмотре расширителя | для каждого шлейфа указывается номер (но не ключ) раздела, с которым он связан;
при просмотре раздела | указывается список шлейфов, в него входящих, с указанием номера (но не ключа) расширителя и порядкового номера шлейфа в нем.
при просмотре связей | в виде древовидной структуры с указанием ключей разделов, ключей расширителей и номеров шлейфов в расширителях.

В дальнейшем, можно, при необходимости, удалить шлейф из раздела, и, затем, добавить его в другой раздел.

    При добавлении в конфигурацию ППКОП-5 его физический и логический уровни задаются однозначно:
  1. Расширителем номер 1 становится расширитель типа ППКОП-5
  2. Расширителем номер 2 становится УВС-5П
  3. Формируется раздел с номером 1, в который включаются все шлейфы расширителя.

Дополнительные функции настройки будут реализованы в последующих версиях ППКОП-5, и, на настоящий момент, недоступны.


Настройка параметров расширителей ПОИСК

4.3.3.6 Настройка параметров расширителей ПОИСК.

В рамках системы ПОИСК каждый прибор имеет свой, уникальный, идентификатор устройства. Данный идентификатор представляет собой 6-и байтное число, устанавливаемое при производстве прибора, и позволяющее однозначно идентифицировать прибор на линии, среди других, ему подобных. После завершения формирования конфигурации системы на пульте и на объекте можно, подав команду запроса.

Кроме того, расширитель каждого типа имеет набор параметров, соответствующий его функциональному назначению. Далее описываются параметры каждого типа расширителей.

  • Параметры Коммуникационного Модуля (КМ)
  • Параметры ППКОП-8
  • Параметры ППКОП-5
  • Параметры УВС-5П
  • Параметры Пульта Управления (ПУ)
  • Параметры Расширителя Реле-2
  • Параметры Расширителя Индикации
  • Параметры УВС-8П и УВС-16


Настройка параметров разделов ПОИСК и ППКОП "Юпитер 5П"

4.3.3.7 Настройка параметров разделов ПОИСК и ППКОП "Юпитер 5П".

При выборе раздела (выполняется переход к закладке отображения «Разделы») нажатие клавиши F3 или двойным нажатие левой кнопки мыши, открывается диалог настройки параметров:

На данный момент отрабатывается только "ОПС без снятия", остальные типы охраны игнорируются. Если происходит снятие объекта, в данное время объект охраняется по таблице как "ОПС без снятия", на пульт выдается сообщение: "ТРЕВОГА (ВРЕМЯ ОХРАНЫ)". Настройка такая же, как и у АК Центр и Атлас.

Также можно задать величину времени "Задержки на выход". Данный параметр задает время, проходящее с момента подачи команды постановки раздела на охрану с ПУ или УВС до момента постановки (при отсутствии нарушения шлейфов с типом "Охранный без задержки" или "Охранный с задержкой" с последующим их восстановлением).


Настройка таблицы пользователей ПОИСК

4.3.3.8 Настройка таблицы пользователей ПОИСК.

Все пользователи системы, вне зависимости от их прав и доступных разделов, объединены в одну таблицу. Вызов таблицы производится из контекстного меню, открываемого при нажатии клавиши пробел, либо правой кнопки мыши или нажатием F2:

В открывшемся диалоге «Номера клиентов» дается возможность просмотреть и настроить список пользователей системы:

Диалог позволяет добавлять новых пользователей в систему, удалять и изменять параметры имеющихся пользователей.

Важно!!!

Пользователь с номером «111» имеет тип «Администратор» (см.ниже.), и не может быть удален из системы или изменить свой тип. Пользователь с типом «Администратор» должен быть в системе только один.

При добавлении нового или изменении параметров существующего пользователя отображается диалог следующего вида:

Для каждого пользователя можно задать ряд параметров:

Номер клиента: | задает номер клиента, набираемый на клавиатуре ПУ или УВС, или закрепленный за используемым брелком. Может принимать значение в диапазоне от 001 до 255 (111 зарезервирован для Администратора)
Пользователь: | задает номер пользователя, ассоциированный с номером клиента (см.выше), используется при поиске описания клиента в базе данных.
Тип: | определяет уровень прав, доступных пользователю. Возможны следующие варианты: Пользователь- имеет возможность производить только смену собственного пароля, а также действия связанные с разделами, к которым ему разрешен доступ: постановку разделов под охрану и снятие с охраны, просмотр журнала сообщений по разделам. Не имеет возможности изменять или просматривать настройки системы. Техник - имеет права пользователя, дополнительно имеет возможность просматривать настройки системы. Администратор- имеет полные права (пользователя и техника), может изменять настройки сети, имеет доступ ко всем разделам.
Доступ к разделам: | задает список разделов, к которым пользователь имеет доступ при выполнении операций взятия/снятия. Возможны следующие варианты: Отсутствует - пользователь не имеет доступа ни к одному из разделов. Данный режим может использоваться для блокировки пользователя. Любой - пользователь имеет доступ ко всем разделам сети. Разделы - может быть задано до двух разделов по которым пользователь может выполнять операции.


Настройка таблицы пользователей ППКОП "Юпитер 5П"

4.3.3.9 Настройка таблицы пользователей ППКОП "Юпитер 5П"

Все пользователи системы, вне зависимости от их прав и доступных разделов, объединены в одну таблицу. Вызов таблицы производится из контекстного меню, открываемого при нажатии клавиши пробел, либо правой кнопки мыши или нажатием F2:

Настройка аналогична настройке пользователей АК-24 и УОО-5


Перенос данных между УТ

4.4. Перенос данных между УТ

В СПИ “Юпитер” 6.0 осталась возможность переноса данных УТ между УТ и АТС (перестановки УТ местами в конфигурации). Точнее, эту операцию можно выполнить копированием файлов и манипуляциями в панели объектов ИМ. Необходимость в подобных операциях может возникнуть в результате изменения топологии сети УТ/ретрансляторов.

Операция достаточно сложна в исполнении и должна быть хорошо спланирована. Перед выполнением операции настоятельно рекомендуется сделать резервную копию всех файлов данных.

Операция проводится в несколько этапов.

  1. Определить в панели объектов ИМ тип УТ. По адресу УТ определить имя файла данных УТ. Определить новое имя файла данных УТ и убедиться что в конфигурации нет УТ в том месте куда задумана перестановка. Как отмечалось ранее имя файла данных начинается с символов “УТ”, далее следует одна цифра-номер логической линии КПЦО и 2 цифры - номер УТ на линии.
  2. Удалить УТ в панели объектов ИМ.
  3. Выйти из программы СПИ Юпитер
  4. Переименовать (и/или скопировать) файл данных УТ в файл с новым именем.
  5. Перезагрузить компьютер с загрузкой системы “Юпитер”
  6. В панели объектов ИМ добавить в новом (заранее выбранном) месте УТ того типа, что был у удаленного.

Если все действия были выполнены правильно, то после добавления УТ вся структура объектов перенесенного УТ будет сохранена, иначе следует восстановить конфигурацию системы из резервной копии.


Конфигурирование системы радиоохраны "СТРУНА" и "СТРУНА-3M"

4.5. Конфигурирование системы радиоохраны "СТРУНА" и "СТРУНА-3M"

В СПИ “Юпитер” 6.0.36 появилась возможность подключить систему радиоохраны "СТРУНА" и "СТРУНА-3M".

Внимание: в системе "СТРУНА" и "СТРУНА-3M" возможны потери сообщений, т.к. в системе "СТРУНА" и "СТРУНА-3M" не предусмотрена возможность получения подтверждения приема пакетов. Возможность передачи данных на Струну отсутствуют из-за односторонней работы протокола "Струны".

Для подключения системы радиоохраны "СТРУНА" и "СТРУНА-3M" необходимо войти в СПИ Юпитер как "Инженер", войти в меню "Настройка\КПЦО" в появившемся диалоге необходимо добавить устройство, в появившемся диалоге указать ключ, обычно "Струна", COM-порт, к которому подключена "Струна" и тип объекта указать "Струна" или "Струна-3" в зависимости от используемой Вами аппаратуры.

Далее Вам будет предложена возможность ввести ключи каналов и виртуальной АТС (для совместимости с СПИ Юпитер). Вы можете нажать кнопку "ОК", так как изменить ключи каналов Вы можете позже.

Переходим к настройке панели объектов Струны.При добавлении оконечных объектов Струны Вам будет предложено ввести только ключ объекта. В панели объектов "Струна" представлена ключем, так же отображается состояние 4 шлейфов: "входного", "объемного", "пожарного" и "КТС".


Особенности настройки ПОИСК по цифровым линиям.

4.6. Особенности настройки ПОИСК по цифровым линиям.

В системе ПОИСК имеется возможность подключать прибор непосредственно к компьютеру по цифровым линиям (например по RS-232), минуя КПЦО и УТ.

    Для корректной работы АРМ ДПУ с ПОИСК следует выполнить ряд специальных настроек:
  1. в случае, если ПОИСК подключается к пульту с использованием цифрового канала связи (используется модуль RS-232 или TCP/IP) следует начинать добавление устройства в систему с добавления КПЦО специального типа «КПЦО-ПОИСК».

  2. В настройках добавленного КПЦО-ПОИСК следует:
    указать скорость работы по каналу
    установить тайм-ауты на чтение в значение 200
    установить режим «Упаковка-2».

  3. В основном меню программы в разделе «Настройки/Драйвер» настроить режим инициализации ПОИСК:

  4. Требуется установить режим "Получить конфигурацию с ПОИСК". В данном режиме после получения сообщения «ЗАПУСК» от ПОИСК пульт будет запрашивать все параметры устройств, настроенные при развертывании системы (настройка производится с ПУ). В дальнейшем, когда система ПОИСК будет поддерживать все команды установки можно будет производить обратную передачу данных с пульта на объектовое устройство.
  5. Далее следует добавить АТС и УТ типа «Юпитер», на которое, в свою очередь добавляется объектовое устройство «ПОИСК-8». При добавлении ПОИСК следует указать номер COM-порта (параметр «Подключение»), используемого для связи с объектовым устройством.

  6. Дальнейшая конфигурация производится обычным образом. В процессе дальнейшей работы можно изменить заданный порт подключения в разделе настройки параметров ПОИСК:


Охрана "автоматических" объектов

5.1. Охрана “автоматических” объектов

Так называемые “автоматические” объекты АК Комета и АК Юпитер, как уже упоминалось, не требуют вмешательства оператора во время постановки и снятия с охраны. Эти действия выполняются с объекта, оборудованного устройством взятия-снятия (УВС). На пульте охраны информация о взятии (снятии) объекта отображается в ленте сообщений. По сообщению объекта изменяется и состояние объекта. Напомним, что состояние объекта отображается в панели объектов и карточке объекта (ГК и ББ). В карточке объекта также отображаются и последние сообщения от устройства.

Вмешательство оператора при работе с “автоматическими” объектами необходимо только в случае возникновения тревог и неисправностей и при проверках работы объектовых устройств с клиентами охраны.


АК Комета

5.1.1. АК Комета

Как упоминалось ранее, АК Комета состоит из группового концентратора (ГК) и подключенных к нему индивидуальных ответчиков (ИО), в количестве до 8 штук.

Ответчики устанавливаются на охраняемом объекте и к ним подключается охранный шлейф. ГК устанавливается либо в помещении одного из охраняемых объектов, где установлен ИО, либо в непосредственной близости от ИО (как правило, в подъезде дома).

Напомним, когда мы говорим о состоянии ИО, чаще имеется ввиду, то как программа пульта представляет состояние реальной аппаратуры. Изменение состояния ИО на объекте сопровождается выдачей сообщения на пульт охраны, которое изменяет состояние ответчика на пульте. Текущее состояние устройства можно просмотреть в карточке устройства и в панели объектов интерфейсной программы. Выбранные из ленты сообщения по устройству можно увидеть в карточке объекта.

Диаграмма перехода состояний ответчика приведена на рис. *.*. Далее приводится набор состояний ИО, отображаемых на пульте интерфейсной программой.

Таблица состояний ИО Комета

Неопределенно/исправен | В это состояние ИО устанавливается в БД компьютера сразу после добавления его в конфигурацию объектов. Это состояние сохраняется до получения одного из описанных здесь сообщений от ИО.
Взят. | В это состояние на пульте объект устанавливается после получения сообщений “Взятие”, “Взятие (по запросу)”, “Взятие (внимание)”. На объекте ИО Комета переходит в состояние “взят” после задержки около 1.5 мин., если был включен тумблер “охрана” и замкнут охранный шлейф объекта.
Снят. | В это состояние на пульте объект переходит после получения сообщения “снятие”, “снятие (по запросу)”, “снятие (внимание)”. На объекте, ответчик переходит в снятое состояние, если правильно набран код на УВС ИО и выключен тумлер “охрана”.
Тревога | В это состояние объект переходит на пульте после получения сообщения “тревога”. На объекте ИО выдает сообщение “тревога” при размыкании охранного шлейфа (срабатывании датчика), если объект был взят на охрану. Сразу после замыкания шлейфа после тревоги ИО Комета переходит в сосояние “взят” и выдает сообщение взятие.

Набор сообщений, которые могут придти с ИО приводится ниже.

Взятие | Означает, что объект был взят на охрану после того, как он был снят или с него была передано сообщение “тревога”.
Снятие | Означает, что объект был снят с охраны. Снятие в АК комета может придти только с ранее взятого объекта.
Тревога | Означает, что на взятом объекте был разорван охранный шлейф, т.е. произошла тревога.

При повторном получении одного и того же сообщения от аппаратуры на пульте эти сообщения будут выданы как “Взятие (повторное)”, “Снятие (повторное)”, “Тревога (повторная)”. Если с объекта приходит “повторное” сообщение, то это может означать, что между ними было потеряно еще одно сообщение. Например, может быть следующая последовательность событий.

Во время перевзятия и опроса ГК, по полученным от ГК данным могут изменяться состояния ответчиков данного ГК в соответствии с диаграммой рис *.* и при этом выдаваться следующие сообщения.

ВЗЯТИЕ (ПО ЗАПРОСУ).
СНЯТИЕ (ПО ЗАПРОСУ).
ТРЕВОГА (ПО ЗАПРОСУ).

Эти 3 сообщения выдаются в ответ на перевзятие ГК Комета, к которому подключен ИО. Сообщения подтверждают, что информация о состоянии ИО на пульте находится в соответствии с реальным состоянием ИО.

Следующие сообщения по ИО выдаются в процессе как перевзятия, так и опроса ГК и указывают на расхождение информации о состоянии ИО на пульте и реальным состоянием ИО.

ВЗЯТИЕ (ВНИМАНИЕ). Сообщение означает, что объект, считавшийся на пульте тревожным, оказался взятым на охрану.

СНЯТИЕ (ВНИМАНИЕ). Сообщение означает, что объект, считавшийся на пульте тревожным, оказался снятым с охраны.

ПОЯВЛЕНИЕ. Сообщение означает, что объект, считавшийся на пульте снятым, оказался взятым на охрану.

ПОТЕРЯ. Сообщение означает, что объект, считавшийся на пульте взятым, оказался снятым с охраны.

ГК Комета может иметь только 2 состояния: ИСПРАВЕН и НЕИСПРАВЕН. Переход ГК в состояние НЕИСПРАВЕН происходит по сообщению “НЕИСПРАВНОСТЬ”. Переход в состояние ИСПРАВЕН будет выполнен при получении любого из приводимых далее сообщений ГК (кроме, естественно, сообщения НЕИСПРАВНОСТЬ) или сообщений одного из ИО, подключенных к ГК.

В любом из этих состояний ГК может быть поставлен в режим ремонта или в режим проверки. В этих режиме ремонта любые сообщения от ГК и ответчиков будут игнорироваться.

Особо следует обратить внимание на карточку ГК. Помимо стандартных полей карточки, описанных ранее, в правом верхнем углу карточки находится поле состояния ответчиков подключенных к ГК, см рис *.*.

Набор сообщений, которые могут придти с ГК Комета:

Дежурный режим. Означает восстановление работоспособности ГК после неисправности. Далее, смотри для сообщений перевзят и опрошен, сообщение “дежурный режим” такжк замыкает последовательность сообщений по ИО - результатов перевзятия/опроса.

Неисправность. Означает неисправность ГК. Неисправное (даже частично) устройство как правило не может само передать такое сообщение на пульт. Поэтому, нужно понимать, что реально это сообщение формирует УТ при отсутствии связи с ГК в следствии неисправности ГК или линии связи с ГК.

Взлом. Означает срабатывание датчика взлома, который есть в ГК Комета. Датчик срабатывает на открытие корпуса устройства. Взлом ГК не означает прекращение охраны ИО данным ГК. Сообщение “взлом” должно обрабатываться дежурным на пульте как сообщение “тревога” от объекта.

Ответ на перевзятие (Перевзятие). Означает, что команда перевзятия была передана устройству вышестоящими устройствами.

Ответ на опрос (Опрос). Означает, что команда опроса была передана устройству вышестоящими устройствами.

Опрошен. Сообщение выдается устройством после выполнения им команды опроса. Вслед за сообщением «опрошен» могут идти сообщения, указывающие на расхождения данных о состоянии ИО на пульте и их реальным состоянием. Расхождения в данных устраняются путем изменения данных на пульте в соответствии с данными полученными от аппаратуры. Группа сообщений завершается сообщением «Дежурный режим».

Перевзят. Выдается устройством после выполнения им команды перевзятия. Вслед за сообщением, по всем включенным ИО будут выданы сообщения, либо подтверждающие их состояние (см. сообщения ИО с пометкой «по запросу»), либо указывающие на расхождения в данных, как при опросе. Группа сообщений завершается сообщением «Дежурный режим».

Неизвестный код ИО. Сообщение выдается УТ (от имени ГК; аналогично неисправности ГК) при получении искаженного сообщения от ГК, в котором содержится недопустимый номер ИО. Практически, это означает что была выявлена потеря сообщения от ИО. После получения такого сообщения желательно выполнить команду перевятия ГК с целью выявить расхождения информации на пульте и на ГК.

Патруль. Сообщение означает срабатывание выключателя, который предназначен для отметки прибытия патруля на охраняемый объект. ГК имеют такой выключатель, но, как правило, он не используется. Чаще, сообщение “патруль” выдается частично неисправным ГК.


АК Юпитер

5.1.2. АК Юпитер

Охраняемый объект, на котором установлено устройство АК Юпитер - 5-шлейфный ББ или ответчик может иметь все те же состояния, что и ответчик Комета, см. выше. Диаграмма переходов между состояниями для объекта Юпитер такая же, как и у Кометы. Вообще, ИО Юпитер и 5-шл. ББ работают схожим образом с ИО Комета. Преимущество АК Юпитер, по сравнению с АК Комета, в том, что во всех взятиях и снятиях объекта фиксируется номер х/о, а в тревогах - номер охранного шлейфа. Плюс, взять или снять объект можно принудительно командой с пульта.

Новое состояние для ИО Юпитер - НЕИСПРАВЕН. Объект переходит в это состояние по сообщению НЕИСПРАВНОСТЬ, а по сообщению ВОССТАНОВЛЕНИЕ - возвращается в предыдущее до неисправности состояние. Объект, также, выходит из неисправности и по любому информационному сообщению, например, ВЗЯТИЕ или СНЯТИЕ.

Помимо сообщений, связанных непосредственно с охраной объекта, ББ может выдавать следующие сообщения.

  • Сообщение ВЗЛОМ генерируется, когда вскрыт корпус ББ и сработал датчик взлома. Аналогичное сообщение есть и у ГК Комета.
  • ЗАПУСК выдается после включения ББ. За этим сообщением идет следом ВЕРСИЯ. Сообщение содержит в качестве параметра номер версии прошивки ПЗУ. В сообщении аппаратуры также закодирована информация о типе ББ - рассчитан он на 24 ИО или 5-шлейфов. Если информация не соответствует конфигурации на пульте, то вслед за сообщением ЗАПУСК, будет выдано сообщение ОШИБКА КОНФИГУРАЦИИ. В случае совпадения конфигураций, этого сообщения не будет.
  • Сообщения РЕЗЕРВНОЕ ПИТАНИЕ и ВОССТАНОВЛЕНИЕ ПИТАНИЯ отмечают соответственно пропадание основного питания ББ и его восстановление. Оба варианта ББ имеют аккумулятор, который позволяет блоку сохранять свою работоспособность и питать подключенные ИО в течении нескольких часов. Блок рассчитан на 4 часа, отдельные экземпляры могут выдержать до 12 часов, в зависимости от числа подключенных ИО. В версии ПО пульта, имевшейся на момент написания данного руководства, использование резервного питания никак не индицировалось. Т.о., чтобы отследить, восстановилось ли основное питание, нужно просмотреть последние сообщения от ББ.

Команды устройствам АК Юпитер

На ИО Юпитер можно подать команды ПЕРЕВЗЯТИЕ и ОПРОС. Смысл этих команд для ИО - установка типов шлейфов и опрос типов и состояния шлейфов. Для ББ на 24 ответчика команда ПЕРЕВЗЯТИЯ разрешает работу ББ с определенными в конфигурации ИО (остальные запрещаются в ББ). Причем текущие состояния ИО устанавливаются в те, которые были на пульте в момент подачи команды. Для 5-шлейфного ББ команда устанавливает типы шлейфов. Короче говоря, команды перевзятия и опроса относятся к тому, что подключено к ББ - или ИО, или шлейфам.

Команда УСТАНОВКА ЗАДЕРЖЕК, упоминавшаяся в главе, посвященной вводу конфигурации устройств, посылает устройству, имеющему шлейфы с задержкой, настройки хранящиеся в базе данных. Напомним, эту команду нужно подавать после выполнения настроек. При нормальной работе, эту команду подавать на устройство не требуется.

Команды ВЗЯТЬ и СНЯТЬ позволяют принудительно поставить/снять объект с охраны. При получении команды ВЗЯТЬ, ББ пытается поставить ИО или себя во взятое состояние. При этом, если шлейфы в нормальном, замкнутом состоянии, то объект будет взят. Иначе - выдаст тревогу, но после восстановления шлейфа(ов) будет взят.

По сообщению ЗАПУСК от ББ, на него автоматически подаются команды ПЕРЕВЗЯТИЕ, УСТАНОВКА ЗАДЕРЖЕК. Т.о., после включения блока выполняется полная его инициализация с использованием информации, хранящейся на пульте. Устанавливаются даже состояния ВЗЯТ/СНЯТ для ИО.


Охрана "ручных" объектов

5.2. Охрана “ручных” объектов

“Ручные” объекты Центр и Атлас очень похожи с точки зрения работы с ними оператора. Здесь будет дано общее описание работы оператора с обоими типами аппаратуры и, там где это нужно, указаны их различия. Однако, при этом нужно понимать, что принципы работы аппаратуры Атлас и Центр существенно различаются. Практически необходимо помнить, что ответчики Атлас и Центр используют телефонную линию для связи с УТ, но аппаратура Атлас позволяет охранять объект независимо от телефонной связи. Аппаратура Центр не позволяет использовать телефон в то время, когда объект находится на охране.

Напомним, что текущее состояние объекта можно увидеть в карточке объекта, в панели объектов, которые были описаны ранее. Для “ручных” объектов состояние объекта отображается и в т.наз. буфере взятий объектов, при постановке объекта на охрану.

Общая диаграмма перехода состояний объектов Атлас и Центр приведена на рис. *.*. Все состояния “ручного” объекта можно разбить на 4 группы : группа состояний взятого; группа снятого; группа берущегося; группа снимающегося. В группах состояний взятого и снятого объект может находиться достаточно долгое время. Через состояния берущегося и снимающегося с охраны объект проходит короткое время - время ручных операций постановки и снятия с охраны.

Группы состояний объекта при постановке на охрану и снятии с охраны будут описаны позже.

Рассмотрим состояния объекта приведенные на рис *.* .

СНЯТ. Означает что объект не охраняется в данный момент и изменения его состояния не отслеживаются на пульте.

НЕИСПРАВЕН (снят). Неисправность аппаратуры произошла в состоянии когда объект был снят с охраны или снимался. При перевзятии такого объекта, если его работоспособность восстановится, он будет установлен в состояние “снят”.

ВЗЯТ. Данное состояние объекта означает что объект охраняется. При этом отслеживается состояние его шлейфа (датчика). Любое размыкание шлейфа будет зафиксировано на пульте, при этом объект перейдет в состояние либо “ожидает звонка”(ОПС), либо “тревога”(КТС), в зависимости от заданного на данный момент типа охраны. В состояние “ВЗЯТ” объект может перейти только после получения сообщения аппаратуры “ВЗЯТИЕ”.

ОЖИДАЕТ ЗВОНКА. В это состояние может перейти объект только с типом охраны “ОПС” при получении сигнала о размыкании охранного шлейфа, который фиксируется в ленте как сообщение “ВХОД”. При переходе в это состояние для объекта в программе взводится таймер на время, которое определено параметром “ВРЕМЯ НА ВХОД” для каждого ручного объекта. По истечении заданного времени, если с объекта не было звонка и оператор не выполнил снятие объекта с охраны, программой будет сформировано сообщение “ТРЕВОГА”.

ТРЕВОГА. В это состояние после получения сообщения “ТРЕВОГА” переходит объект с текущим (по расписанию охраны) типом охраны “КТС”, “ОПС без снятия”. Объект с типом охраны “ОПС” переходит в состояние тревога после получения сообщения “ВХОД”, если истекло время ожидания звонка и не было выполнено снятие объекта оператором.

Специфика аппаратуры Атлас. После того как с объекта Атлас было получено сообщение ВХОД или ТРЕВОГА, при восстановлении охранного шлейфа, объект будет взят на охрану (перейдет в состояние ВЗЯТ). Однако, если таймер для объекта с ОПС был установлен и объект не был снят с охраны, то тревога по взятому объекту будет выдана по истечении периода таймера. После тревоги и взятия(по сообщению аппаратуры), объект может снова выдать тревогу (вход).

Специфика аппаратуры Центр. При получении сигнала о размыкании шлейфа, телефонная линия объекта переключается блоком УТ с аппаратуры охраны на телефон. Т.о. клиент охраны получает возможность позвонить со своего телефона на пульт охраны. Но при этом, состояние шлейфа прибора ОПС уже не будет отслеживаться. Повторно поставить объект на охрану можно, если произвести взятие объекта “вручную” командой с пульта. Сравните с объектом Атлас (см. выше), который сам перейдет в состояние “взят”.

От ручного объекта могут поступать следующие сообщения.

ВЗЯТИЕ. Означает переход объекта во взятое состояние, при котором состояние охранного шлейфа объекта будет контролироваться на пульте. Для “ручных”, объект берется под охрану по команде “перевзятие” с пульта, если на охраняемом объекте включен и исправен прибор ОПС.

СНЯТИЕ. Означает переход объекта в снятое состояние. Для “ручных” объектов снятие, также как и взятие, выполняется по команде с пульта.

ВХОД и ТРЕВОГА. Два сообщения, которые означают разрыв охранного шлейфа объекта. Однако для объектов с типом охраны КТС и ОПС+ обрыв шлейфа означает тревогу. Для объектов ОПС - то же событие рассматривается программой сообщение ВХОД и запускает отсчет времени на обработку входа на объект. По истечении заданного времени, если объект не был снят с охраны, уже сама программа искуственно выдает сообщение ТРЕВОГА.

НЕИСПРАВНОСТЬ(параметр). Означает неисправность, но для аппаратуры типа Центр - не самого устройва ОПС на объекте, а части схемы блока УТ отвечающей за контроль данного объекта. Для аппаратуры типа Атлас сообщения о неисправности направления никогда не выдаются.

НЕИСПРАВНОСТЬ(ПРГ). Не следует путать данное сообщение с предыдущим. Как и в предыдущем случае, сообщение не означает неисправности прибора на объекте. Сообщение исскуственно формируется программой в случае превышения допустимой задержки аппаратуры на передачу любой команды.

5.2.1. Карточка “ручного” объекта


Карточка "ручного" объекта

5.2.1. Карточка “ручного” объекта

Карточка ручного объекта рис *.* по виду мало отличается от карточки любого другого устройства, описанной ранее. Отдельно следует обратить внимание на меню операций в карточке объекта. Состав его пунктов, для “ручного” объекта, меняется в зависимости от состояния объекта на момент вызова карточки. Пункты меню операций дублируются так называемыми “горячими клавишами”, нажатие которых равносильно выбору пункта меню и нажатию клавиши Enter.

Список “горячих клавиш”, действующих в карточке “ручного” объекта приводится ниже:

F2 | Увеличение/уменьшение поля раздела карточки
F3 | Вызов окна параметров объекта (расписания охраны)
F4 | Проверка ключа "Атлас"
F5 | Взять без выхода (ОПС)
F6 | Взять без выхода (КТС)
F7 | Взять с выходом (ОПС)
F8 | Снять с охраны
F9 | Отменить взятие
F10 | Повторить взятие
"↑" и "↓" | Выбор х/о из списка

Если объект имеет связанные с ним ключи, т.е. все операции с объектом распространяются на несколько объектов сразу, то для подтверждения операции будет открыто окно вида рис *.*.

Объекту может быть сопоставлено до 3-х связанных ключей. В приведенной выше панели, первым в списке отображается ключ объекта, для которого была открыта карточка, остальные записи в списке - связанные ключи. На момент начала операции все ключи будут выбраны, т.е. по умолчанию операция распространяется на сам объект и все связанные ключи. Если нужно выполнить операцию только для некоторых ключей, список выбранных можно изменить цифровыми клавишами <1>...<4>, соответствующими каждому пункту списка.


Постановка "ручного" объекта на охрану

5.2.2. Постановка “ручного” объекта на охрану

Постановку объекта на охрану можно выполнить из меню операций в карточке “ручного” объекта. Существуют 3 варианта постановки на охрану объекта:
1) взять с выходом как ОПС; 2) взять без выхода ОПС; 3) взять без выхода КТС.

Взять объект с выходом как ОПС - это обычный вариант постановки на охрану объекта ОПС. В этом случае программа выполняет задержку между подачей команды на взятие оператором и уходом команды аппаратуре. Время задержки определено параметром “Время на выход”, значение по умолчанию - 90 секунд.

В случае взятия без выхода программа сразу подает команду аппаратуре. Такой вариант взятия может использоваться для немедленной постановки объекта на охрану, например, при “невзятии” объекта на охрану в результате предыдущей попытки постановки объекта на охрану.

Подав команду на один объект, оператор может работать с другими и не дожидаться результатов выполнения первой команды. Объекты, по которым оператором поданы команды на взятие, но команда о взятии на аппаратуру еще не передана, находятся в т.наз. “буфере взятий объектов”. Буфер взятий уже упоминался в главе “Журналы системы”. Окно буфера взятий (рис *.*) открывается сразу после подачи оператором команды на взятие с выходом, при этом окно карточки объекта закрывается. Окно буфера можно также открыть из основного экрана программы : вызвать меню журналов системы, нажав Пробел, и выбрав клавишами "↑" и "↓" пункт “Буфер взятий объектов”, нажать Enter.

Список берущихся объектов упорядочен по их ключам в БД. Перемещения по списку выполняются клавишами "↑" и "↓" , для выбранной записи нажатием Enter можно открыть карточку объекта.


Постановка на охрану объекта типа Центр

5.2.2.1. Постановка на охрану объекта типа Центр

Переход состояний объекта Центр в процессе его постановки на охрану иллюстрирует диаграмма рис. *.*.

При постановке объекта Центр на охрану, проверка объекта никак не автоматизирована. Постановка объекта Центр обычно выглядит следующим образом.
1) Клиент звонит на пульт охраны с просьбой о постановке объекта на охрану и проводит проверку прибора ОПС. Клиент включает прибор и, если он исправен, кратковременное нажатие на рычаг телефона не должно прервать связь с оператором пульта.
2) Оператор дает клиенту после проверки подтверждение, что объект будет поставлен на охрану и подает команду на взятие. При этом только начинается отсчет времени на выход (определенного параметром “Время выхода”) и объект переходит в состояние ОЖИДАЕТ ВЫХОДА. Телефонная линия клиента при этом не переключается на станционную аппаратуру системы, и телефонная связь с клиентом не прерывается.
3)После этого, если взятие не будет отменено, остальные действия будут выполнены программой пульта.
4) Программа по истечении времени проверки подает команду контроллировать состояние объекта на станционную аппаратуру. Пока команда не отправлена на аппаратуру, объект будет находится в состоянии ОЖИДАЕТ КОМАНДУ, после - в состоянии ОЖИДАЕТ ВЗЯТИЕ. Если команда выполнится успешно и УТ Центр обнаружит включенный прибор ОПС на телефонной линии объекта, тогда на пульт придет сообщение ВЗЯТИЕ от объекта. Иначе будет выдано сообщение НЕВЗЯТИЕ.

Если истекло время выхода, или время на подачу команды, или время на ожидание сообщения взятия, программа выдаст сообщение НЕИСПРАВНОСТЬ(ПРГ) и переведет объект в состояние НЕИСПРАВЕН(берется). Два последних интервала времени задаются для всех объектов одновременно. Время выхода для каждого объекта может быть задано индивидуально.


Постановка на охрану объекта типа АТЛАС

5.2.2.2. Постановка на охрану объекта типа АТЛАС

Для объекта Атлас диаграмма переходов приведена на рис *.*.

Процесс постановки на охрану состоит из следующих этапов:
1) Оператор подает команду на взятие объекта, по которой объект переходит в состояние “ОЖИДАЕТ КОМАНДУ” до момента передачи команды аппаратуре. По факту ухода команды объект устанавливается в состояние “ОЖИДАЕТ ВЗЯТИЕ”.
2) Если объект берется по варианту “Взять ОПС с выходом”, проверка для клиента заключается во включении прибора ОПС. При этом, если прибор ОПС исправен и охранный шлейф замкнут, на пульте состояние объекта меняется на “ОЖИДАЕТ ВЫХОДА”. После подтверждения оператором исправности прибора, клиент может покинуть объект. Оператор после проверки может уже не контроллировать состояние объекта, остальные действия выполнит программа.
3) При разорванном шлейфе (открытой входной двери) объект переходит в состояние "ОЖИДАЕТ ЗАКРЫТИЕ", при восстановлении - назад в "ОЖИДАЕТ ВЫХОДА".
4) По истечении времени на выход, если объект находится в состоянии "ОЖИДАЕТ ВЫХОДА" (прибор включен, шлейф замкнут), программа выдаст по объекту сообщение "ВЗЯТИЕ" и переведет его в состояние "ВЗЯТ".

Если объект находится в состоянии "ОЖИДАЕТ ЗАКРЫТИЯ" (прибор включен, но шлейф разомкнут, т.е. сработал датчик или открыта входная дверь) на момент истечения времени на выход, по объекту программой будет выдано сообщение "НЕВЗЯТИЕ" и он перейдет в состояние "НЕВЗЯТИЕ".

Если объект берется на охрану как ОПС/КТС без выхода, то после подачи команды оператором, команда передается аппаратуре (состояние "ОЖИДАЕТ ВЗЯТИЕ") и объект при получении сообщения "ВЗЯТИЕ" или "НЕВЗЯТИЕ" без задержки переходит в состояние "ВЗЯТ" или "НЕВЗЯТИЕ".

Если передача команды аппаратуре выполняется за время больше, чем допустимое (задается для всех объектов одновременно, обычно 10-15 секунд), то программа выдает сообщение "НЕИСПРАВНОСТЬ(ПРГ)" и переводит объект в состояние "НЕИСПРАВЕН".


Снятие "ручных" объектов с охраны

5.2.3. Снятие “ручных” объектов с охраны

Снятие с охраны объектов Атлас и Центр происходит одинакого. Снятие выполняется из любого состояния взятого объекта (“ВЗЯТ”, “ТРЕВОГА”, “НЕИСПРАВНОСТЬ(взят)” и др.). Диаграмма переходов состояний при снятии приведена на рис *.*.

Для снятия ранее взятого объекта, оператором подается команда “Снять” из меню карточки объекта. При этом программа переводит объект в состояние “ОЖИДАЕТ КОМАНДУ СНЯТИЯ”. В этом состоянии объект находится до передачи команды аппаратуре, после которой он переходит в состояние “ОЖИДАЕТ СНЯТИЕ”. При получении в ответ от аппаратуры сообщения “СНЯТИЕ”, объект переходит в снятое состояние. Если в процессе снятия истекает допустимое время на уход команды (обычно 10-15 секунд), объект переходит в состояние НЕИСПРАВЕН(снят) с выдачей сообщения “НЕИСПРАВНОСТЬ(ПРГ)”.

При повторной подаче команды “Снять” в одном из состояний снимающегося с охраны объекта, объект сразу переводится в состояние “СНЯТ”. На диаграмме это действие названо “ускоренным снятием”.


Смена режима охраны объекта

5.2.4. Смена режима охраны объекта

Для уже взятого на охрану объекта может быть изменен режим постановки на охрану с “КТС” на “ОПС” и наоборот. Смена режима объединяет в себе как бы две операции - снятие объекта и последующее взятие с другим типом охраны.

Переход с “КТС” на “ОПС” из любого состояния взятого объекта выполняется по команде “взять с выходом(ОПС)”. При этом в ленту проходит сообщение СНЯТИЕ и объект переводится в состояние “ОЖИДАЕТ ВЫХОДА(берется)”. Сообщение “СНЯТИЕ” необходимо, чтобы отметить, что объект некоторое время, пока изменяется тип охраны, не охраняется.

Для аппаратуры типа “АТЛАС” после этого, объект переходит между состояниями “ОЖИДАЕТ ВЫХОДА(берется)” и “ОЖИДАЕТ ЗАКРЫТИЯ(берется)”. А после истечения времени выхода - соответственно в состояние “ВЗЯТ(ОПС)” или “НЕВЗЯТИЕ”. Т.е. выполняется вся последовательность постановки на охрану, за исключением проверки прибора. Объект “ЦЕНТР” находится в состоянии “ОЖИДАЕТ ВЫХОДА(берется)” в течении времени данного на выход. После прохождения команды “перевзятия” (дается автоматически программой) и получении с аппаратуры сообщения “ВЗЯТИЕ”, объект “ЦЕНТР” переходит в состояние “ВЗЯТ(ОПС)” или “НЕВЗЯТИЕ” (если шлейф объекта нарушен).

Переход с “ОПС” на “КТС” выполняется по команде “взять без выхода(КТС)” из состояния “ВЗЯТ(ОПС)” для объектов “Атлас” и “Центр” заключается в простом переводе объекта в состояние “ВЗЯТ(КТС)”. При этом в ленте фиксируется сообщение “ВЗЯТИЕ”.

Если смена типа охраны производится после поступления сообщений “ВХОД” или “ТРЕВОГА”, из любого состояния взятого объекта, но не состояния “ВЗЯТ”, перед взятием объекта как “КТС” аппаратуре посылается команда на снятие и в ленте фиксируется сообщение “СНЯТИЕ”, а затем объект переводится в состояние “ОЖИДАЕТ ВЫХОДА(берется)”. Сразу после получения сообщения “ВЗЯТИЕ” от аппаратуры, объект переводится в состояние “ВЗЯТ(КТС)”. Т.е. выполняется та же последовательность, что и при постановке объекта как “КТС”, но без проверки прибора.


5.2.5. Настройка списка паролей для ручных объектов

В АСЦН Юпитер существует возможность ввести дополнительную проверку пароля при снятии объекта с охраны. Если в Вашей организации используется эта возможность, то при постановке ручного объекта (типа АТЛАС или ЦЕНТР) на охрану, в карточке снятого объекта будет выведен пароль текущего дня. Когда объект будет поставлен на охрану, этот пароль зафиксируется в том состоянии, в котором он был на момент постановки, и не будет изменяться до снятия объекта с охраны.

Таким образом, при постановке объекта на охрану, дежурная должна назвать клиенту пароль текущего дня. При снятии объекта с охраны, в карточке объекта, дежурная увидит этот пароль. Если клиент, снимающий объект с охраны, не называет правильный вариант пароля, дежурная может вместо снятия объекта с охраны зафиксировать этот факт. Для этого случая в меню карточки используется пункт «-». При его выборе, в ленте фиксируется сообщение ТРЕВОГА(ПАРОЛЬ).

Если снятие и взятие выполняются с номером хозоргана 0-дежурная, или 98-техник, или 99-офицер, то пароль заданный ранее при взятии объекта на охрану с другим номером хозоргана остается. Т.е. при каких-либо проверках аппаратуры (снятиях/взятиях) на объекте без участия клиента нужно указывать номер х/о дежурной, техника или офицера.

Настройка списка паролей для ручных объектов

Чтобы использовать возможность программы по установке дополнительного пароля при работе с ручными объектами, который называется дежурной клиенту при постановке на охрану и называется клиентом при снятии с охраны, необходимо настроить список паролей.

Списки паролей - это файлы dBase III, в каждом хранится список паролей на один месяц. Имя файла имеет вид pswMM_YY.dbf, где MM-месяц, YY-год. Файлы должны находиться в каталоге, заданном в настройках путей программы параметром «Каталог паролей». Для генерации файлов паролей используется утилита make_psw.exe, которая, вероятнее всего, у Вас находится в подкаталоге UTIL каталога интерфейсной программы. При запуске без параметров выдается подсказка по ключам командной строки:

:
c:\Jupiter.win\Password> make_psw
Утилита формирования файла паролей для АРМ ДПУ Юпитер v.5.03.
Файлы имеют имена pswMM_YY.dbf (MM-месяц, YY-год).
используйте: MAKE_PSW.EXE -<ключ 1› -<ключ N›
ключи:
M= - задание номера месяца (0 - все за год), по умолчанию текущий
Y= - задание года (1999,2000,2001...), по умолчанию текущий
D= - задание файла словаря, по умолчанию psw_dict.txt
словарь - файл строк с паролями, разделенными символами
'пробел', 'перевод строки', 'возврат каретки',
'.', ',', ':', ';', '!', '|'.
R - включает режим случайного выбора ключей

Словарь - это обычный текстовый файл, который можно подготовить, например, встроенным редактором Norton Comander. Файл состоит из набора слов, разделенных пробелами, переводами строки, символами «.», «,», «:», «!». Например, файл pass.txt будет содержать:

Анапа,
Астрахань,
Архангельск,
Ярославль,
Казань,
Пермь

После того как файл со словами-паролями подготовлен, запускаете утилиту, строкой примерно следующего вида:

c:\Jupiter.win\Password> make_psw -M=4 -Y=2000 -D=pass.txt

Утилита создаст файл psw04_00.dbf с паролями на апрель 2000 года

Если необходимо перетасовать слова случайным образом, то утилиту следует запустить с ключом -R. Готовые файлы паролей необходимо поместить в упомянутый ранее каталог файлов паролей.


Команды опроса ПОИСК.

5.5.1 Команды опроса ПОИСК

К данному типу команд относятся следующие:

Опрос типов шлейфов | подается на шлейф, ППКОП-8 или систему в целом, в последнем случае соответствует подаче отдельных команд на все ППКОП-8 системы. Выполнение данной команды заключается в передаче на пульт информации о типах шлейфов.
Опрос задержек шлейфов | подается на шлейф, ППКОП-8 или систему в целом, в последнем случае соответствует подаче отдельных команд на все ППКОП-8 системы. Выполнение данной команды заключается в передаче на пульт информации о величине задержек срабатывания шлейфов, при подаче на ППКОП-8 и систему передается информация только по шлейфам с типом "Охранный с задержкой"
Опрос шлейфов по разделам | подается на шлейф, ППКОП-8 или систему в целом, в последнем случае соответствует подаче отдельных команд на все ППКОП-8 системы. Выполнение данной команды заключается в передаче на пульт информации о распределении шлейфов по разделам.
Опрос состояния разделов | подается на раздел или систему в целом, в последнем случае соответствует подаче отдельных команд на все разделы системы. Выполнение данной команды заключается в передаче на пульт информации о текущем состоянии разделов.
Опрос номера версии | подается на расширитель или систему в целом, в последнем случае соответствует подаче отдельных команд на все расширители системы. Выполнение данной команды заключается в передаче на пульт информации о номерах версий программного обеспечения расширителей, образующих систему.
Опрос идентификатора | подается на расширитель или систему в целом, в последнем случае соответствует подаче отдельных команд на все расширители системы. Выполнение данной команды заключается в передаче на пульт информации об идентификаторе присвоенном расширителю.
Опрос режима работы | подается на ПУ, УВС-8П, УВС-16, РР-2, РИ-8. Выполнение данной команды заключается в передаче на пульт информации о режиме работы соответствующего расширителя
Опрос задержки на выход | подается на раздел. Выполнение данной команды заключается в передаче на пульт информации о значении задержки на выход для раздела


Команды перевзятия ПОИСК.

5.5.2 Команды перевзятия ПОИСК

К данному типу команд относятся следующие:

Перевзятие типов шлейфов | подается на шлейф, ППКОП-8 или систему в целом, в последнем случае соответствует подаче отдельных команд на все ППКОП-8 системы. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации о типах шлейфов.
Перевзятие задержек шлейфов | подается на шлейф, ППКОП-8 или систему в целом, в последнем случае соответствует подаче отдельных команд на все ППКОП-8 системы. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации о величине задержек срабатывания шлейфов, при подаче на ППКОП-8 и систему в целом передается информация только по шлейфам с типом "Охранный с задержкой"
Перевзятие шлейфов по разделам | подается на шлейф, ППКОП-8 или систему в целом, в последнем случае соответствует подаче отдельных команд на все ППКОП-8 системы. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации о распределении шлейфов по разделам.
Перевзятие состояния разделов | подается на раздел или систему в целом, в последнем случае соответствует подаче отдельных команд на все разделы системы. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации о текущем состоянии разделов.
Перевзятие идентификатора | подается на расширитель или систему в целом, в последнем случае соответствует подаче отдельных команд на все расширители системы. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации об идентификаторе присвоенном расширителю.
Перевзятие режима работы | подается на ПУ, УВС-8П, УВС-16, РР-2, РИ-8. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации о режиме работы соответствующего расширителя
Перевзятие задержки на выход | подается на раздел. Выполнение данной команды заключается в передаче на объектовое устройство с пульта информации о значении задержки на выход для раздела


Команды управления ПОИСК.

5.5.3 Команды управления ПОИСК

К данному типу команд относятся следующие:

Сброс сирены | подается на раздел или систему в целом. Команда отключает сирену, включенную на объекте в результате возникновения тревожного события.
Сброс индикации пожара | подается на раздел. Команда приводит к формированию сигнала, приводящего к сбросу датчиков, подключенных к пожарным шлейфам, а также к очистке индикации пожара по указанному разделу.
Сброс индикации тревог | подается на раздел. Команда приводит к очистке индикации тревоги указанного раздела.
Сброс индикации неисправности | подается на раздел. Команда приводит к очистке индикации неисправности указанного раздела, также команда приводит к формированию сигнала, приводящего к сбросу датчиков, подключенных к пожарным шлейфам,
Сброс блока | подается на систему в целом. Команда приводит к полной очистке содержащейся в блоках системы информации, с последующим перезапуском всей системы. Команда может использоваться при переводе объектового устройства на другое направление, УТ или АТС без необходимости физической очистки прибора на объекте.
Теплый сброс блока | подается на систему в целом. Команда приводит к перезапуску блоков системы без удаления содержащейся в них информации. Команда позволяет перезапустить систему при возникновении сбоев в ее работе.
Снять с охраны | подается на раздел. Команда выполняет принудительное снятие раздела с охраны по требованию оператора.
Поставить на охрану | подается на раздел. Команда выполняет принудительное взятие раздела на охрану по требованию оператора.


Настройка примечаний

7.11. Настройка вывода звука через звуковую карту

Внимание: Вывод звуковых сообщений через звуковую карту поддерживается СПИ Юпитер начиная с версии 6.0.14.

Для настройки СПИ Юпитер для вывода звука через звуковую карту необходимо обновить версию СПИ Юпитер до версии 6.0.14 или более поздней. При запуске СПИ Юпитер версии 6.0.14 в каталоге установке Юпитера (обычно C:\Jupiter.win\) создается каталог Sound. В него необходимо скопировать следующие файлы:
alarm.wav - проигрывается при поступлении тревоги с объекта;
alarmc.wav - проигрывается при поступлении тревоги с объекта, находящегося в буфере проверок.
Файлы типа 1.wav, 2.wav и т.д. Данные файлы проигрываются при поступлении сообщения от объекта. Номер файла выбирается в зависимости от значения поля "Звук" таблицы сообщений. Если оно равно нулю - сообщение проходит без звука.

Далее необходимо войти в СПИ Юпитер 6.0 с инженерным паролем, меню "Настройка\Расположение файлов". В появившемся диалоге в поле "Каталог звуков (*.wav)" необходимо указать путь к каталогу с образцами звуков (обычно это C:\Jupiter.win\Sound):

После этого необходимо войти в меню "Настройка\интерфейс" и в появившемся диалоге установить флаг: "Выводить звук через звуковую карту".

После этого необходимо перезапустить СПИ Юпитер, чтобы изменения вступили в силу. Опять войти в СПИ юпитер как инженер и протестировать звуки через пункты меню: "Отладка\Тест звука". Если тестирование прошло успешно - настройка на этом закончена.


Процедуры перевзятия и опроса

5.3. Процедуры перевзятия и опроса

Для различных устройств АК и УТ в меню операций (в панели объектов и карточке) имеются пункты “Перевзять” и “Опрос”. Ранее процедуры перевзятия и опроса уже упоминались. “Перевзятие” устанавливает информацию в устройстве в соответствии с конфигурацией и информацией на пульте о состоянии устройств. “Опрос”, наоборот, считывает имеющуюся в устройстве информацию о состоянии подчиненных устройств и устанавливает состояние устройств в конфигурации на пульте в соответствии с этими данными. Однако, существуют особенности выполнения этих команд разными устройствами.

1. УТ Комета.

По команде перевзятия для УТ Комета для УТ передается информация о том, какие ГК включены в конфигурацию объектов на пульте. Если УТ, по умолчанию, считало все ГК подключенными, а неподключенные направления - неисправными ГК, в процессе перевзятия УТ получает информацию, с какими ГК оно должно работать. Вдобавок выполняется перевзятие всех подключенных к УТ ГК. Информация выдается по всем ГК, как при перевзятии каждого ГК в отдельности. Выполнение перевзятия УТ Комета завершается двумя сообщениями “опрошен УТ”, с выдачей неисправностей и восстановлений по всем бывшим/ставшим неисправными ГК.

Опрос УТ Комета выполняется как опрос всех подключенных ГК. При опросе УТ на пульт передается информация о состоянии ГК и объектов которой располагает УТ, а не полученная с ГК. Поэтому, опрос УТ выполняется несколько быстрее перевзятия, но обращения к ГК при этом не происходит.

2. ГК Комета.

При подаче команды перевзятия на ГК Комета, УТ Комета передает ее на ГК. Далее УТ и ГК выполняют работу, скрытую от пользователя: ГК по всем взятым ИО выдает сообщения “взятие”, которые завершаются сигналом дежурного режима.

Пользователи, знакомые с АСЦН Юпитер версии до 4.00, должны знать об этой последовательности сообщений, которые выдавались программой пульта в течении некоторого (около 20-30 секунд) времени. С переходом на версию ПО Юпитер 5.00 и введением нового протокола обмена данными УТ-КПЦО-Компьютер, УТ выдает всю информацию в виде одного сообщения с запакованными результатами перевзятия, после выполнения всей процедуры. В ленте сообщение фиксируется в виде пакета сообщений “ПЕРЕВЗЯТ- . . . -ДЕЖУРНЫЙ РЕЖИМ”, пришедших в одну секунду.

При опросе ГК на пульт передается информация о состоянии ГК и объектов, которой располагает УТ, а не полученная с ГК. Поэтому, опрос УТ выполняется несколько быстрее перевзятия, но обращения к ГК при этом не происходит.

3. УТ Центр и УТ Атлас.

Команда перевзятия для УТ Центр содержит информацию о каждом направлении только в 2-х вариантах.
1) Направление было на охране или бралось. Тогда по команде перевзятия, объект будет взят на охрану, или перейдет в состояние тревога.
2) Направление было снято или снималось с охраны. Тогда объект будет снят с охраны.

Если по команде на УТ не удалось переключить соответствующую линию, объект может выдать сообщение “НЕИСПРАВНОСТЬ” и перейти в состояние “НЕИСПРАВЕН(взят)” или “НЕИСПРАВЕН(снят)”.

При опросе, УТ только выдает всю накопившуюся в результате команд с пульта и изменений на объектах информацию о состоянии объектов.

Внимание: Команды перевзятия и опроса для УТ Центр не столь безобидны, как те же команды для УТ Комета. При перевзятии УТ Центр может произойти взятие на охрану объекта, который в этот момент ожидал команду снятия, либо был в состоянии “НЕВЗЯТИЕ”, которое не было сброшено. При этом телефонная линия клиента будет принудительно переключена на аппаратуру охраны и, если прибор ОПС не был выключен, объект будет ошибочно взят на охрану.

По команде опроса есть риск потерять все ожидающие в этот момент выполнения команды (на взятие и снятие) поданные по объектам данного УТ. Поэтому команду опроса УТ Центр можно выполнять только в экстренных случаях, например, при включении резервного компьютера с устаревшей информацией о состоянии объектов. Команду перевзятия УТ можно выполнить при запуске УТ Центр; однако, эта команда должна быть подана автоматически в подобной ситуации.

В любом случае, и при перевзятии, и при опросе УТ Центр, желательно убедиться в отсутствии команд по объектам УТ перед подачей команды на УТ. И, особенно для “ручных” объектов, необходимо понимать, когда нужно подавать команду перевзятия, а когда - команду опроса.

ВАЖНО. Если Вы не видите в течении нескольких секунд результатов подачи команды, возможно, что команда ожидает в очереди команд. Не следует повторять многократно одну и ту же команду в течении короткого интервала времени,а особенно команду к УТ, т.к. это замедляет работу всей системы. Помните, что программа не может “забыть” о поданной команде. А в случае невозможности подачи команды, например, по причине большого числа находящихся в очереди команд, программа специально известит пользователя об этом.

Различие УТ Центр и Атлас: УТ Центр в отличие от УТ Атлас может вернуть состояние направления как “НЕИСПРАВЕН”.

4. УТ Юпитер.

По команде перевзятия для УТ Юпитер для УТ передается информация о том, какие направления включены в конфигурацию объектов на пульте. Если УТ, по умолчанию, считало все направления подключенными, а неподключенные направления - неисправными, в процессе перевзятия УТ получает информацию, с какими направлениями оно должно работать. В отличии от перевзятия УТ Комета, не происходит перевзятие направлений.

Опрос УТ Юпитер выполняется как опрос всех подключенных направлений. При опросе УТ на пульт передается информация о состоянии направлений, которой располагает УТ.

5. УОО Юпитер.

При перевзятии УОО Юпитер на УОО передается инфомация с пульта о конфигурации шлейфов УОО.

При опросе УОО Юпитер возвращает свое состояние: “Снят” или “Взят”.

6. ББ Юпитер.

При перевзятии ББ Юпитер на ББ передается инфомация с пульта на ББ о состоянии ответчиков на 3 линиях ББ. Передаются состояния: “ТРЕВОГА”, “ВЗЯТ”, “СНЯТ”.
Внимание: Если на пульте устаревшая информация (при замене компьютера) может произойти взятие или снятие ИО Юпитер.

При опросе ББ Юпитер возвращает информацию о состоянии ответчиков на 3 линиях.

7. ИО Юпитер.

При перевзятии ИО Юпитер на ИО передается инфомация с пульта о конфигурации шлейфов ИО.

При опросе ИО Юпитер возвращает состояние своих шлейфов.


Проверка приборов ОПС объекта

5.4. Проверка приборов ОПС объекта

Во время монтажа или проверки приборов ОПС на объектах, на пульт могут приходить сообщения никак не связанные с охраной объектов. Состояние объекта, где проводятся работы, также может меняться произвольным образом. Для этого случая в интерфейсной программе предусмотрен режим проверки объектов.

В режиме проверки блокируется вывод любых сообщений от объекта, но изменения его состояния можно отследить в окне проверок рис. *.*.

Постановка объекта на проверку начинается с нажатия клавиши “/” (на дополнительном цифровом поле клавиатуры), снятие с проверки - с нажатия “*”. При этом будет открыто соответствующее окно ввода ключа объекта рис *.*.

По нажатию “Esc” можно вернуться в основной экран программы. После набора ключа и нажатия “Enter”, объект будет соответственно поставлен на проверку или снят с проверки. При этом появится или будет убрана запись в окне проверяемых объектов. При выполнении постановки/снятия объекта с проверки в ленту об этом будет занесено сообщение, в параметре которого стоит номер дежурного, выполнившего операцию.

В окне проверяемых объектов для перемещения по записям используются клавиши "↑" и "↓". По нажатию “Esc” для выбранной записи будет открыта карточка объекта. Для выбранного в окне проверок объекта, окно снятия с проверки уже будет содержать ключ объекта.

Проверка любого объекта может длиться время, не превышающее заданного в настройках программы, обычно 10 мин. После чего он автоматически переходит в нормальный режим работы.


Команды ПОИСК

5.5. Команды ПОИСК

    Для получения конфигурации системы ПОИСК, а также для изменения значения некоторых параметров имеется возможность подачи ряда команд.

  1. Команды, для направления ПОИСК в целом

  2. Команды для расширителей

  3. Команды для разделов

Доступ к командам можно получить нажатием Пробел или правой кнопки мыши на выбранном объекте:

    Все команды можно разделить на три группы:

  1. Команды опроса, позволяют запросить информацию с объектового устройства

  2. Команды перевзятия, позволяют передать информацию на объектовое устройство.

  3. Команды управления устройством, позволяют изменять состояние объектового устройства.


Архив сообщений системы

6.1. Архив сообщений системы

Переход в архив сообщений выполняется из основного экрана программы по нажатию клавиши . По умолчанию загружаются все сообщения за последний месяц. Во время загрузки перед пользователем выводится окно:

После окончания выборки открывается окно архива сообщений:

  1. Маркер (указатель) выбранной записи
  2. Ключ устройства в БД Ладога и конфигурации АСЦН Юпитер
  3. Сообщение от огбъекта
  4. Номер дежурного пульта во время прихода сообщения
  5. Время получения сообщения
  6. Дата получения сообщения
  7. Номер выбранной записи и общее число записей

Пролистать записи в архиве сообщений можно клавишами “PgUp”, “PgDown”, "↑" и "↓". По нажатию Enter открывается карточка объекта. По нажатию пробела открывается меню вида рис. *.*.

Период - изменения периода выборки. После выбора данного пункта меню откроется диалог выбора периода выборки:

Пункт “Фильтр“ открывает окно установки фильтра рис.*.*.

  1. Включить фильтр по ключам
  2. Включить фильтр по сообщениям

Пункт “Отмена Фильтра“ отменяет установленный фильтр.

Пункт меню операций архива сообщений “Печать” открывает панель установки диапазона печатаемых записей, как в архиве обработанных тревог. Напомним, что диапазон номеров записей при открытии панели устанавливается с первой по последнюю. А куда будут выводиться данные - в файл или на принтер, определяется настройками печати программы.


Синтезированные ключи устройств в сообщениях

6.2. Синтезированные ключи устройств в сообщениях

Синтезированными ключами здесь называются исскуственно формируемые ключи несуществующих объектов. Ключи используются в сообщениях от таких объектов. При формировании ключа программа ориентируется на адрес объекта в сети устройств передачи данных, т. е. на те номера устройств, которые были бы выведены в карточке объекта (КПЦО, Линия, УТ, Напрравление, Объект), если бы объект был включен в конфигурацию.

Сообщения с синтезированными ключами могут приходить от устройств, которые уже подключены, но на пульте о них не введена информация в конфигурацию. Сообщения с такими ключами могут быть и результатом сбоев связи и неисправностей аппаратуры.

Далее приводится рис. *.*, поясняющий способ формирования синтезированного ключа драйвером аппаратуры.

Ниже приводятся примеры синтезированных ключей

12A185 | Сообщение от 5-го ответчика, 18-го ГК(ББ), 10-го УТ 2-й линии 1-го КПЦО
238450 | Сообщение от 45-го направления, 8-го УТ, 3-й линии 2-го КПЦО
141000 | Сообщение от 1-го УТ, 4-й линии 1-го КПЦО

Внимание: отличия от версии Юпитер 5.x.x “уплывание” ответчика Комета в поле ключ передается не синтезированный ключ, а ключ ГК.
Необходимо помнить, что синтезированный ключ генерится в заголовке панели объектов программы.


"Уплывание" ответчика Комета

6.3. “Уплывание” ответчика Комета

Эффект “Уплывание” ответчика Комета возникает, когда номер ответчика начинает распознаваться ГК Комета как номер соседнего с реально установленным ИО. Например, от ответчика №2 на пульт приходят сообщения как от №1 или №3.

В связи с частым появлением в последнее время на старых блоках Кометы случаев так называемого “уплывание” ответчика Комета, было изменено формирование для ответчика Кометы сообщения от исключеного объекта. Если ИО не включен в конфигурацию, возможно два варианта:

  1. ГК включен в конфигурацию - сообщение будет содержать не синтезированный ключ, а ключ вышестоящего ГК, в параметре - номер ответчика.
  2. иначе - передается синтезированный ключ как и в DOS версии .


Установка путей размещения файлов программы

7.1. Установка путей размещения файлов программы

Внимание: не рекомендуется менять установки путей по умолчанию. Чтобы изменения вступили в силу - необходимо перезапустить СПИ Юпитер 6.0. Это необходимо сделать только для резервного компьютера (См. Подготовка резервного компьютера).

Диалоговое окно настройки путей размещения файлов программы приведено на рис *.*.

Обычно, пути файлов настраиваются, как показано на рис *.*.

Лог-файл - файл, в котором фиксируется информация, как запуск и остановка пульта, срабатывание таймеров и т.д. Так же в данный файл пишутся некоторые ошибки, такие как переполнение буферов.

Устройства 1 уровня - файл, в котором содержится информация о состояниях и настройках устройств КПЦО, АТС и УТ.

Контрольные объекты - файл, в котором содержится информация о объектах, поставленных на контроль и время их автоматического снятия с контроля.

Необработанные тревоги - файл, в котором находятся тревоги, которые оператор видит в окне "Необработанные тревоги".

Таймеры ручных объектов - файл, в котором содержится информация о взведенных в данный момент таймерах.

Примечание объектов - файл, в котором содержатся примечания объектов.

Путь к лентам отладки - каталог, в котором находится информация о пакетах принятых и переданных на КПЦО.

Путь к лентам сообщений - каталог, в котором находятся принятые сообщения от объекта (бывший каталог Ribbon).

Путь к лентам тревог - каталог, в котором находятся обработанные тревоги.

Каталог паролей - каталог, в котором находятся пароли взятия для ручных объектов.

Каталог обновления - см. обновление БД Ладога.

Путь к файлам Ладоги и БД настроек пока не используется.


Установка таймеров программы

7.3. Установка таймеров программы

Окно установки таймеров программы изображено на рис *.*. Все значения параметров задаются в секундах.

Все, кроме "общих", параметры используются только при работе с “ручными” объектами Атлас и Центр. 3 первых параметра устанавливаются по умолчанию всем вновь добавляемым “ручным” объектам, однако, затем для каждого объекта эти значения могут быть изменены. Для удобства работы задать эти параметры желательно до того, как Вы начнете добавлять объекты в конфигурацию системы.

Параметр “Задержка проверки” имеет значение только для объектов типа Атлас, т.к. только этот тип позволяет программе на пульте отслеживать состояние прибора ОПС во время проверки. Параметр задает допустимое время задержки между началом постановки объекта на охрану и завершением проверки (переходом в состояние “ОЖИДАЕТ ВЫХОДА”). Превышение этого допустимого времени приведет к переходу объекта в состояние “НЕИСПРАВНОСТЬ(берется)”.

Настройка “Неохраняется комната хранения оружия” действует для объектов, у которых проставлен расширенный тип Оружие”. Если такой объект находится в снятом состоянии более указанного времени, то программа формирует сообщение ТРЕВОГА(НЕТ_ОХРАНЫ).

Настройка “Период проверки КТС” задает время в часах, в течении которого объекты, помеченные расширенным типом “КТС”, должны пройти проверку с дежурной пульта. Т.е. должны быть поставлены и сняты с проверки в окне проверок. Если объект не проверялся больше заданного времени, то в журнале КТС он будет мигать или отображаться более ярким цветом.

Параметр “Задержка выхода” задает задержку между началом постановки ручного объекта на охрану и, для объекта Центр - подачей команды на аппаратуру для переключения линии, для объекта Атлас - перевода объекта программой во взятое состояние.

Параметр “Задержка входа” задает задержку между получением сообщения “ВХОД” (срабатыванием датчика объекта при текущем типе охраны ОПС) и выдачей программой сообщения “ТРЕВОГА”, если в это время не будет выполнено снятие объекта с охраны. Иными словами, это время в которое клиент должен позвонить на пульт, чтобы оператор успел снять объект с охраны. Напомним, что данный параметр действует для всех новых объектов, но его можно изменить для каждого объекта отдельно.

Параметр “Задержка команды” задает допустимую задержку для ухода команды на аппаратуру. При подаче достаточно большого (порядка 10-20) команд на аппаратуру, команды могут ожидать своей очереди на передачу длительное время, примерно по 5 секунд на каждую команду. При превышении данного периода времени на уход команды по объекту, программа переведет его в состояние “НЕИСПРАВНОСТЬ” в той фазе, где он находился до этого (брался, снимался, был взят). Разработчики считают значение 120 секунд для данного параметра оптимальным.

Параметр “Задержка ответа” задает задержку между подачей команды на “ручной” объект и ответом аппаратуры, например, командой перевзятия на направление Центр и сообщением “ВЗЯТИЕ”. Т.к. команды для “ручных” объектов обрабатываются достаточно быстро и сообщения “ручных” объектов передаются в системе в первоочередном порядке, значение задержки 10 секунд разработчики считают оптимальным.

Настройка “Неохраняется комната хранения оружия” действует для объектов, у которых проставлен расширенный тип «Оружие». Если такой объект находится в снятом состоянии более указанного времени, то программа формирует сообщение “ТРЕВОГА(НЕТ_ОХРАНЫ)”.

Настройка “Период проверки КТС” задает время в часах, в течении которого объекты, помеченные расширенным типом “КТС”, должны пройти проверку с дежурной пульта. Т.е. должны быть поставлены и сняты с проверки в окне проверок. Если объект не проверялся больше заданного времени, то в журнале КТС он будет мигать или отображаться более ярким цветом.


Настройка звука

7.4. Настройка звука

Внимание: Возможность вывода звука через звуковую карту реализовано в версии 6.0.12 и выше.

Настройка звука для вывода через звуковую карту.

Если в системе установлена звуковая карта, можно настроить СПИ Юпитер для подачи звуковух сигналов через нее. Данная возможность присутствует, начиная с версии 6.0.12. Для этого необходимо правильно установить драйвера звуковой карты для Windows, затем войти в СПИ Юпитер как инженер, через пункт меню "Настройка/Интерфейс" вызвать диалог:

В данном диалоге, необходимо установить переключатель: "Звуковое сопровождение" и "Выводить звук через звуковую карту". После этого в каталог "Sound" необходимо скопировать файлы:

  • alarm.wav - проигрывается при поступлении сигнала тревоги.
  • alarmc.wav -проигрывается при поступлении сигнала тревоги, если объект находится в буфере проверок.
  • 1.wav, 2.wav, 3.wav, 4.wav, 5.wav, 6.wav - проигрываются при прохождении сообщений, в настройке которых в параметре звук указана цифра от 1 до 6. См.: Настройка сообщений
После этого необходимо перезапустить СПИ Юпитер, войти как инженер и проверить звуки через меню: "Отладка/Тест звука". Если звук восспроизводится нормально, настройка на этом закончена.

Настройка звука для вывода через динамик (Windows 2000/XP).

Настройка вывода звука через встроенный динамик под Windows 98/ME при установке программы происходит автоматически. Под Windows 2000/XP вам необходимо скопировать файл snddrv.sys в каталог C:\WINDOWS\SYSTEM32, затем выполнить команду:

c:\>regini snddrv.reg

перезапустить компьютер, и проверить вывод звука через меню: "Отладка/Тест звука".

Внимание: Для успешного выполнения команды regini пользователь должен иметь привилегии администратора данного компьютера.

Содержание файла snddrv.reg:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\snddrv]
"Type"=dword:00000001
"Start"=dword:00000002
"Group"="Extended base"
"ErrorControl"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\snddrv\Enum]
"0"="Root\\LEGACY_SNDDRV\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001


Настройка БД

7.5. Настройка БД

Для работы СПИ Юпитер 6.0 использует две базы данных Microsoft Access 97 SP2:

  1. БД основных настроек - JupUser.mdb
  2. БД Ладога Windows версия - Ladoga.mdb

В БД основных настроек находятся таблицы:

  1. Таблица обрабатываемых сообщений
  2. Список пользователей и их зашифрованные пароли
  3. Список основных причин тревог
  4. Список основных примечаний

Таблица обрабатываемых сообщений состоит из:

  1. Код сообщения
  2. Текстовая расшифровка сообщения
  3. Цвет сообщения
  4. Признак, является ли данное сообщение тревожным

Не рекомендуется редактировать данные таблицы через Microsoft Access, настоятельно рекомендуем использовать для этого СПИ Юпитер 6.0.

СПИ Юпитер работает через ODBC драйвера. Чтобы СПИ Юпитер мог соединиться с базой данных необходимо создать ссылку на базу mdb-файл в конфигурации ODBC. При установке инсталлятор это делает автоматически, но в некоторых случаях, например, если на резервном компьютере храняться несколько рабочих мест, имеет смысл БД вынести в отдельный каталог на диске.
Мы предполагаем, что файл ladoga.mdb расположен в D:\Jupiter.win\ladoga\ladoga.mdb. Ему должна соответствовать запись в конфигурации ODBC - LadWin. для создания этой записи необходимо:

  1. Открыть панель объектов (Пуск/Настройка/Панель объектов)

  2. Открыть "источники данных ODBC (32)". Если такого пункта не существует - возможно не установлен Microsoft Access 97.

    В появившемся окне выбрать закладку "Пользовательский DSN" или "Системный DSN", где прописан псевдоним LadWin. По умолчанию, СПИ Юпитер прописывает псевдоним в "Пользовательском DSN". Если псевдоним LadWin найден - Вам необходимо выбрать псевдоним LadWin и нажать кнопку "Изменить" и перейти к пункту 7. Если псевдоним не найден - Вам необходимо нажать кнопку "Добавить..." для добавления нового псевдонима.

  3. Появится окно в котором Вам необходимо указать тип ODBC драйвера. Для mdb-файлов это "Microsoft Access driver (*.mdb)".

    И нажать кнопку "Готово".

  4. Откроется окно в котором в поле "Data Source Name" необходимо указать псевдоним: "LadWin".

  5. Нажать кнопку "Select..." для выбора расположения файла ladoga.mdb:

  6. После закрытия окна выбора базы данных, в поле "Database" будет указат путь к файлу ladoga.mdb.

  7. Для изменения пути к файлу ladoga.mdb, Вам необходимо нажать кнопку "Select.." и указать путь к файлу ladoga.mdb.

Аналогичным образом можно изменить путь к файлу основных настроек. Надо отредактировать или создать псевдоним "JupCommon", и указать путь к файлу JupUser.mdb.


Установка паролей

7.6. Установка паролей

Для настройки списка пользователей в программе вызывается панель списка пользователей рис. *.*.

Правила ввода данных в панели такие же, как и в панели ввода ключевых слов БД. Для ввода/редактирования записи пользователя открывается панель вида рис. *.*.

Номер дежурной в данной панели задается только при добавлении записи, при редактировании номер только выводится. Переход между пунктами блока выключателей “Привелегии пользователя” выполняется клавишами “<-”, “->” , “PgUp” и “PgDown”, отметка пункта - клавишей Пробел. Некоторые пункты из этого блока в данной версии программы еще не используются.

Пункт “Добавление/удаление объектов” разрешает работу пользователя с конфигурацией объектов. Для исключения случайных изменений конфигурации объектов в результате ошибочного ввода с клавиатуры и т.п. ситуаций, для операторов пульта данную функцию желательно отключить.

Пункт “Блокировка/разблокировка” разрешает выполнение блокировки /разблокировки устройств из меню операций для устройств в панели объектов. Напомним, что блокировка устройства приводит к тому, что все сообщения от устройства и его подчиненных будут игнорироваться программой. Блокировка нужна для запрета сообщений от реально несуществующих устройств, но уже введенных в конфигурацию системы и т.п. операций.

Пункт “Изменение установок” разрешает выполнение установок программы, которым и посвящен данный раздел руководства.

Пункт “Изменение паролей” разрешает пользователю изменять свой собственный пароль и другие данные пользователя, а также записи других пользователей.

Пункт “Установка времени” разрешает пользователю изменять текущее время на компьютере из программы. Панель установки времени вызывается по из основного экрана программы.

Пароль желательно задать для пользователей имеющих возможность изменять конфигурацию объектов, т.к. конфигурация является наиболее ценной информацией (в смысле ее ввода или восстановления).


Настройка сообщений

7.7. Настройка сообщений

Настройка сообщений программы позволяет определить свойства каждого сообщения, которое может придти от аппаратуры или быть сформированно программой, т.е. любого сообщения фиксирующегося в ленте и архивах. Изменение параметров сообщений может повлиять на логику работы программы. Например, любое сообщение можно определить как тревожное, и тогда оно будет обрабатываться соответствующим тревожным сообщениям образом. Таким образом изменение параметров сообщений является достаточно рискованной операцией, которую без особой необходимости выполнять не рекомендуется. Для сведения, настройки сообщений хранятся в файле EVENT.MGZ в каталоге исполняемых файлов ИМ. Резервную копию этого файла желательно сделать перед выполнением каких-либо серьезных изменений.

Панель настройки сообщений, вызываемая из меню настроек программы, изображена на рис. *.*.

Переключение между списком сообщений и “кнопками” панели выполняется клавишей . Сообщение в списке выбирается клавишами “<-”, “->” , “PgUp” и “PgDown”. При нажатии на выбранной кнопке панели, будет выполнена соответствующая кнопке операция.

Для добавления сообщения в список и редактирования уже существующего открывается панель вида рис. *.*. Пользователю не имеет смысла вводить свои собственные новые сообщения, но иногда требуется изменить параметры уже существующих.

Код сообщения можно ввести только для новой записи, для существующей он лишь выводится в панели. Код должен быть в пределах 0-255. Некоторые значения кодов не используются, а те, что используются жестко закреплены за определенными событиями в системе. Список сообщений с их кодами приводится в приложении *.*.

Строка “Текст” задает строку, которой будет обозначаться сообщение.

Параметры “Фон” и “Текст” задает цвет фона и текста, которым будет выводиться строка сообщения во всех окнах, где выводятся сообщения. Цвет настраивается стандартным диалогом для выбора цвета Windows.

Параметр “Звук” задает звук, который будет выводится через динамик при поступлении данного срообщения. Значение 0 означает - выводить без звука. В данный момент можно для нетревожного собщения ввести 6 звуков (с 1 по 6).

Флаг “регистрируемое”, определяет, регистрировать ли сообщение или нет. При приходе не регистрируемого сообщения программа ведет себя так, как будто аппаратура не отправляла данного сообщения.

Флаг “тревожное”, определяет, будет ли рассматриваться сообщение как тревожное. Тревожные сообщения при поступлении заносятся в окно(журнал) необработанных тревог и при этом, если разрешен звук “тревога”, программа включает звук сирены. После сброса, тревожное сообщение заносится в архив обработанных тревог. В оригинальных настройках, флаг тревожного сообщения стоит для всех видов сообщений “ТРЕВОГА”, “НЕИСПРАВНОСТЬ”, “НЕВЗЯТИЕ”.


Настройка причин тревог

7.8. Настройка причин тревог

Настройка причин тревог в программе подразумевает редактирование списка вариантов причин возникновения тревожных сообщений. Список причин тревог, напомним, вызывается при задании причины тревоги в журнале обработанных тревог. Панель настройки списка причин приводится на рис. *.*.

Переход между пунктами блока выключателей “Привелегии пользователя” выполняется клавишами “<-”, “->” , “PgUp” и “PgDown”. Для фиксации программой сделанных в списке изменений нужно выбрать кнопку “Установить” и нажать . Для добавления или редактирования записи открывается панель рис. *.*.

Параметр “код” можно задать для новой записи, для редактируемой - он только выводится в панели. Код причины в списке никак не связан с нумерацией причин, которая может быть установлена в Вашей организации охраны. Код причины используется для упорядочивания списка и не выводится в журнале обработанных тревог. Если в Вашей кодировке, например, причина “проникновение” имеет номер 32 и встречается чаще других, то в списке программы задайте ей код 1, а в тексте можете написать “32. проникновение”. Тогда в списке, данная причина будет выводиться первой строкой.

Параметр “причина” определяет текст, который будет введен в журнал обработанных тревог.

Параметр “проверочная” определяет, является ли тревога, результатом проверки приборов ОПС и т.п. Напомним, что при сбросе тревоги, сразу можно задать причину “проверочным” тревожным сообщениям.


Настройка примечаний

7.9. Настройка примечаний

Напомним, что примечания можно задать любому объекту в конфигурации системы. Примечание будет выводиться в карточке объекта, вызываемой из программы Юпитер, но не в СУБД Ладога, т.к. примечания к объектам хранятся только программой ИМ Юпитер в т. наз. “журнале объектов с примечаниями”.

Настройка списка примечаний выполняется способом, аналогичным способу настройки причин тревог, поэтому здесь не не описывается. Единственное отличие списка примечаний в том, что запись состоит из номера и текста примечания.


Установка ПО пульта

8.1. Установка ПО пульта

Компоненты драйвера для Windows, включенные в эту версию программы, предоставляются пока только в целях демонстрации и для тестирования новых возможностей системы. НЕ РЕКОМЕНДУЕТСЯ устанавливать их на действующее рабочее место оператора пульта.

Перед установкой компонентов внимательно ознакомьтесь с соответствующей документацией по драйверу аппаратуры.

Для установки ПО АСЦН Юпитер необходим IBM-совместимый компьютер, с установленной операционной системой Windows 98 SE или Windows Me, следующей конфигурации:

Процессор Pentium-333 и выше
Объем ОЗУ 64Mб (желательно 128 Мб)

Для установки системы Юпитер желательно скопировать с установочной дискеты файл самораспаковывающегося архива JupInst.EXE в один из каталогов жесткого диска. Далее, запустите JupInst.EXE.

Программа запросит временный каталог для распаковки (обычно c:\windows\temp). После успешной распаковки програма автоматически запустит процесс установки.

После запуска программы установки (Рис. 1) Вам будет предложено ознакомится с условиями использования данной версии. Если Вы не согласны с предложенными условиями эксплуатации – нажмите кнопку “Отмена” после чего программа закончит свою работу. Если вы согласны с данными условиями Вам необходимо нажать кнопку “Принимаю”, после чего разблокируется кнопка “Далее”.

Рис. 1

После нажатия кнопки “Далее” Вам будет предложено выбрать каталог для установки программы (Рис. 2). При желании Вы можете изменить каталог установки программы. В ознакомительной версии изменение каталога не предусмотрено (кроме буквы жесткого диска).

Рис. 2

После этого Вам необходимо будет нажать кнопку “Далее”. Вам будет показан выбранный Вами каталог для установки (Рис. 3). Если Вы не согласны с данными параметрами установки, Вы можете нажать кнопку “Назад” и вернуться к выбору каталога установки (Рис. 2). Если Вы согласны с данными параметрами, то Вам необходимо нажать кнопку “Далее”, если каталог установки не существует – программа запросит подтверждение на создание каталога (Рис. 4). После чего Вам необходимо подтвердить создание нового каталога, и программа установки установит драйвер в указанный каталог.

Рис. 3

Рис. 4

Далее Вам будет предложено (Рис. 5) вызвать настройщик конфигурации устройств (желательно его вызвать) для создания пустой конфигурации или переноса конфигурации из DOS версии программы Юпитер 5.0. (См. Конвертор конфигурации СПИ Юпитер 6.0.)

Рис. 5

Если Вы в конверторе базы данных объектов создали путой файл конфигурации, Вам необходимо будет добавить КПЦО. Для этого необходимо запустить программу Юпитер 6.0 (через меню Пуск\Программы\Юпитер 6.0\СПИ Юпитер 6.0). Далее зайти в меню Настройка\КПЦО, после чего выбрать в появившемся диалоге КПЦО1 и нажать Enter (или щелкнуть правой кнопкой мыши). Появится диалог добавления КПЦО (Рис. 6). Где Вам предложено будет ввести ключ КПЦО (например КПЦО1) и указать порт на котором находится КПЦО. Поддерживаются два КПЦО, которые подключаются к COM1 (IRQ=4 Port=0x3F8) или COM2 (IRQ=3 Port=0x2F8). После закрытия данного диалога Вы можете по нажатия кнопки F5 Добавить в конфигурацию АТС и УТ.

Рис. 6


Конвертор конфигурации СПИ Юпитер

8.2. Конвертор конфигурации СПИ Юпитер

    Конвертор конфигурации (Рис. 7) позволяет:
  • Создать пустую конфигурпцию объектов по умолчанию

  • Перенести DOS конфигурацию Юпитер 5.0

Рис. 7

Для создания пустой конфигурации Вам необходимо выбрать пункт “Создать пустой файл конфигурации” и нажать кнопку “Начать”. После создания пустой конфигурации Вы можете закрыть конвертор и начать работать с программой “Юпитер 6.0”.
Для переноса конфигурации из DOS версии Вам необходимо выбрать пункт “Импортировать конфигурацию”, далее нажать кнопку ‘…’ чтобы указать программе каталог расположения файла drv.cfg версии Юпитера 5.0.
Если файл указан правильно в полях КПЦО1-4 будут указаны пути, где конвертор будет искать файлы описания направлений DOS-версии. Их можно подкорректировать (чтобы лишний раз не вызывать команду subst). Установить флаг “Импортировать файлы направления” и нажать кнопку “Начать”. По окончании переноса файлов Вы можете посмотреть лог-файл dostowin.log.

Импорт из DOS-версии "СПИ Юпитер 5.0". Внимание:

1. Конвертор не считывает информацию, на каком из COM-портов находится КПЦО. Эту информацию необходимо указать вручную. Для этого необходимо запустить "СПИ Юпитер 6.0". Войти в меню "Настройка\КПЦО". Появится диалоговая панель (Рис. 8). Выбрать данный КПЦО, вызвать выпадающее меню нажатием "Enter" или правой кнопкой мыши, выбрать пункт меню "Настройка" и после появления диалога "Настройка КПЦО" указать COM-порт, к которому подключено КПЦО и нажать кнопку "Закрыть" и перезапустить "СПИ Юпитер 6.0".

2. Для переноса групп объектов (КТС, ОПС, ОПС+) Вам необходимо войти в "СПИ Юпитер" как "ИНЖЕНЕР", выбрать пункт меню "Файл\Импорт\Групп объектов" и указать расположение файла ext_type.dbf (обычно он расположен в каталоге j:\jupiter.1\single). После этого будет выполнен импорт групп объектов.

3. Импорт списка дежурных из DOS-версии выполняется через пункт меню: "Файл\Импорт\Пользователи". Программа запросит расположение файла password.mgz.

4. Ленты сообщений Вам необходимо скопировать из каталога j:\jupiter.1\ribbon в каталог c:\jupiter.win\message. После этого Вам необходимо вызвать программу c:\jupiter.win\Tape2LM.exe для построения файла с последними сообщениями от объекта.

Рис. 8

Если перенос файлов прошел без сбоев, Вы можете закрыть конвертор и начать работать с программой “Юпитер 6.0”.

Все рекомендации, предложения и ошибки программы мы принимаем:
Тел.: 8 (812) 350-5424
Факс: 8 (812) 352-5728
E-mail: elesta@elesta.ru, alex@elesta.ru
HTTP: http://www.elesta.ru


Описание файлов СПИ Юпитер 6.0

8.3. Описание файлов СПИ Юпитер 6.0

По умолчанию, программа “СПИ Юпитер 6.0” устанавливается в каталог “C:\Jupiter.win”. Далее предполагается, что каталог установки не был изменен.

    Драйверы для взаимодействия с аппаратурой:
  • KPCO.VXD – драйвер для обмена с КПЦО
  • SNDDRV.VXD – драйвер для подачи звукового сигнала на динамик (для совместимости с Windows 2000 (XP)
    Исполняемые файлы:
  • Jupiter.exe - СПИ “Юпитер 6.0”
  • ViewDbg.exe – просмотр отладочной информации
  • ViewMsg.exe – просмотр лент сообщений
  • DOSTOWIN.EXE – конвертор базы данных объектов из DOS версии Юпитер 5.0.
  • Tape2LM.EXE – по лентам сообщений строит выборку 100 последних сообщений от объекта.
    Файл настроек:
  • jupiter.ini – файл основных настроек СПИ Юпитер. Не рекомендуется редактировать вручную (только через меню настроек)
  • driver.cfg – состояние и настройка устройств верхнего уровня (КПЦО, АТС, УТ)
    Файлы, содержащие временную информацию(в случае их отсутствия создаются заново):
  • ctlobj.co – файл объектов, находящихся в данное время на контроле
  • timers.tmr – взведенные таймеры
  • ctlalarm.lrm – необработанные тревоги
  • tapefltr.dbf – временные файл для просмотра лент сообщений.
  • lastmsg.lmg - 100 последних сообщений от объекта
  • jupiter.log – файл отладочной информации, периодически желательно удалять (начиная с версии 6.0.36 появилась возможность задавать максимальный размер данного файла).
    Назначения каталогов:
  • C:\Jupiter.win\alarm - ленты тревог
  • C:\Jupiter.win\debug - ленты отладочной информации
  • C:\Jupiter.win\message - ленты сообщений.
  • C:\Jupiter.win\ladoga - БД Ладога Windows-версия.
  • C:\Jupiter.win\database - БД отображений сообщений от объектов, стандартные причины тревог, список пользователей.
  • C:\Jupiter.win\Update - Для автоматического переноса БД Ладога при работающем СПИ Юпитер 6.0

Формат лент данных каталогов. Создаются подкаталоги, типа: 2002.02 – ленты за февраль месяц 2002 года. Формат лент сообщений (каталог Ribbon в Юпитер 5.0) оставлен прежний.

  • C:\Jupiter.win\Database\JupUser.mdb – основные настройки программы, такие как Таблица основных сообщений СПИ Юпитер, основные причины тревог, основные примечания к объекту, список пользователей. Если на пульте установленно несколько компьютеров с программой "СПИ Юпитер 6.0" Вы можете заполнить этот файл на одном компьютере и скопировать на остальные. После перезапуска "СПИ Юпитер 6.0" считает новые таблицы.
  • C:\Jupiter.win\Ladoga\ladoga.mdb – новая версия программы Ладога. Если на пульте установленно несколько компьютеров с программой "СПИ Юпитер 6.0" Вы можете заполнить этот файл на одном компьютере и скопировать на остальные. После перезапуска "СПИ Юпитер 6.0" считает новые таблицы.
  • C:\Jupiter.win\password – список паролей по дням (генерится DOS программой make_psw.exe из дистрибутива Юпитер 5.0)

    Каталоги:
  • C:\Jupiter.win\Database\kpco1
  • C:\Jupiter.win\Database\kpco2
  • C:\Jupiter.win\Database\kpco3
  • C:\Jupiter.win\Database\kpco4
    В них расположены файлы:
  • состояния устройств нижнего уровня (файлы типа ut104.dat)
  • команды на отправку на линию КПЦО (файлы типа cmd11.que)

Все рекомендации, предложения и ошибки программы мы принимаем:
Тел.: 8 (812) 350-5424
Факс: 8 (812) 352-5728
E-mail: elesta@elesta.ru, alex@elesta.ru
HTTP: http://www.elesta.ru


Балтика DOS-версии

9.1. Балтика DOS-версии

В СПИ "Юпитер" версий старше 6.0.12 имеется возможность поддержки взаимодействия с АРМ ДО «Балтика». При этом становятся доступны следующие возможности:

  • автоматическая передача тревожных сообщений в АРМ ДО «Балтика»;
  • получение подтверждения о приеме тревожного сообщения офицером на обработку;
  • получение причины установленной дежурным офицером причины тревоги с помещением ее в запись архива обработанных тревог.

Данные функции требуют наличия модифицированного АРМ ДО «Балтика» адаптированного для связи с АРМ ДПУ «Юпитер».

Рис. 7

Настройка параметров программы заключается в задании параметров связи с АРМ ДО в разделе «Балтика» меню «Настройка»:

  • "Протокол" - для связи с DOS-программой "Балтика", необходимо установить: "Общий каталог"
  • "Каталог" – задает каталог для размещения файлов, используемых для обмена данными с АРМ ДО. Данный каталог должен совпадать с каталогом, используемым АРМ «Балтика» как каталог расположения рабочих мест «Юпитер».
  • "Период опроса" - периодичность сканирования файлов опроса АРМ «Балтика» (рекомендуется задавать 5-10 сек.)
  • "Период ответа" - период ожидания признака приема тревожного сообщения от АРМ «Балтика», по истечении которого будет сформирован звуковой сигнал (рекомендуется задавать 20-30 сек.)

Внимание: В случае, если к одному АРМ ДО «Балтика» подключено несколько СПИ Юпитер, в СПИ Юпитер необходимо прописать номер рабочего места. В сетевой версии в файле arm.ini, для локальной через меню "Настройка\Сервер". Запрещается нескольким СПИ Юпитер присваивать одинаковые номера рабочих мест.

Рис.


Балтика Windows-версии

9.2. Балтика Windows-версии

На момент написания руководства АРМ ДО Балтика Windows-версии подерживает только передачу тревоги по общему каталогу. См. Балтика DOS-версии;


Подготовка резервного компьютера

10. Подготовка резервного компьютера

На случай выхода из строя одного из компьютеров АРМ-ов дежурных на пульте должен быть подготовлен резервный компьютер. Резервный компьютер может заменить любое из рабочих мест и поэтому на нем должны быть установлены программы и перенесена конфигурация системы для всех рабочих мест.

Настоятельно рекомендуется конфигурировать все компьютеры пульта по возможности единообразно. Это облегчит понимание содержания файлов конфигурации на любой машине. Желательно размещать одинаковые программы на разных компьютерах в каталогах с одинаковыми именами.

Будем исходить из того, то на ПЦО имеется 4 рабочих места. Жесткий диск резерного комьютера разбит на 2 и более логических дисков. Для определенности будем считать, что СПИ Юпитер 6.0 будет установлен на диск D. Сперва создадим на диске D: каталоги:
"Jupiter.w1",
"Jupiter.w2",
"Jupiter.w3",
"Jupiter.w4"
В каталог Jupiter.w1 скопируем конфигурацию с 1 рабочего места, в каталог Jupiter.w2 скопируем конфигурацию со 2 рабочего места и т.д. Теперь необходимо подправить пути к файлам резерного компьютера, если на 1 рабочем месте СПИ Юпитер установлен в каталог "d:\Jupiter.w1" конфигурацию править не обязательно, во всех остальных случаях необходимо подправить ini-файл с настройками путей. Для этого из каждого каталога "Jupiter.w1", "Jupiter.w2","Jupiter.w3","Jupiter.w4" необходимо запустить jupiter.exe с ключом -path:
d:\jupiter.w1>jupiter -path

После этого необходимо создать каталоги "DataBase" и "Ladoga" и скопировать туда соответстенно файлы JupUser.mdb и Ladoga.mdb. И прописать на них ссылки в DSN (См. Настройка БД). После этого необходимо вынести на рабочий стол ярлыки Jupiter.exe из каждого каталога "Jupiter.w1", "Jupiter.w2","Jupiter.w3","Jupiter.w4" и переименовать ярлык "d:\jupiter.w1\jupiter.exe" в "Рабочее место 1" и т.д.

После этого необходимо настроить планировщик задач Windows, чтобы он с периодичностью в 30 мин переносил конфигурацию с рабочего места на резерный компьютер. Внимание: планировщик должел переносить с рабочего места все файлы кроме jupiter.ini.

Внимание: необходимо обновлять файлы JupUser.mdb и Ladoga.mdb в каталогах "DataBase" и "Ladoga" при изменениии их на рабочем месте.


Замена неисправного компьютера на резервный

11. Замена неисправного компьютера на резервный

При неправильной работе системы и подозрении на неисправность компьютера прежде всего следует выяснить, действительно ли является неправильная работа результатом неисправности аппаратуры. Ошибки программ иногда могут проявляться самым неожиданным образом. Например (практически известный случай), если исчерпан весь объем свободного места на жестком диске, обмен с аппаратурой может не прекращаться, но при этом в программе будет остановлена запись ленты.

Замена компьютера - достаточно серьезная операция и, поэтому, при явной неисправности монитора или клавиатуры, желательно заменить только их. Важно помнить, что любое соединение/отключение разъемов компьютера нужно выполнять при отключенном питании.

При серьезной неисправности компьютера одного из рабочих мест, либо невозможности быстро определить причину неправильной работы программ, компьютер должен быть заменен на резервный.

Если на пульте охраняются "ручные" объекты, во время замены компьютера дежурным следует записывать все заявки на взятие и снятие объектов для последующей обработки.

При замене следует выполнить следующую последовательность действий.

  1. Если компьютер частично исправен и возможна работа с диском, желательно перенести на резервную машину последнюю конфигурацию устройств, ленту сообщений и архив тревог за текущие сутки. Ленты сообщений за предшествующие дни (уже не изменяются программой) могут быть перенесены позже.
  2. Обязательно отключить питание КПЦО и, желательно, отключить из сети блок питания КПЦО. Подключение и отключение работающего КПЦО даже от выключенного компьютера, может привести к выходу из строя COM-портов компьютера.
  3. Заменить компьютер на резервный. При выключенном питании проверить все соединения устройств и подключить кабель КПЦО (не включая питание КПЦО).
  4. Включить компьютер и загрузить необходимое рабочее место.
  5. При выключенном КПЦО, когда сообщения аппаратуры не поступают на пульт, проверить, что конфигурация объектов и лента (взятая с основной машины) за текущие сутки работы доступна. Следует проверить установку даты и времени на резервной машине; это важно, чтобы не запутать и без того сложную ситуацию с лентами сообщений. Если это необходимо, исправить ошибки в настройках программы. Важно помнить, что настройки путей файлов данных вступают в силу после перезагрузки программы.
  6. Включить КПЦО и убедиться в наличии обмена информацией с компьютером (по индикатору КПЦО). Если необходимо, настроить драйвер аппаратуры.
  7. По всем УТ в конфигурации устройств выполнить команды ОПРОСА, для восстановления последнего состояния объектов в программе. Ни в коем случае по УТ Атлас и Центр не следует подавать команду перевзятия. При перевзятии, напомним, информация посылается с компьютера на аппаратуру. А поскольку, информация о состоянии объектов на резервном компьютере могла устареть, при перевзятии большое число объектов могут быть ошибочно взяты или сняты с охраны и последующий опрос не исправит ситуацию.

При замене могут возникнуть рассматриваемые ниже проблемы.

  1. Нет обмена данными с КПЦО (на индикаторе КПЦО - "НО" или "СК"). Это может произойти, если настройки КПЦО драйвера аппаратуры для резервной и основной машин различаются. Данная ситуация описана в документации по драйверу аппаратуры. Если настройки совпадают, возможно, КПЦО был подключен к COM-порту компьютера, отличающемуся от заданного. Тогда следует (при выключенном питании компьютера и КПЦО) переключить КПЦО на нужный COM-порт, либо изменить номер порта в настройках драйвера. Обычно на корпусе компьютера порт СОМ1 имеет 9-штырьковый разьем "папа", СОМ1 - 25-штырьковый "мама". При том, что BIOS многих материнских плат компьютеров поддерживает функцию замены местами СОМ-портов, а разъем СОМ1 у большинства пользователей ассоциируется с 9-штырьковым разъемом, часто возникает недоразумение, когда "СОМ1" реально оказывается СОМ2, а "СОМ2" - СОМ1.
  2. В программе ИМ не выводится информация ленты за предыдущие дни ( и возможно за данный день) работы системы. Это закономерное явление, если при замене машины не были перенесены файлы лент. Ленты за предыдущие дни можно будет перенести позже. Ленту за текущие сутки, нужно перенести сразу, при обнаружении данной проблемы после включения резервного компьютера. Иначе достаточно большое число сообщений, с момента выхода из строя основной машины до момента обнаружения отсутствия последней ленты, будет потеряно. Если последнюю ленту не удалось перенести сразу на резервный компьютер и прошло достаточно много сообщений на резервной машине, заменять файл текущей ленты на файл с резервного компьютера не рекомендуется. Объединить разорванную ленту можно будет позже, с использованием утилиты ADDRIB.
  3. Лента за текущие сутки на резервный компьютер была перенесена, но предшествующие неисправности основного компьютера сообщения в окне просмотра лент не видны. В данном случае следует проверить настройку пути для записи лент и, заодно, прочие настройки путей файлов данных. Либо, если пути файлов настроены правильно, проверить, действительно ли файлы лент находятся в указанном каталоге. Следует отметить, что при запуске программы ИМ, если ленты в указанном каталоге лент отсутствуют, то программа создает пустые файлы лент. В данной версии программы пустые файлы можно определить по их длине, она составляет соответственно 482 и 2048 байт. Поэтому, может возникнуть недоразумение, когда каталог лент существует, файлы лент в нем есть, а ленты, при просмотре в программе, не содержат той информации, которая была перенесена с другой машины. При этом файлы лент были скопированы в другой каталог и, естественно, программе об этом ничего не известно.


Особенности работы клиент-серверного ПО СПИ Юпитер

12.1. Особенности работы клиент-серверного ПО СПИ Юпитер

В состав клент-серверного СПИ Юпитер 6.0 входят:

  • Сервер СПИ Юпитер 6.0 (в дальнейшем - сервер)
  • Клиент СПИ Юпитер 6.0 (в дальнейшем - клиент)
  • Программный ретранслятор пакетов с КПЦО на сервер СПИ Юпитер 6.0 (в дальнейшем - ретранслятор)

Сервер - содержит всю информацию об устройствах и производит обработку входящих пакетов и действий операторов и пользователя.

Клиент - отображает информацию об устройствах, действия оператора передает на сервер для дальнейшей обработки.

Ретранслятор - принимает информацию с КПЦО и передает на сервер для дальнейшей обработки.

СПИ Юпитер 6.0 использует протокол TCP/IP. Данный протокол необходимо установить на все компьютеры, на которых планируется использование СПИ Юпитер 6.0.

Рекомендации по использованию:

Данное программное обеспечение рекомендуется использовать, при наличии не более 4 КПЦО. В случае использования большего количества рекомендуем использовать одноранговую версию СПИ Юпитер 6.0, которая проходит тестирование, и всем купившим клиент-серверную версию будет поставлятся бесплатно. Основное отличие - при сбоях сети одноранговая версия автоматически переходит в однопользовательский вариант, и продолжает работу без поддержки сети и потери информации. В клиент-серверной версии в случаях проблем с сервером или сетью полностью прекращается обмен информации с устройствами до полного восстановления функциональности сервера. Также серверная версия предъявляет повышенные требования к оборудованию и обслуживающему персоналу.


Настройка сервера СПИ Юпитер

12.3. Настройка сервера СПИ Юпитер

Вариант 1. Один или два КПЦО

Мы рекомендуем установить сервер на компьютер, к которому физически подключены эти КПЦО. В случае проблем с сетью продолжится обмен информацией с КПЦО и один дежурный на сервере сможет некоторое время контролировать ситуацию до устранения проблем с сетью. Этот компьютер должен быть Pentium III 1000 МГц и выше, 256 М памяти. Материнская плата 815 серии с двумя COM портами на борту. На компьютере необходимо установить Windows 98 SE, Internet Explorer 6.0 и Microsoft Access из пакета Microsoft Office 97 SP2.

Для установки сервера на этом компьютере необходимо запустить файл JupInst.exe из каталога Local на CD диске и следовать инструкциям из пакета установки локальной версии СПИ Юпитер 6.0. В дальнейшем мы будем предполагать, что установка выполнена в каталог D:\Jupiter.win.

Рис. 1

После установки локальной версии СПИ Юпитер 6.0 для перевода локальной версии в режим сервера необходимо запустить jupiter.exe с параметром -server для перевода локальной версии в серверный вариант:

Рис. 2

После перевода разблокируются пункты меню "Настройка\Сервер" и "Настройка\Рабочие места" и изменяется структура расположения каталогов.После этого Вам необходимо вызвать пункт меню "Настройка\Сервер", откроется диалог:

Рис. 4

Вам необходимо выбрать: "Работать в режиме одноранговой сети". Изменения параметров портов оставлено для совместимости с будущими версиями Windows, на данный момент их изменение не требуется. Опция "Работать в режиме сервера" после успешного тестирования перехвата будет убрана.

После этого Вам необходимо вызвать пункт меню "Настройка\Рабочие места", откроется диалог:

Рис. 5

В данном диалоге необходимо прописать имена компьютеров, с которых разрешен доступ клиента. Редактирование имен компьютера осуществляется нажатием клавиши "Enter" или двойным щелчком мыши по выбранной позиции, после чего открывается диалог редактирования имени рабочего места:

Рис. 6

Вам необходимо прописать имя и тип компьютера. Если этого не сделать, при попытке соединения с сервером клиента, не указанного в данном списке сервера, клиент выдаст ошибку "Запрещен доступ с указанного компьютера":

Рис. 7

И сервер сразу же закроет соединение с этим клиентом. Имена компьютеров прописываютя в файле arm.ini.

Внимание: файл arm.ini должен быть одинаков на всех компьютерах в Вашей сети, на которых установлен СПИ Юпитер (сервер, клиент, дежурный офицер).


Настройка клиента СПИ Юпитер

12.4. Настройка клиента СПИ Юпитер

Переходим к настройке клиентского рабочего места. Для клиентского рабочего места необходим компьютер Celeron-800 и выше, 128 М оперативной памяти. Емкость жесткого диска значения не имеет, так все данные хранятся на сервере. Но рекомендуется не меньше 10 Гб. На данном комьютере можно установить Windows 98 SE, Windows 2000 SP2, Windows XP SP1 и выше. Рекомендуется Windows 98 SE. Так же необходимо установить Internet Explorer 6.0. Microsoft Access из Microsoft Office 97 SP2 устанавливать не обязательно, но желательно, на случай беспроблемного переконфигурирования системы.

Для установки клиентского рабочего места необходимо на комьютере создать пустой каталог, допустим E:\Jupiter\JpClient. Скопировать туда файлы JpClient.exe и snddrv.vxd из каталога Client CD диска. Так же необходимо скопировать туда файл arm.ini, в котором содержится список компьютеров системы Юпитер корневого каталога из сервера СПИ Юпитер 6.0. Запустить JupClient.exe с ключем -ini:

Рис. 10

Откроется диалог:

Рис. 11

В поле "Сервер\Основной" необходимо ввести имя сервера, настроеного нами ранее. Поле "Сервер\резервный" временно не используется. "Порт данных" и "порт сигналов" изменять не нужно. Они должны совпадать с портами, которые указаны у сервера. "Запуск" - при запуске клиент пытается с сервером, если клиент не может установить соединение, он выполняет программу, указанную в поле "Выполнить", иногда целесообразно или запустить локальную версию (но не в нашем случае), или отправить сообщение на компьютер администратора сети. Для этого необходимо создать bat-файл следующего содержания:

net send cmp-admin "Сбой связи с сервером СПИ Юпитер 6.0"
И прописать полный путь к этому файлу в поле "Выполнить". "Наличие КПЦО" и "Задержка" временно не используются.

Нажать кнопку "OK". Через несколько секунд в каталоге должен появится файл Jupclnt.ini. Создайте иконку JupClient.exe на рабочем столе и запустите JupClient.exe.

Рис. 11

Через 10-15 секунд клиент должен соединиться с сервером:

Рис. 11


Перевод пульта в режим работы по протоколу ПК-3М

13.1. Перевод пульта в режим работы по протоколу ПК-3М

В начале 2004 года был переработан протокол связи КПЦО - Компьютер. Новый протокол, получивший название ПК-3М, обладает следующими преимуществами:

  • Настройка скорости связи по COM-порту
  • Трехпроводной кабель КПЦО-Компьютер
  • Возможность работы через модемы
  • Стабильная работа под операциоными системами Windows 9x/NT/2000SP2
Протокол ПК-3М реализован в КПЦО версии 3.11. СПИ Юпитер поддерживает протокол ПК-3М начиная с версии 6.0.34.

Для настройки работы пульта по протоколу ПК-3М, необходимо войти в меню "Настройки\Драйвер" и в появившемся диалоге установить "Тип драйвера" 3.11.

Перезапустить СПИ Юпитер, чтобы изменения вступили в силу. Далее войти в меню "Отладка\Драйвер\Задержки КПЦО" и установить задержки КПЦО версии 3.11 Нормальная - 500 мс., интенсивная - 50 мс.

Далее Вам необходимо войти в панель настройки КПЦО, откруть пункт меню "Настройка"

Откроется диалог настройки КПЦО, в котором следует установить скорость обмена КПЦО-Компьютер (см. описание КПЦО), обычно 19200, и параметры:

  • IntervalTimeout
  • TotalTimeoutMultiplier
  • TotalTimeoutConstant
Установить в значение 200 мс. Данные параметры следует изменять при работе КПЦО-Компьютер через модемы. "Номер на канале" в настоящее время не используется, но для совместимости с будушими версиями рекомендуется установить в ноль.


Расшифровка таблицы сообщений СПИ Юпитер 6.0

13. Расшифровка таблицы сообщений СПИ Юпитер 6.0.36

СООБЩЕНИЯ СПИ СТРУНА

№ | Сообщение | Расшифровка
0x1 | "СТРУНА: ВРЕМЯ" | Полученно текущее время (передается СТРУНОЙ каждый час). Например: "ВРЕМЯ:23:00"
0x2 | "СТРУНА: ТРЕВОГА ШЛЕЙФОВ" | ?
0x3 | "СТРУНА: НЕИЗВЕСТНОЕ СООБЩЕНИЕ" | ?
0x4 | "СТРУНА: СООБЩЕНИЕ ОТ ИСКЛЮЧЕННОГО" | ?
0x5 | "СТРУНА: ОТКЛЮЧЕНИЕ НА ПЦО" | ?
0x6 | "СТРУНА: СНЯТИЕ" | Объект снят с охраны
0x7 | "СТРУНА: ВЗЯТИЕ" | Объект взят под охрану
0x8 | "СТРУНА: ВКЛЮЧЕН (НА ПЦО)" | ?
0x9 | "СТРУНА: ВЫКЛЮЧЕН (НА ПЦО)" | ?
0xA | "СТРУНА: ТРЕВОГА ШЛЕЙФОВ (ЗАПРОС)" | ?
0xB | "ВЗЛОМ (ПО ЗАПРОСУ)" | Сообщение выдается каждый час. Подтверждение вскрытии прибора
0xC | "СТРУНА: СНЯТИЕ (ПО ЗАПРОСУ)" | Сообщение выдается каждый час. Подтверждает, что объект не охраняется.
0xD | "СТРУНА: ВЗЯТИЕ (ПО ЗАПРОСУ)" | Сообщение выдается каждый час. Подтверждает, что объект находится под охраной.
0xE | "СТРУНА: СНЯТИЕ (ВНИМАНИЕ)" | ?
0xE1 | "СТРУНА: РЕЗЕРВНОЕ ПИТАНИЕ (ПЦО)" | ?
0xE2 | "СТРУНА: ПОТЕРЯ АКБ (ПЦО)" | ?
0xE3 | "СТРУНА: ВОССТАНОВЛЕНИЕ ПИТАНИЯ (ПЦО)" | ?
0xE4 | "СТРУНА: НЕИСПРАВНОСТЬ (ПО ЗАПРОСУ)" | Сообщение выдается каждый час. Подтверждает, что объект неисправен.

СООБЩЕНИЯ СПИ ЮПИТЕР

№ | Сообщение | Расшифровка
0xF | "РАСШИРИТЕЛЬ " | Отладка ППКОП-5 и ППКОП-8
0x10 | "ВЗЯТИЕ" | Объект взят под охрану
0x11 | "ВЗЯТИЕ (ПОВТОРНОЕ)" | Пришло сообщение о взятии объекта уже взятого на охрану. Может означать, что между этим и предыдущим сообщением от объекта было потеряно сообщение от объекта.
0x12 | "ВЗЯТИЕ (ВНИМАНИЕ)" | При опросе/перевзятии пришло сообщение о взятии объекта, но на пульте он считался снятым
0x13 | "ВЗЯТИЕ (ПО ЗАПРОСУ)" | Формируется при постановке на охрану УОО-5 или ИО-3 с пульта, так же при ответе на перевзятие или опрос. Подтверждает, что объект охраняется.
0x14 | "ВОССТ.ШЛЕЙФА" | Ранее нарушенный шлейф охраны восстановился («Юпитер»)
0x15 | "ВЗЯТИЕ (ОПС)" | Формируется при постановке на охрану Атлас-3 или Центра как ОПС
0x16 | "ВЗЯТИЕ (КТС)" | Формируется при постановке на охрану Атлас-3 или Центра как КТС
0x17 | "ВЗЯТИЕ(ОПС БЕЗ ВЫХ)" | Формируется при постановке на охрану Атлас-3 или Центра как ОПС, клиенту задержка на выход включена не была
0x18 | "ВЗЯТИЕ(ОПС С ВЫХ)" | Формируется при постановке на охрану Атлас-3 или Центра как ОПС, клиенту была дана задержка на выход
0x19 | "ВЗЯТИЕ (ПО ЗАПРОСУ, НЕПОЛНОЕ)" | Формируется при постановке на охрану УОО-5 или ИО-3 с пульта с нарушенными шлейфами, обычно за ним следуют сообщения ТРЕВОГА с указанием нарушенных шлейфов
0x1A | "ВЗЯТИЕ (НЕПОЛНОЕ)" | Формируется при постановке на охрану УОО-5 или ИО-3 с нарушенными шлейфами, обычно за ним следуют сообщения ТРЕВОГА с указанием нарушенных шлейфов
0x1B | "ВЗЯТИЕ (ПОВТОРНОЕ, НЕПОЛНОЕ)" | ?
0x20 | "СНЯТИЕ" | Снятие объекта с охраны
0x21 | "СНЯТИЕ (ПОВТОРНОЕ)" | Пришло сообщение о снятии объекта уже снятого с охраны. Может означать, что между этим и предыдущим сообщением от объекта было потеряно сообщение.
0x22 | "СНЯТИЕ (ВНИМАНИЕ)" | Для объектов типа «Комета» / «Юпитер» означает, что объект снимается после тревоги. Для объектов с ручной тактикой означает, что объект считавшийся взятым при проверке оказался снят.
0x23 | "СНЯТИЕ (ПО ЗАПРОСУ)" | Сообщение выдается при перевзятии / опросе объекта. Подтверждает, что объект не охраняется
0x30 | "ТРЕВОГА" | Проникновение на охраняемый объект (нарушение шлейфа охраны).
0x31 | "ТРЕВОГА (ПОВТОРНАЯ)" | Повторное поступление сигнала ТРЕВОГА
0x32 | "ТРЕВОГА (ВНИМАНИЕ)" | Поступление сообщения ТРЕВОГА по снятому объекту
0x33 | "ВЗЛОМ" | Сообщение о вскрытии прибора «Комета» / «Юпитер».
0x34 | "ТРЕВОГА (КЛИЕНТ)" | Означает использование запрещенного для данного объекта брелка для взятия / снятия объекта с / на охрану.
0x34 | "ТРЕВОГА (БРЕЛОК)" | То же, что и "ТРЕВОГА (КЛИЕНТ)"
0x35 | "ТРЕВОГА(ПО ЗАПРОСУ)" | Сообщение выдается при перевзятии / опросе объекта. Подтверждает, что объект находится в тревоге.
0x36 | "САБОТАЖ" | Попытка имитации на линии связи между УТ и охраняемым объектом
0x37 | "ТРЕВОГА(НЕТ ОХРАНЫ)" | Поступление сообщения тревога от объекта, не охраняемого дольше положенного времени (оружейные комнаты, кассы, наркотоки)
0x38 | "ТРЕВОГА(ПАРОЛЬ)" | ?
0x39 | "ТРЕВОГА(ОПС)" | Тревожное сообщение от объекта охраняемого в режиме ОПС
0x3A | "ТРЕВОГА(КТС)" | Тревожное сообщение от объекта охраняемого в режиме КТС
0x3B | "ТРЕВОГА (ТИХАЯ)" | Сообщение о взятии / снятии объекта под принуждением
0x3C | "ТРЕВОГА (ПОДБОР)" | Сообщение об обнаружении попытки подбора кода
0x3D | "ПОЖАР" | ?
0x3E | "ТРЕВОГА (ПОДМЕНА)" | ?
0x3F | "ТРЕВОГА (ОБУЧЕНИЯ ВЗЯТОГО)" | ?
0x40 | "НЕИСПР.ПРГ. " | Не используется, для совместимости с DOS версией
0x41 | "ВОССТАНОВЛЕНИЕ" | Восстановление работоспособности устройства после неисправности или шлейфа после тревоги.
0x42 | "РЕЗЕРВНОЕ ПИТАНИЕ" | Переход устройства на работу от источника резервного питания
0x43 | "ВОССТАНОВЛЕНИЕ ПИТ." | Переход устройства на работу от сети.
0x44 | "НЕВЗЯТИЕ" | За отведенное время объект не взялся на охрану после выполнения проверки.
0x45 | "НЕИСПРАВНОСТЬ (УТ)" | Данное сообщение генерируется ПО пульта только для объектов с ручной тактикой охраны и означает что команда не была вовремя передана устройству или не поступил ответ от устройства (истекло время на передачу команды / прием ответа).
0x46 | "НЕИСПРАВНОСТЬ" | Неисправность устройства. Сообщение формируется вышестоящим устройством всистеме, обнаружившим неисправность нижележащего (отсутствие корректного сигнала).
0x47 | "ПОДТВ. НЕИСПР." | Не используется, для совместимости с DOS версией
0x48 | "НЕ ПРОШЕЛ ПРОВЕРКУ" | Отметка о том, что проверка объекта с ручной тактикой при постановке на охрану проверка объекта КТС / Комбинированного закончилась неудачей.
0x49 | "ОТМЕНА ВЗЯТИЯ" | Отметка о том, что дежурная подала команду на отмену взятия объекта
0x4A | "НАЧАЛО ОБУЧЕНИЯ" | Отметка о том, что объект был переведен в режим обучения
0x4B | "КОНЕЦ ОБУЧЕНИЯ" | Отметка о том, что объект был выведен из режима обучения в обычный режим работы
0x4C | "ЗАКРЫТИЕ КОРПУСА" | Отметка восстановления датчика закрытия корпуса (парное к ВЗЛОМу)
0x4E | "ТРЕВОГА (ВРЕМЯ СНЯТИЯ)" | ?
0x4F | "БЛОК НЕИМИТОСТОЙКИЙ" | ?
0x50 | "ДЕЖУРНЫЙ РЕЖИМ" | Подтверждает работоспособность устройства. В ответах на опрос или перевзятие устройства завершает последовательность сообщений.
0x53 | "НЕИСПРАВНОСТЬ (ПО ЗАПРОСУ)" | ?
0x54 | "ЗАДЕРЖКА НА ВЫХОД" | ?
0x55 | "СБРОС ПОЖАРНЫХ ДАТЧИКОВ" | ?
0x56 | "ПОТЕРЯ АККУМУЛЯТОРА" | ?
0x57 | "ВОССТАНОВЛЕНИЕ АККУМУЛЯТОРА" | ?
0x58 | "НЕИСПРАВНОСТЬ (КЗ)" | ?
0x59 | "НЕИСПРАВНОСТЬ (ОБРЫВ)" | ?
0x5A | "НЕИСПРАВНОСТЬ (ВЕРХНИЙ ПРЕДЕЛ)" | ?
0x5B | "НЕИСПРАВНОСТЬ (НИЖНИЙ ПРЕДЕЛ)" | ?
0x5C | "ВНИМАНИЕ (ПОЖАР)" | ?
0x5D | "СБРОС ПАМЯТИ ТРЕВОГ КТС" | ?
0x5E | "НЕВЗЯТИЕ (КТС)" | ?
0x5F | "ВЕРСИЯ-П:" | Тестирование ППКОП-5 и ППКОП-8
0x61 | "ПАТРУЛЬ" | Извещает о сработке специального датчика на приборе «Комета» / «Юпитер»
0x62 | "ПОТЕРЯ" | При опросе / перевзятии объекта, считавшегося взятым, получена информация, что объект снят с охраны.
0x63 | "ПОЯВЛЕНИЕ" | При опросе / перевзятии объекта, считавшегося снятым/неисправным, получена информация, что объект находится на охране.
0x64 | "САМОИСКЛЮЧЕНИЕ" | При опросе / перевзятии объекта, считавшегося включенным , он оказалось исключенным.
0x65 | "ОШИБКА КОНФИГУРАЦИИ" | Неправильно настроен драйвер аппаратуры. Обычно при несовпадении типа устройства на пульте и в действительности.
0x66 | "СБОЙ СВЯЗИ" | При передаче команды была неисправна линия связи КПЦО-УТ или на линии были помехи
0x67 | "НЕГОТОВНОСТЬ" | При подаче команды устройство было не готово ее воспринять.
0x68 | "ВХОД" | На объекте с ручной тактикой охраны с типом охраны ОПС был нарушен шлейф. По истечении заданного на вход времени, если с объекта не было звонка и он не был снят, ПО пульта сформирует сообщение «ТРЕВОГА»
0x69 | "КОМАНДА НА СНЯТИЕ" | Передача команды на снятие объекта с охраны
0x6A | "ВЫХОД" | ?
0x6B | "КОМАНДА НА ПЕРЕВЗ." | Дежурная выполнила команду смены режима охраны объекта
0x6C | "ЗАКРЫТИЕ" | ?
0x6D | "НЕПОЛНОЕ ВЗЯТИЕ" | ?
0x6E | "ЛИНИЯ" | Для тестирования АК-24 версии 3.4
0x6F | "ПЛАТА" | Выдает неверную информацию, оставлено для совместимости
0x70 | "ДОБАВЛЕНИЕ УСТР." | Формируется при добавлении любого устройства в конфигурацию.
0x71 | "УДАЛЕНИЕ УСТРОЙСТВА" | Формируется при удалении любого устройства из конфигурации
0x72 | "БЛОКИРОВКА" | Формируется при постановке устройства в режим блокировки сообщений (сообщения от устройства и его подчиненных устройств игнорируются)
0x73 | "РАЗБЛОКИРОВКА" | Формируется при разблокировании устройства.
0x74 | "ИЗМЕНЕНИЕ КЛЮЧА" | Изменение ключа устройства на пульте.
0x75 | "АВТОБЛОКИРОВКА" | Устройство было автоматически заблокировано при подмене.
0x76 | "ВОССТАНОВЛЕНИЕ (ПОДМЕНА)" | На объекте после подмены включили оригинальное устройсто.
0x77 | "САНКЦИОНИРОВАНИЕ" | ?
0x78 | "АВТОСАНКЦИОНИРОВАНИЕ" | Пульт автоматически начал нормально работать с новым устройством, после подмены.
0x79 | "ВХОД АДМИНИСТРАТОРА" | В систему пожарных приборов выполнен вход пользователя с привилегиями администратора.
0x7A | "ВЫХОД АДМИНИСТРАТОРА" | Из системы пожарных приборов выполнен выход пользователя с привилегиями администратора.
0x80 | "СООБЩЕНИЕ ОТ ИСКЛЮЧЕННОГО" | Получено сообщение от устройства, которого нет в конфигурации.
0x81 | "НЕИЗВЕСТНОЕ СООБЩ." | Получено неизвестное сообщение от устройства.
0x83 | "ИЗМЕНЕНИЕ ТАБЛИЦЫ ОХРАНЫ" | На пульте изменили таблицу охраны объекта.
0x84 | "ИЗМЕНЕНИЕ СВЯЗАННЫХ КЛЮЧЕЙ" | На пульте изменили связанные ключи объекта ручной тактики охраны.
0x85 | "ИЗМЕНЕНИЕ ЗАДЕРЖЕК" | На пульте изменили задержки на вход и выход объектов с ручной тактикой охраны.
0x86 | "ИЗМЕНЕНИЕ ПРИМЕЧАНИЯ" | На пульте изменили примечание объекта
0x87 | "ИЗМЕНЕНИЕ ШЛЕЙФА" | На пульте изменили шлейф или задержку шлейфа Юпитер.
0x88 | "ИЗМЕНЕНИЕ ВРЕМЕНИ ОТЪЕЗД" | На пульте изменили дату, до которой уехали собственники. До истечения данной даты тревоги по данному объекту будут идти без задержки.
0x89 | "ИЗМЕНЕНИЕ ГРУППЫ ОБЪЕКТОВ" | Тестирование ППКОП-5 и ППКОП-8
0x8F | "ОТВЕТ НА СОСТОЯНИЕ ГРУПП" | Тестирование ППКОП-5 и ППКОП-8
0x90 | "ОТВЕТ НА ПЕРЕВЗЯТИЕ" | Устройство выполнило команду «перевзятие»
0x91 | "ИСКЛЮЧЕНИЕ" | Устройство выполнило команду «исключение»
0x92 | "ОТВЕТ НА ОПРОС" | Устройство выполнило команду опроса. Следом за этим могут следовать другие сообщения с результатом опроса, завершаемые сообщением «ДЕЖУРНЫЙ РЕЖИМ».
0x93 | "НЕПРОХОЖД. КОМАНДЫ" | Команду устройству не удалось передать
0x94 | "АППАРАТНОЕ ПЕРЕВ." | При восстановлении работоспособности устройства вышестоящим устройством на него была подана команда «перевзятие»
0x95 | "ВЕРСИЯ ПЗУ" | Содержит информацию о версии и типе ПО прибора.
0x96 | "ПАРАМЕТРЫ" | Передача на устройства блока параметров
0x98 | "ОШИБКА ПАРАМЕТРОВ" | На устройство была подана неверная команда.
0x99 | "ОТВЕТ НА СОСТОЯНИЕ ГРУПП" | ?
0x9A | "КОМАНДА ОПРОС" | ?
0x9B | "ЗАПРОС ВЕРСИИ" | Передача на устройство команды «запрос версии».
0x9C | "ОПИСАНИЕ" | Содержит расширенную информацию о версии и типе ПО прибора.
0x9D | "ШЛЕЙФ-ГРУППА: " | Тестирование ППКОП-5 и ППКОП-8
0x9E | "ОПИСАНИЕ ШЛЕЙФА" | Тестирование ППКОП-5 и ППКОП-8
0x9F | "ЗАДЕРЖКА" | Тестирование ППКОП-5 и ППКОП-8
0xA0 | "ВНУТРЕННЯЯ ОШ. ДР." | Не используется, для совместимости с DOS версией
0xA1 | "СБЩ.НЕ ОБР.ДО КОНЦА" | Не используется, для совместимости с DOS версией
0xA2 | "НАЙДЕН ДУБЛ. КЛЮЧ" | Не используется, для совместимости с DOS версией
0xA4 | "НАЧАЛО ПЕРЕИНД." | Не используется, для совместимости с DOS версией
0xA5 | "ЗАВЕРШЕНИЕ ПЕРЕИНД." | Не используется, для совместимости с DOS версией
0xA6 | "КЛЮЧ НЕ НАЙДЕН" | Не используется, для совместимости с DOS версией
0xA8 | "КОМАНДА НЕ ПЕРЕДАНА" | ?
0xB0 | "ЗАПУСК" | 1) Запуск СПИ Юпитер после входа в программу или смены дежурного пульта 2) Запуск устройства при включении питания
0xB1 | "ОСТАНОВКА" | Остановка программы СПИ Юпитер.
0xB2 | "СМЕНА ДЕЖУРНЫХ" | На пульт заступил другой дежурный
0xB3 | "ОБНОВЛЕНИЕ" | Внутреннее сообщение драйвера. В ленту сообщений не пишется
0xB4 | "ПОСТАНОВКА НА ПРОВ." | Постановка объекта на проверку функционирования.
0xB5 | "СНЯТИЕ С ПРОВЕРКИ" | Снятие объекта с проверки функционирования
0xB6 | "ОЧИСТКА КЛЮЧА" | Сбрасывает состояние ответчика в СНЯТИЕ (для ИО «Комета»)
0xB7 | "СМЕНА ВРЕМЕНИ" | Отметка изменения времени системы
0xB8 | "ПОТЕРЯ СВЯЗИ КПЦО" | Не используется, для совместимости с бета-версиями СПИ Юпитер.
0xB9 | "ДЕЖ. ОФИЦЕР НЕ ПРИНЯЛ ТРЕВОГУ" | ?
0xBA | "ПРОВЕРКУ ПРОШЕЛ" | Отметка о прохождении проверки объекта КТС / Комбинированного.
0xBB | "ПРОВЕРКУ НЕ ПРОШЕЛ" | Отметка о непрохождении проверки объекта КТС / Комбинированного.
0xBD | "ПОТЕРЯ СВЯЗИ С АРМ" | ?
0xBE | "ВОССТАНОВЛЕНИЕ СВЯЗИ С АРМ" | ?
0xBF | "ПЕРЕЗАПУСК ДРАЙВЕРА" | При потере связи с КПЦО пульт выполнил перезапуск драйвера КПЦО.
0xC0 | "ПЕРЕЗАПУСК УСТРОЙСТВА" | С пульта был выполнен перезапуск объекта Юпитер
0xC1 | "КОМАНДА ОПРОС" | Команда опроса передана устройству
0xC2 | "ЗАПРОС ИМИТОСТОЙКОСТИ" | ?
0xC3 | "КОМАНДА НА ПЕРВЗ." | Команда перевзятия передана устройству (не путать с ответом на команду - сообщением “ПЕРЕВЗЯТ”, которое приходит уже после выполнения команды устройством)
0xC6 | "УСТ.ЗАДЕРЖКИ" | Установка величин задержек для охранных шлейфов «Юпитер»
0xC8 | "ЗАПРОС ПАРАМЕТРОВ" | Передача команды запроса параметров устройства
0xC9 | "ЗАПРОС ТИПОВ ЛИНИИ" | Для тестирования АК-24 версии 3.4
0xCA | "ИСКЛЮЧЕНИЕ" | ?
0xCB | "ЗАПРОС ВЕРСИИ ПЗУ" | Передача на устройство команды «запрос версии».
0xCB | "ПЕРЕЗАПУСК УСТРОЙСТВА" | ?
0xCD | "НЕВЕРНЫЙ АДРЕС" | Сообщение от объекта с неверным полем адреса
0xCE | "УСТ.СОСТОЯНИЯ" | Установка нового состояния объекта
0xCF | "ИМИТОСТОЙКОСТЬ: " | ?
0xD0 | "ИМИТОСТОЙКОСТЬ (ПО ЗАПРОСУ): " | ?
0xD1 | "ОПРОС ТИПОВ ШЛЕЙФОВ" | Тестирование ППКОП-5 и ППКОП-8
0xD2 | "УСТАНОВКА ТИПОВ ШЛЕЙФОВ" | Тестирование ППКОП-5 и ППКОП-8
0xD3 | "ОПРОС ЗАДЕРЖЕК ШЛЕЙФОВ" | Тестирование ППКОП-5 и ППКОП-8
0xD4 | "УСТАНОВКА ЗАДЕРЖЕК ШЛЕЙФОВ" | Тестирование ППКОП-5 и ППКОП-8
0xD5 | "ОПРОС ШЛЕЙФОВ ГРУППЫ" | Тестирование ППКОП-5 и ППКОП-8
0xD6 | "УСТАНОВКА ШЛЕЙФОВ ГРУППЫ" | Тестирование ППКОП-5 и ППКОП-8
0xD7 | "ОПРОС СОСТОЯНИЯ ГРУППЫ" | Тестирование ППКОП-5 и ППКОП-8
0xD9 | "ОПРОС ЗАДЕРЖКИ НА ВЫХОД" | Тестирование ППКОП-5 и ППКОП-8
0xDA | "СОСТОЯНИЕ " | Тестирование ППКОП-5 и ППКОП-8
0xDB | "ПАРАМЕТРЫ" | Тестирование ППКОП-5 и ППКОП-8
0xDC | "ЗАПРОС ПАРАМЕТРОВ" | Тестирование ППКОП-5 и ППКОП-8
0xDD | "УСТАНОВКИ ПАРАМЕТРОВ" | Тестирование ППКОП-5 и ППКОП-8
0xEC | "ПАРАМЕТР" | Тестирование пртокола 3.11
0xED | "ПАРАМЕТР" | Тестирование пртокола 3.11
0xF0 | "ОШИБКА КОНТРОЛЬНОЙ СУММЫ" | Не используется, для совместимости с бета-версиями Юпитера 6.0
0xF1 | "ТАЙМЕР 20" | Не используется, для совместимости с бета-версиями Юпитера 6.0
0xF2 | "ТАЙМЕР 21" | Не используется, для совместимости с бета-версиями Юпитера 6.0
0xF3 | "ОШИБКА СВЯЗИ С БАЛТИКОЙ" | ?
0xF9 | "ОТСУТСВИЕ ОПИСАНИЕ" | При рассогласовании таблиц драйвера СПИ Юпитер и графического интерфейса. Возникает при внесении новых сообщений в устройства. При получении данного сообщения необходимо связаться с разработчиком.
0xFA | "ПОДКЛЮЧЕНИЕ АРМ" | ?
0xFB | "ОТКЛЮЧЕНИЕ АРМ" | ?
0xFC | "НЕОПОЗНАНЫЙ АРМ" | ?


Список изменений и дополнений СПИ Юпитер 6.0

14. Список изменений и дополнений СПИ Юпитер 6.0

Юпитер 6.0.31: (17.11.2003)
Исправлены проблемы с падением ППКОП-5(8). Добавлена возможность настройки цветов буфера взятия и снятия (буква "W" на клавиатуре). По-умолчанию - настройки Невы. На разрешении экрана 1024x768 увеличен шрифт настройки ручных объектов. Запоминается номер оператора, который ввел примечание. Изменение шрифта выборок КТС, ОПС, и т.д. Добавлен экспериментальный протокол для связи с КПЦО версии 3.11. Изменен порядок кнопок, добавлена возможность переназаначения клавиши "Снятия ручного оъекта" на клавишу "F9".

Юпитер 6.0.32:
При удалении ключа подтверждается его номер и остаются в карточке объекта последние 100 сообщений. Добавлена возможность перевзятия десятка УТ Центр, блокировка, разблокировка. В выборке ручных объектов, находящиеся в состоянии, не соответствующим таблице охраны помечаютя знаком "?".

Юпитер 6.0.32a:
Добавлена таблица охраны ручных в карточку объекта.

Юпитер 6.0.32b:
Иправлена внесенная ошибка с перевзятием Центра.

Юпитер 6.0.32c:
Исправлена ошибка выборки сообщений для ключей с русскими буквами.

Юпитер 6.0.32d:
Фиксируется время установки примечания. Ограничение на максимальный размер log-файла.

Юпитер 6.0.32e:
Добавлено сообщение для 5-шлейфника "Сброс памяти тревог КТС". Перевзятие АТС в карточке объекта для протокола 3.11.

Юпитер 6.0.32f:
Уменьшение задержки опроса КПЦО для протокола 3.11, если буфер команд не пустой. Обе задержки настраиваются. Перевзятие линии, добавлен RS-232 для протокола 3.11.

Юпитер 6.0.32g:
Исправлена ошибка с удалением команд протокола 3.11.

Юпитер 6.0.32h:
Исправлена ошибка с задержкой шлейфа 1 сек. Вывод отладки протокола 3.11.

Юпитер 6.0.32i:
Исправлена ошибка падения Юпитера, если в Балтике дежурный не принял во-время тревогу. Добавлено сообщение для Центра "Тревога (Подмена)". Отработка квитанции "Номер версии" КПЦО. Установка времени "Уехали до ..." для ручных объектов.

Юпитер 6.0.32k:
Исправлена ошибка с различным топом взятия ключа в ленте и в состоянии объекта. Порядок перевзятия УОО-5 как и до 6 июня 2003 г.

Юпитер 6.0.32m:
Добавлена выборка по глухим ключам. Исправлена ошибка с кэшированием wav файлов.

Юпитер 6.0.32n:
Исправлено: ё->Ё (карточка объекта\хозорганы) Балтика - все тревоги, которые не принял офицер. Если в карточке объекта нет фокуса ввода и приходит сообщение от этого объекта - прокрутка ленты. Из выборок неснятых во-время с охраны объектов и не поставленных во-время на охрану исключены заблокированные объекты.

Юпитер 6.0.32p: (11.12.2003)
Имитостойкость Центра: В команде A3 посылается код имитостойкости, по сообщению 81 запоминается.

Юпитер 6.0.33: (18.12.2003)
По Shift+F3 не сбрасывается окно ввода пароля по Esc.

Юпитер 6.0.33: (28.12.2003)
При закрытии пульта - номер оператора. Смена дежурных - как в DOS - версии. Резервное копирование каталогов \kpcoX

Юпитер 6.0.33a: (16.12.2003)
Настройка скорости общения и тайм-аутов по протоколу 3.11. В протокол отладки добавлена дата. Добавлено сообщение "Невзятие (КТС)". Включен в панели объектов ППКОП. Добавлено сообщение "Потеря аккум. (З)".

Юпитер 6.0.33b: (02.02.2004)
Исправлена ошибка с перезапуском драйвера протокола 3.11. Добавлена дата в протокол отладки.

Юпитер 6.0.33c: (02.02.2004)
Исправлена ошибка с перезапуском драйвера протокола 3.11. В Центре анализируется посылка 0xED. Исправлена ошибка с сообщением Центра 0x46.

Юпитер 6.0.33e: (07.02.2004)
Переписан вывод звука под Windows NT/2K/XP

Юпитер 6.0.33f: (11.02.2004)
Добавлена обработка сообщений (Струна):

  • "ОБЪЕКТ:XXX ВКЛЮЧЕН",
  • "КАНАЛ:XXX ВКЛЮЧЕН",
  • "СН+РЕЗ" Убрано из настроек - "Выводить код имитостойкости".

    Юпитер 6.0.33g: (12.02.2004)
    Редактирование из клиента таблицы цветов сообщений. Исправлена ошибка с выводом 2 тревоги под Windows NT/2K/XP. Добавлена обработка Струны сигнала состояния "Авария".

    Юпитер 6.0.34b (18.02.2004)
    Исправлена ошибка при удалении хозоргана, который последний ставил-снимал ручной объект с охраны. Клиент позволяет редактировать все таблицы и настройки Балтики.

    Юпитер 6.0.34c (19.02.2004)
    Реализована выборка по глухим ГК Комета.

    Юпитер 6.0.34d (24.02.2004)
    Исправлено отображение шлейфов заблокированного ИО Юпитер и УОО.

    Юпитер 6.0.34e (26.02.2004)
    Ускорена отрисовка в клиенте панели АТС и УТ.

    Юпитер 6.0.34d (27.02.2004)
    Ускорена отрисовка в клиенте панели ИО и Центра. Исправлена проблема с запуском КПЦО на Pentium-4. Для УОО введена команда "Сброс блока". Исправлена ошибка с добавлением УТ (ошибка создания файла), если тип УТ был отличен от добавляемого - переименовываем старый в bak и переписываем файл.

    Юпитер 6.0.34e (27.02.2004)
    Исправлены внесенные в 6.0.34d версию ошибки с отработкой перемещения по стрелкам (сброс тревоги и выборки). Установка причин тревог на перехваченом АРМ. Ускорена индексация файла последних сообщений объекта.

    Юпитер 6.0.34f (03.03.2004)
    Перехват. Создание DSN при загрузке.

    Юпитер 6.0.34g (03.03.2004)
    Оптимизация выборки объектов.

    Юпитер 6.0.34k (11.03.2004)
    Исправлена ошибка с падением панели на разрешении 800x600. Правильно отрабатываются сообщения: Верхний и Нижний предел для УОО-3. Сброс проверки КТС в 8 часов.

    Юпитер 6.0.34m (14.03.2004)
    Исправлен баг с отрисовкой ответчиков в карточке объектов.

    Юпитер 6.0.35 (17.03.2004)
    Исправлена ошибка с тревогой комбинированных ключей, если в таблице охраны указанно - ОПС без снятия. Исправлен внесенный баг с выборкой номеров версий. Комнаты хранения оружия работают на Юпитере. Исправлена проблема с выборками по ГК и ответчикам Юпитер. Изменено время сброса тревоги. Исправлена внесенная ошибка со сбросом тревоги.

    Юпитер 6.0.35b (22.03.2004)
    Исправлена ошибка с опросом ручных объектов

    Юпитер 6.0.35c (28.03.2004)
    Реализован протокол 3.11 с упаковкой КПЦО. Удаление и добавление разделов в ПОИСке, ограничение - одна группа.

    Юпитер 6.0.35h (07.04.2004)
    Исправлена ошибка с кэшированием первого сообщения. Настройка ПОИСка как с прибора, так и с интерфейса.

    Юпитер 6.0.35p (07.04.2004)
    Убрана опция "Драйвер для быстрого компьютера". Теперь она постоянно включена для драйвера VxD.

    Юпитер 6.0.35r (22.04.2004)
    При появлении связи с КПЦО добавлено сообщение "Восстановление КПЦО". Исправлена обработка сообщения: "Изменение времени охраны". Сообщение: IDM_FILE_EXIT заменено на WM_CLOSE.

    Юпитер 6.0.36
    Выборки во весь экран. Сброс флага резервное питаное при запуске, исправлен звук на клиенте.

    Юпитер 6.0.36b
    Ускоренна выборка тревог за месяц.

    Юпитер 6.0.36c
    Устанено зависание выборки тревог и сообщений при разных файлах arm.ini на клиенте и сервере. "Изменение шлейфа" выводится с номером шлейфа. Удаление 5- и 8- шлейфника из панели направлений (для совместимости с отладочными версиями). В Струне "Саботаж" заменен на "Взлом". Реализован запуск Внешней программы. Меню команд у ППКОП-5 одинаково с ППКОП-8.

    Юпитер 6.0.36f:
    Введено сообщение: "Неисправность по запросу". "F0" у Струны нормально отрабатывается.

    Юпитер 6.0.36h:
    Отображение в карточке ручных объектов времени: "Уехали до ...".


Параметры Коммуникационного Модуля (КМ)

4.3.3.6.1 Параметры Коммуникационного Модуля (КМ).

При выборе настройки параметров КМ открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.

Также можно просмотреть идентификатор устройства, полученный в результате выполнения команды опроса идентификатора (см. описание команд).


Параметры ППКОП-8

4.3.3.6.2 Параметры ППКОП-8.

При выборе настройки параметров ППКОП-8 открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая, будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.

Также можно просмотреть идентификатор устройства, полученный в результате выполнения команды опроса идентификатора (см. описание команд).

Кроме того, для ППКОП-8П, возможно произвести настройку параметров работы каждого шлейфа (см.ниже).


Параметры ППКОП-5

4.3.3.6.3 Параметры ППКОП-5.

При выборе настройки параметров ППКОП-5 открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая, будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.


Параметры УВС-5П

4.3.3.6.4 Параметры УВС-5П.

При выборе настройки параметров УВС-5П открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая, будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.


Параметры Пульта Управления (ПУ).

4.3.3.6.5 Параметры Пульта Управления (ПУ).

При выборе настройки параметров Параметры Пульта Управления (ПУ). открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.

Также можно просмотреть идентификатор устройства, полученный в результате выполнения команды опроса идентификатора (см. описание команд).

Кроме того, для ПУ, возможно произвести настройку дополнительных параметров работы:

Звук:

при нажатии на клавишу | Нажатия клавиш сопровождаются звуком.
при Взятии/Снятии | Выполнение операции взятия/снятия раздела на/с охраны сопровождается звуком, напоминающим о необходимости снять раздел (при снятии с охраны) или отмечающим интервал времени до выхода (при взятии на охрану).

Привязка:

Задается раздел, состояние которого будет отображаться на светодиодных индикаторах «пожар/неисправность/тревога/взят/снят/питание» ПУ.


Параметры Расширителя Реле-2

4.3.3.6.6 Параметры Расширителя Реле-2

При выборе настройки параметров РР-2 открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая, будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.

Также можно просмотреть идентификатор устройства, полученный в результате выполнения команды опроса идентификатора (см. описание команд).

Кроме того, для РР-2, возможно произвести настройку дополнительных параметров работы:

Режим работы:

В таблице задается режим работы для каждого реле расширителя. При выборе реле (нажатие Enter или двойное нажатие левой кнопки мыши) отображается диалог, позволяющий выбрать требуемые параметры работы:

Может быть задан один из следующих режимов:

Не определен | реле не задействовано.
Раздел - сирена | реле управляет работой сирены. При переходе заданного раздела в состояние отличное от нормы (тревога, неисправность, пожар) сирена включается. Также задается время, в секундах, по истечении которого, сирена будет выключена.
Раздел – выносная индикация | реле управляет работой выносного индикатора. При переходе заданного раздела в состояние отличное от нормы (тревога, неисправность, пожар) индикатор будет активирован.
Раздел – вкл.-выкл | реле управляет работой исполнительного механизма. В нормальном состоянии реле замкнуто. При переходе заданного раздела в состояние отличное от нормы (тревога, неисправность, пожар) реле будет разомкнуто на заданный интервал времени.
Раздел – выкл.-вкл | реле управляет работой исполнительного механизма. В нормальном состоянии реле разомкнуто. При переходе заданного раздела в состояние отличное от нормы (тревога, неисправность, пожар) реле будет замкнуто на заданный интервал времени.
Раздел – пожарная автоматика | реле управляет работой пожарной автоматики. В нормальном состоянии реле разомкнуто. При формировании по заданному разделу сообщения «ПОЖАР» (срабатывания пожарного шлейфа) реле будет замкнуто ЧЕРЕЗ заданный интервал времени с момента срабатывания.
Событие – выкл.-вкл | реле управляет работой исполнительного механизма (дверного замка). В нормальном состоянии реле разомкнуто. При вводе для выбранного раздела события (нажатие специальной клавиши на ПУ или УВС, привязанного к заданному разделу) реле будет замкнуто на заданный интервал времени.
Событие – выкл.-вкл | реле управляет работой исполнительного механизма (дверного замка). В нормальном состоянии реле замкнуто. При вводе для выбранного раздела события (нажатие специальной клавиши на ПУ или УВС, привязанного к заданному разделу) реле будет разомкнуто на заданный интервал времени.

Два последних режима позволяют использовать расширитель реле в сочетании с ПУ или УВС, имеющего привязку к конкретному разделу, в качестве кодовой клавиатуры для управления электромагнитным/электромеханическим замком.

Раздел:

Определяет раздел для тех режимов работы реле, которые связаны с изменением состояния разделов.

Задержка:

Определяет задержку для тех режимов, где она предусмотрена.


Параметры Расширителя Индикации.

4.3.3.6.7 Параметры Расширителя Индикации.

При выборе настройки параметров РИ-8 открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в тексте примечания.

Также можно просмотреть идентификатор устройства, полученный в результате выполнения команды опроса идентификатора (см. описание команд).

Кроме того, для РИ, возможно произвести настройку дополнительных параметров работы:

Режим работы:

Не определен | индикаторы не задействованы
индивидуальный | режим работы каждого индикатора определяется индивидуально в таблице «Индивидуальный режим работы»
состояние раздела | все индикаторы отображают текущее состояние раздела, заданного в параметре «Привязка»
состояние ШС | индикаторы отображают состояние шлейфов раздела, заданного в параметре «Привязка»

Таблица индивидуальных режимов работы:

В таблице задается режим работы для каждого индикатора. При выборе индикатора (нажатие Enter или двойное нажатие левой кнопки мыши) отображается диалог, позволяющий выбрать требуемые параметры работы:

Может быть задан один из следующих режимов работы индикатора:

Не определен: | индикатор не задействован.
Состояние раздела: | индикатор отображает состояние выбранного раздела
Состояние шлейфа: | индикатор отображает состояние выбранного шлейфа на заданном расширителе.

Привязка:

Задается раздел, состояние которого, или его шлейфов, будет отображаться на светодиодных индикаторах РИ в режимах работы «Состояние раздела» или «Состояние ШС», соответственно.


Параметры УВС-8П и УВС-16

4.3.3.6.8 Параметры УВС-8П и УВС-16

При выборе настройки параметров УВС открывается диалог следующего вида:

В данном диалоге можно задать строку примечания, которая будет отображаться в карточке расширителя, и номер оператора, который внес последние изменения в текст примечания.

Также можно просмотреть идентификатор устройства, полученный в результате выполнения команды опроса идентификатора (см. описание команд).

Кроме того, для УВС, возможно произвести настройку дополнительных параметров работы:

Режим работы:

не определен | индикаторы состояния разделов/шлейфов не задействованы
индивидуальный | режим работы каждого индикатора определяется индивидуально в таблице «Индивидуальный режим работы»
состояние раздела | все индикаторы отображают текущее состояние раздела, заданного в параметре «Привязка»
состояние ШС | индикаторы отображают состояние шлейфов раздела, заданного в параметре «Привязка»

Привязка:

Задается раздел, состояние которого будет отображаться на светодиодных индикаторах «пожар/неисправность/тревога/взят/снят/питание» УВС-16.

Звук:

при нажатии на клавишу | Нажатия клавиш сопровождаются звуком.
при Взятии/Снятии | Выполнение операции взятия/снятия раздела на/с охраны сопровождается звуком, напоминающим о необходимости снять раздел (при снятии с охраны) или отмечающим интервал времени до выхода (при взятии на охрану).

Таблица индивидуальных режимов работы:

В таблице задается режим работы для каждого индикатора. При выборе индикатора (нажатие Enter или двойное нажатие левой кнопки мыши) отображается диалог, позволяющий выбрать требуемые параметры работы:

Может быть задан один из следующих режимов:

Звук:

Не определен | индикатор не задействован
Состояние раздела | индикатор отображает состояние выбранного раздела
Состояние шлейфа | индикатор отображает состояние выбранного шлейфа на заданном расширителе.


Введение

1. Введение

Данное руководство содержит сведения о составе и функционировании автоматизированной системы централизованного наблюдения (далее АСЦН) Юпитер.

Руководство предназначено для широкого круга пользователей АСЦН Юпитер. Дежурным пульта необходим раздел посвященный интерфейсной программе и рекомендуется ознакомиться с пунктом "Общие сведения о функционировании системы". Разделы касающиеся установки и настройки ПО необходимы только инженеру пульта.


Изменение конфигурации устройств

4. Изменение конфигурации устройств

Рассмотрим операции с конфигурацией устройств по их уровню в системе. Ввод конфигурации устройств необходимо проводить в том порядке, в каком они описаны далее - начиная с линии КПЦО и заканчивая ответчиками АК.

  • 4.1. Операции с линией КПЦО ("АТС")
  • 4.2. Операции с УТ
  • 4.3. Операции с конфигурацией устройств АК
    • 4.3.1. Конфигурация АК Комета
      • 4.3.1.1. Конфигурация ГК Комета
      • 4.3.1.2. Конфигурация ИО Комета
    • 4.3.2. Конфигурация АК Центр и Атлас (-)
    • 4.3.3. Конфигурация АК Юпитер (-----)
      • 4.3.3.1 Настройка шлейфов
      • 4.3.3.2 Настройка брелков
      • 4.3.3.3 Особенности АК Юпитер, связанные с настройками